Skip navigation

Lion Mail and Worthless/Failing Searches

29347 Views 83 Replies Latest reply: Jun 28, 2013 10:42 AM by Fritz Lang1 RSS
  • RMunz Calculating status...
    Currently Being Moderated
    Jan 23, 2012 3:33 PM (in response to Alan Hirshberg)

    I got it working with your suggestion. None of the previous ones were working for me.

     

    Fresh install OSX 10.7.2 on a MBP 7,1 2.4GHz.

     

    Thanks a lot!

  • DDRSII Calculating status...
    Currently Being Moderated
    Jan 28, 2012 4:41 AM (in response to xmetal280)

    I was having the same problem until I put all my hard drives into the 'Privacy' panel for Spotlight, closed the preferences, then opened it back up and took my drives out of the Privacy. Spotlight reindexed everything just like stated above.

     

    This works great thank you. Mail search is once again a valuable tool.

  • eve728392 Calculating status...
    Currently Being Moderated
    Jan 31, 2012 6:49 AM (in response to DDRSII)

    I've tried the put drives into "Privacy" and take them out and now waiting for it to "reindex." I'd just like to note that not only does search in mail not work *at all*, but even more productivity-destroying, Finder search does not work! I have several crucial documents which have not been properly sorted into folders, and now they are completely inaccessible to me until I get this working again.

     

    Given that this problem has been an issue for some folks since July, I'm pretty surprised it has not yet been fixed with an update, or that folks at Genius bars seem not to be aware of the problem (which, quite frankly, is usually the case; I've gone many times with problems that were widespread, but have always been treated as though they were individual, and have often gotten not much more than an "aw shucks" until the next update comes out which mysteriously fixes the problem, as though they are not keen on acknowledging that a more general problem when it exists if they haven't had occasion to fix it yet).

     

    I just feel like when you pay money for an upgrade which you are *forced* to make in order to continue using your other devices/products properly, it should work out of the box--else you should get a refund!

     

    Seriously distressing.

  • mrc3 Calculating status...
    Currently Being Moderated
    Feb 3, 2012 5:38 AM (in response to xmetal280)

    I find two things disturbing.  First, the various steps outlined in this thread work for some, but not others.  That tell's me we don't know the root cause.  Second, there have been lots of these little glitches in Lion.  Very un-Mac-like.

     

    I turned of Spotlight becuase I don't use it (and I thought I didnt' need it) and it's a bit of a pig.  I had no idea Mail search would stop working.  Not nice.

  • daytrader Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 21, 2012 9:34 AM (in response to daytrader)

    Well, somehow whatever I did on Jan 10 worked, but it took a long time to work.  On Jan 14 (when I posted again in here asking for help) it did not work for sure. Sometime after Jan 14, it started working on its own, without me doing anything else.

     

    Go figure...

  • James Nachbar Calculating status...
    Currently Being Moderated
    Feb 21, 2012 12:48 PM (in response to mrc3)

    I tried rebuilding my mailboxes, and that worked for a while, but it stopped working again.

     

    I have gone to using Thunderbird for searching my mailbox, although Thunderbird does not do a good job of flagging mail from correspondents, so I still use Mail for other email client functions.

  • BvE Calculating status...
    Currently Being Moderated
    Mar 9, 2012 4:47 AM (in response to xmetal280)

    Dear all

    yes, I am having these same problems with search.  The search 'help' response claims you can specify the 'from' 'to' etc. using the 'arrow' but this does not appear.  You only get a 'from' lable when you put in a contact already in your address book, but it is impossible in my case to get 'from' to stay so as to execute a search from someone not already listed.  I am so frustrated with Lion which gives me never-before problems with Apple.  Amongst these are:

    - computer doesn't remember my preferences on restart (e.g. not wanting to use password or making my additional cinema screen the main stream

    - programmes like word occassionally freeze going into spinning disk mode

    - yesterday word simply wouldn't open files that were in the finder, only allowing them to be read when moved to the desktop; Word also claimed not to be able to save because too many windows were open, when only one was open. 

    My family now have two powerbooks running Lion and they have similar problems.  I also know others who have had them so claims that the problems come from transferred preferences from my old powerbook running the wonderful Snowleapard are wrong.

    I really hope that, given their stunning profits, Apple put some money into solving these problems in upgrades asap.

  • Matthew Rumbelow Calculating status...
    Currently Being Moderated
    Mar 15, 2012 2:32 AM (in response to xmetal280)

    Yep, re-indexing the entire hard drive via the Spotlight system prefs is the solution.

     

    Spotlight found emails with certain search criteria, but Mail didn't (well, beyond the date of my Lion upgrade anyway). 

     

    Go to System Preferences, then Spotlight, click on the Privacy tab, click the + to add the entire Macintosh HD to the list of "Prevent spotlight from searching these locations" and then remove the Macintosh HD by clicking the - button. Spotlight will re-index the entire drive - it will take some time, but it works.

  • Siddharth Khanna Calculating status...
    Currently Being Moderated
    Mar 15, 2012 3:25 AM (in response to xmetal280)

    Try restarting your lion Mail..i Mean REINSTALLING the mail..Guess That Will hepl you..

  • Steady Ed Calculating status...
    Currently Being Moderated
    Mar 19, 2012 9:40 AM (in response to xmetal280)

    Downloading and running "OnyX for Lion" mentioned in an earlier post solved the problem forme

  • aayush.agarwala Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 20, 2012 5:00 AM (in response to xmetal280)

    I was experiencing similar problems with my Macbook Pro. I tried most of the solutions recommended aboce but to no avail. The search word was just not returning resulsts from the body of the mails. I finally disabled my Gmail account on Apple Mail and enabled it again. That worked for me.

  • remkofromnl Calculating status...
    Currently Being Moderated
    Apr 28, 2012 10:51 PM (in response to daytrader)

    Hey Daytrader,

     

    I do not know if you have solved it by now, but I had exactly your issues and couldn't fix it be all proposed solutions.

    I did all your steps, but I think the issue lies in the fonts caches. Because when I did following suddenly it worked:

    • In OnyX I cleaned Font caches (again) but now I manually selected the Fonts under System and Users + Adobe + Microsoft Corp
    • Afther this I ran OnyX Maintenance -> Rebuild and selected Launch Services + Spotlight index + Mail Envelope Index
    • In Mail I did a rebuild of all mailboxes (I do not know it this is really necessary but better save than sorry).

     

    Then.... it worked!

     

    To be honest I think the search issue was triggered after an Microsoft Office update. So again it is Microsoft's fault......

  • Satchmo Level 4 Level 4 (1,245 points)
    Currently Being Moderated
    Apr 29, 2012 2:51 AM (in response to remkofromnl)

    remkofromnl wrote:

     

    To be honest I think the search issue was triggered after an Microsoft Office update. So again it is Microsoft's fault......

     

    I haven't had any Microsoft products installed, so that doesn't fly.

  • AZLoco Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 16, 2012 7:57 PM (in response to brianwilson71)

    I've tried all of the suggestions on this thread thus far, including enabling Locate via Terminal which is off in Lion by default, some type of Security hazard/restricting (blah, blah, blah for home users).  Nada, nothing, zilch got me squat.  I've even reinstalled Lion over Lion.  I'm on Lion 10.7.4 and an avid die hard Apple fan to the core and a .Mac/MobileMe/iCloud user.  All my stuff is synced with Apple.  So imagine the pain, frustration and fn headaches.  Mail wouldn't find my name, my Apple ID user name, nothing.....  So I tried and tried, rebuilt this rebuilt that, used Onyx, used MacPilot, used ACLr8, Disk Utility, Snow Leopard install disk utility from boot, resetting ACL's.  Finally a trio of commands worked for me. 

     

    Close the Mail application first before any of this, even better close all open applications except terminal until finished with these commands.

     

    1.  Open terminal and use this, it will ask you to authenticate:  sudo mdutil -E /

    2.  Then at the next command prompt enter this, it will ask you to authenticate:  sudo mdutil -i on /Users

    3.  Open up System Preferences and go to Spotlight.  Under "Search Results" mark all the boxes if not marked already and then drag "Messages & Chats" to the top so that it is first.  If it's already first I guess you can try to drop it to second and that might work.  It wasn't first for me but I drug it there anyways.  Then close System Preferences.

     

    Now close/exit Terminal and then open up Mail.  If you were as lucky as me and typed in a search term you know there is a cr*p load of, then you should be smiling at all the results like I did.  I can't believe that I was almost so desperate that I almost said out loud that I would start using Outlook 2011 for Mac and HoudahSpot if this didn't work.  Those are some serious words to say out loud, at least for me.

     

    Good luck and God I hope this helps another down-trodden, beat up Apple Lion user like myself, who happens to have 80,000+ e-mails stored since 2002 using Mail.

  • Alan Hirshberg Calculating status...
    Currently Being Moderated
    May 16, 2012 8:08 PM (in response to AZLoco)

    Having problem with the second command:

     

    Alans-MacBook-Pro-2:~ alanrh$ sudo mdutil -i on /Users

    /Users:

    Error: invalid operation.

              No index.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (7)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.