9 Replies Latest reply: Feb 5, 2012 12:10 AM by Marcel Burkart-Huber
Marcel Burkart-Huber Level 1 Level 1 (25 points)

Since i updated our clients to 3.5.2, i can't access some of them anymore ("connection to ??? failed"). They are running os 10.7.2 others 10.7.3. Access to clients with 10.6.8 is still ok. Anyone else with this problem?

  • 1. Re: No more access to 3.5.2-clients
    TeenTitan Level 4 Level 4 (2,410 points)

    Have you tried connecting to the client using the finder instead of ARD?

     

    ie:

    go to dock

    click on finder

    go to menu bar

    click on go menu

    chose connect to server

    put in the address vnc://computerName.local

    click connect.

     

    Alertively can you ssh into the client?

  • 2. Re: No more access to 3.5.2-clients
    Marcel Burkart-Huber Level 1 Level 1 (25 points)

    I tried with the vnc-command, but failed. Probably because I'm not at the local network but on wlan via ipsec?

    how do I use the ssh-command?

     

    Further Info:

    I have no more screen access to those clients from the local network and via WLAN. But I still have access to all reports of the clients. Very strange.

  • 3. Re: No more access to 3.5.2-clients
    TeenTitan Level 4 Level 4 (2,410 points)

    are the clients on the same WLAN? Do you know the IP of one of the effected clients? can you ping it?

     

    ie:

    go to dock

    click on finder

    click on go menu

    chose utilites

    double click on terminal

    type 'ping (put computer IP address here)'

     

    if ping works, you could try connecting via connect to server or via SSH

     

    SSH would be:

    while terminal is still open

    ssh loginName@(put computer IP address here)

    if you can connect, do you get the correct computer name?

  • 4. Re: No more access to 3.5.2-clients
    Marcel Burkart-Huber Level 1 Level 1 (25 points)

    Yes ping works and also ssh. I can connect and I get the correct computer name.

     

    For your Info:

    I'm at home and connect to our office-network via ipsec. Our office-network is a LAN-Network and there are those clients.

  • 5. Re: No more access to 3.5.2-clients
    TeenTitan Level 4 Level 4 (2,410 points)

    Ok so

     

    if you SSH into the client , and use the command "tail -F /var/log/secure.log"  to view the secure log. While viewing the secure log, you could try to connect to the client via VNC.

     

    IE: vnc://user@(ip address) ,  vnc://user:password@(ip address)  and vnc://(ip address) ? (using the go menu)

     

    Your attempts to connect should show up in secure.log and may give us some insite into the issue.

  • 6. Re: No more access to 3.5.2-clients
    Marcel Burkart-Huber Level 1 Level 1 (25 points)

    While viewing the secure log, I tried all three vnc-logins, but nothing happened. I wasn't able to connect and I saw no reaction in the secure log.

     

    Was it correct to try the vnc-command in the 'go menu' under 'connect to server'?

  • 7. Re: No more access to 3.5.2-clients
    TeenTitan Level 4 Level 4 (2,410 points)

    Well if it was reaching ARDAgent on clent computer, you should be seeing some thing in the secure log.

     

    Have you cehcked to make sure the firewall is off on both computers?

     

    Have you checked to make sure Remote Management is enabled on the client?

     

    Apple Remote Desktop: Configuring remotely via command line (kickstart):

     

    You need an administrator account to use the kickstart utility. To begin using the kickstart utility, use the sudo command, such as:

    $ sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -restart -agent

     

    Activate Remote Desktop Sharing, enable access privileges for the users "admin", grant full privileges for the users "admin", restart ARD Agent and Menu extra:

    $ sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -on -users admin -privs -all -restart -agent -menu

     

    You could ssh try rebooting ARDAgent

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -restart -agent

     

    Or make sure ARDAgent is enabled with

    sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -on

  • 8. Re: No more access to 3.5.2-clients
    Marcel Burkart-Huber Level 1 Level 1 (25 points)

    I retried the thing with the console log, but still there is no reaction.

     

    I can't understand, why I see the client on my ARD as 'idle' or 'available' and why I still can get all reports etc. but have no access to the screen anymore. I used this function almost daily and never had any problems with it, regardless if i was on the lan in the office or via ipsec from home. I made no changes, remote management is still active. Since ARD-Client 3.5.2, I can't 'screen-access' any 10.7.2- or 10.7.3-clients, but still all 10.6.8-clients. And all the other ARD-commands are still working (report, manage,...).

     

    I tried the command 'wake up' and the status changes from 'idle' to 'available' and in the log-file there now ist the following entry: 'Feb  5 08:58:18 Marcels-MacPro3GHz loginwindow[4604]: resume called when there was already a timer'.

  • 9. Re: No more access to 3.5.2-clients
    Marcel Burkart-Huber Level 1 Level 1 (25 points)

    I can't believe it, but after I did 'sudo /System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/Resources/k ickstart -activate -configure -access -on', screen-access is back!

     

    TeenTitan, thank you very very much!

     

    Sincerely

    Marcel Burkart