1 2 3 4 5 Previous Next 366 Replies Latest reply: Jan 31, 2014 2:45 PM by polgriz Go to original post Branched to a new discussion.
  • 30. Re: Unable to purchase.
    kingmajong Level 1 Level 1 (0 points)

    I have the same problem...it seems the problem started after I put in the credit card NO. to the free -Apple ID.

     

    At first I was using  ID for free downlaod app ( no input credit NO.)   that period  I just click on buy app ( paid app) to see what will happen.....  ( sure it didn't let me download cause I didn't credit NO.)

     

       at last...oneday I decided to buy a paid app....so I update the same old APPLE ID   with my credit card NO.

    After that I got error message...  " the app xxxx    unable to purchase this time..."  

     

      Well...it 's the name of paid  app I click to test to downlaod (while no credit card)   ...:(  I didn't really want to buy it...  but it still randomly pop up when I try  download any new app.

     

       More over....  I got another error...    there's an free app I try to download  ...and I  stop process before it complete.  SO  when the error meesage pop up....   the error download icon is show up in my ihpone too! and I can't delete it ....it's the icon app..showing in   " waiting " stage.     I just have to  open another app or download new app to make it disappear.    but It can comeback again !

     

        Finally I try new way...hope it works permanetly.

     

    I open  Itune on PC. conenct to iphone. 

     

    - go to iTune store > log in APPLE account > choose your account -name on top right. > click it and put in password again

     

    -  You will go to Account information page...look down and you will see tab " reset warning all buying and download item"

     

    click it and sync iphone again...

     

      I think the problem is gone now...but  have to try again tomorrow if this will permanently work....

     

      please try my way and tell me how is it....

  • 31. Re: Unable to purchase.
    Mac OS XP Level 1 Level 1 (75 points)

    The reset warnings button I think only should make it so old warnings that you dismissed will show again. But hey, if you keep downloading apps without the message, let us know!

  • 32. Re: Unable to purchase.
    kingmajong Level 1 Level 1 (0 points)

      Oh no     it seems  reset all warning,,,       didn't work.  I notice that when I downlaod game...the error message will more likely to  show up.

     

       maybe the error is relate to app -game and app book ? 

  • 33. Re: Unable to purchase.
    kemajor Level 1 Level 1 (0 points)

    Just adding my two cents...  Same issue on both my iPad 2 and iPhone 4S.

     

    I've tried every suggested solution and then some but still get the errors.

     

    I think I'll call and use my AppleCare and see what they say.  Although I suspect it will be the same old story...

     

    1) Backup and then do a complete restore of your devices and see if that works.

    2) Completely reset your devices and re-install all of your apps from scratch.

     

    Those seem to be the "solution" to every issue I've ever called about.

     

    Number 1 has never solved an issue for me and number two would take some much time and effort I would rather just throw my iThings away and replace them with other products.  I literally have 500+ apps.  Re-installing and reconfiguring, settings up, etc of them on just one device would take a crazy amount of time in total hours and would have to be done over a period of two weeks or so.

     

    Just typing this knowing it is what I'm likely to hear is raising my BP so much I think I'll skip calling.

     

    If I come up with anything I'll post back.

     

    - KEM

  • 34. Re: Unable to purchase.
    JustinR Level 5 Level 5 (4,475 points)

    Same problem for me, too. iPhone 4S iOS 5.0.1.

     

    None of the previous tips resolved it. 

  • 35. Re: Unable to purchase.
    dat2 Level 1 Level 1 (0 points)

    same problem here.

     

    ipad2 model#MC770LL

    w/ ios 5.01

     

    download anything from app store and get a message saying "can not download this and 8 other apps at this time"...

     

    at this point several things can happen...

     

    1. the app downloads fine.

    2. or the app gets stuck on waiting forever.

     

    i have tried all things mentioned, nothing works as a solution yet. i am inclined to think this is an apple server error?

     

    then to make it stranger...

     

    last night i downloaded 2 apps from purchased list "not on this ipad" that my wife uses... i get the usual error mentioned above but the apps download. so i stick them in her apps folder and today bought an app for myself. i get the "can not download this and 8 other apps at this time" error but the app downloads AND my ipad2 REDOWNLOADS the 2 apps from the night before, which were already installed.

     

    very frusturating behavior... anybody with a fix yet?

     

    thanks.

     

    d

  • 36. Re: Unable to purchase.
    CrewJackets Level 1 Level 1 (0 points)

    I've had the same message appear randomly during purchases for about a week now too.  I think it has got to be a bug within the iTunes account server.  At first I was worried that I was being charged multiple times for the same app(s).  I haven't seen any evidence that might suggest a duplicate charge issue, so the erratic message is more annoying than anything else.

     

    I am glad to hear there are many users with this issue.  The timeframe seems to be the same for everyone who has chimed in so far.  If resetting and restoring don't seem to be working, it seems even more likely that it's a glitch on the iTunes server end. 

     

    Hopefully Apple will scope it out and fix it.  Although, this could serve as a fun competition to see how high one of us can run up the "and __ other apps" number before it gets resolved.  Mine is currently at 5.

  • 37. Re: Unable to purchase.
    kingmajong Level 1 Level 1 (0 points)

        some minor update... 

     

        I think  the tip.... reset all warning and downloadling history  help me a bit,,,at  least it stop the  error downloading- icon of the bad app I have deleted it.    It doesn't show again when the error message " unable to purchase" pop up.  

     

       even though I try to buy one paid app. ....  the buying is successful...but the " unable to purchase " error message of the past app  still pop up ramdomly...:(

     

       Can anyone tell this to app store?

     

          Is there anyway to delete the error file that making this annoying message?:(

  • 38. Re: Unable to purchase.
    AndreXuxu Level 1 Level 1 (0 points)

    Hello again everybody,

     

    My final update on this issue and how I eliminated it. As I posted, disabling Restrictions greatly decreased the frequency of the error on my iPad but did not permanently fix it.

    So I ran out of patience and decided to bite the bullet and go for kemajor's "Solution 2”, which of course is not really a fix but a ‘let’s commit suicide and start a whole new life all over again.’

    So far it seems to be working.

    If you decide to do this, here’s a more detailed checklist of how I did it on my iPad (iPhone is exactly the same):

     

    1. Disable Restrictions (I had it on).
    2. Do a complete iTunes PC sync, making sure everything I care for is checked: music, apps, books, etc.
    3. Go over each and every folder and app on my iPad, actually writing down the names and content of each folder, so I remember to put everything back where it belongs.
    4. As I go over each app, I also check to see if it has any personal information or files that I need to backup, sync or somehow save for later restoration. Hint: after losing all my data too many times, I keep all such apps grouped together in a folder I call My Stuff. This includes, in my case, a note taking app, a pdf reader and file manager, a password manager, and an audio memo app. Save or sync all this stuff.
    5. In my case (I don’t know if I’m doing something wrong) iTunes does not back up photos taken with the device’s camera. So I uploaded these to my cloud service.
    6. THIS NEXT STEP TOTALLY AND IRREVERSIBLY DELETES EVERYTHING ON THE DEVICE. Go to Settings -> General -> Reset -> Erase All Content and Settings. Confirm as requested and everything, including whatever was causing the bug, is gone.
    7. Now start life all over again. Reconfigure my account, email, sync  iTunes, restore all files, etc., etc.

    Note that on the last step, I disregarded any iCloud and iTunes backup for this device, as I assumed that whatever that was causing the bug could have been saved with the backup.

     

    Hopefully someone more patient will come up with a far better and less painful solution.

     

    BTW, I suspect that this bug, in my case, was created by Apple at the request of my wife, who always complains that I spend too much money in the App Store buying all those enticing apps. Perhaps she was right after all.

  • 39. Re: Unable to purchase.
    ryanpetris Level 1 Level 1 (5 points)

    That is simply an unacceptable solution, though, especially when you have more than a few apps to reinstall. For example, I have over 500 apps on my iPad, and reorganizing those from scratch would take a very long time. A simpler solution should be something along the lines of Apple allowing us to delete any data that the AppSore app is storing, like how you can with any other app in Settings > General > Usage.

     

    Also, this bug reappeared for me too, but I am willing to live with having to press "OK" sometimes when updating apps if it means that I don't have to reset, reorganize, and otherwise start from scratch with everything. Hopefully Apple has a fix for it sometime in the not-so-distant future.

  • 40. Re: Unable to purchase.
    AndreXuxu Level 1 Level 1 (0 points)

    I couldn't agree more. In my case I ended up reinstalling about 100 of the 220+ apps that I had. Getting all my stuff back into the iPad took many hours spread over 3 days.

  • 41. Re: Unable to purchase.
    kingmajong Level 1 Level 1 (0 points)

      Well....Your solution may be effective...but it 's too much task to do.

     

    It as same as restore iphone as new device again!

     

      

      More over...I think this problem can   come again someday soon ...because   whenever your download process go wrong ..the same error would come back again ... right ? While APPLE store  dosen't solve this error yet.

     

      SO we need a more simple tip to correct this error whenever it happen.  ( now we can  only click ok...and ignor it  ,,,YES!!! ???) 

  • 42. Re: Unable to purchase.
    AndreXuxu Level 1 Level 1 (0 points)

    My best guess is that there was some temporary glitch with App Store that affected everyone of us at around the same day and time. Possibly we all downloaded close to the same time and some bugged data was created locally on our devices.

     

    I say this because (1) the problem has not returned on my iPad after the full erase and reset, even after many downloads, and (2) the problem has not affected my other iDevices on which I haven't downloaded in a while.

     

    So, to answer your comments, (a) yes, it is too much work, but I use my iPad for some very critical functions and I don't like any kind of odd or buggy behavior, even if apparently harmless, (b) I think that whatever caused the problem was very temporary, likely has been corrected and will not recur - but of course I could be totally mistaken, and (c) I don't expect Apple to come up with any custom solution for a glitch that affected a relatively small number of customers and hasn't made it into the newspapers.

     

    Apple, please prove me wrong on this last point!

  • 43. Re: Unable to purchase.
    DukToonz Level 1 Level 1 (0 points)

    I just wanted to add my name to the list of those hoping for an apple update style fix.  Resetting my iPad in hope that the error won't pop up again is fairly unacceptable.  If it was a guarantee, I might consider it.  Can't stress the word might enough though.

     

    The error, while annoying, isn't enough to make me wanna kill two days returning my iPad to its current working state.  There simply must be a better way. bleh

  • 44. Re: Unable to purchase.
    Rob RS125R Level 1 Level 1 (0 points)

    I, too, have had this annoying message for quite a while now.  It began with one app listed by name in the "Uable to Purchase" message notification and then that original app plus 1 additional app, then 2 apps over time.

     

    In any case, I was able to solve the problem.  Perhaps this will help others.

     

    After a little research, I theorized that the message was related in some way to my Apple Account information.  Maybe the account was not being accessed correctly (for some reason on Apple's end; server issues, etc.) when I attempted to make the orginal purchases or maybe I had some corrupted information inthe account data fields (although I was able to purchase new apps).  So, I did two things:

     

    1.  I opened iTunes on my Mac.  Clicked on the iTune Store. Made sure I was logged into my Apple Account.  Clicked on the drop down arrow for my Apple ID in the upper rght hand corner of the window.  Clicked on the "Account" option to display the account information page and re-entered my payment information.  Saved this (i.e., clicked on "Done").  Exited iTunes.

     

    2. On my iPad (1st generation, iOS 5.01), I opened Settings>Store>tapped on my Apple ID>signed out.  Then closed Settings.  Completely powered off the iPad.  Powered on the iPad.  Tapped Settings>Store> signed into my Apple Account.  Closed Settings.

     

    I am now able to download apps from the App Store on  my iPad without the "Uable to Purchase" message notification.

     

    Give it a try and see what happens.

1 2 3 4 5 Previous Next