Skip navigation

Calculator/Numbers decimal point isn't working correctly

4075 Views 9 Replies Latest reply: Mar 10, 2012 11:30 AM by Linc Davis RSS
Nefertete Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 4, 2012 6:07 AM

Since the installation of Lion the decimal point isn't working alright. Not in the calculator and not in Numbers.

 

1. For instance when I type 1500 in the Calculator the displays says 1,500. That's not correct, in Europe it should be 1.500

No preferences in the calculator to change it. It worked well with Snowleopard.

In system preferences Decimals is changed to ",", thousands is "."

 

2. Numbers. When I type 123456789 in  numeric field it's changed in 123.456.789

   If I change the last four digits to 2233 and accidently forget to change the points the point stays on the same place. It will say 123.452233

The same if you add a digit 123.456.789 will be 123.456.7892233

This worked well in Snowleopard.

 

Can it be solved?

  • Linc Davis Level 10 Level 10 (107,850 points)

    System Preferences > Language & Text > Formats > Numbers

  • Linc Davis Level 10 Level 10 (107,850 points)

    Please read this whole message before doing anything.

     

    This procedure is a test, not a solution. Don’t be disappointed when you find that nothing has changed after you complete it.

     

    Step 1

     

    The purpose of this step is to determine whether the problem is localized to your user account.

     

    Enable guest logins and log in as Guest. For instructions, launch the System Preferences application, select Help from the menu bar, and enter “Set up a guest account” (without the quotes) in the search box.

     

    While logged in as Guest, you won’t have access to any of your personal files or settings. Applications will behave as if you were running them for the first time. Don’t be alarmed by this; it’s normal. If you need any passwords or other personal data in order to complete the test, memorize, print, or write them down before you begin.

     

    As Guest, launch the application(s) and test. Same problem(s)?

     

    After testing, log out of the guest account and, in your own account, disable it if you wish. Any files you created in the guest account will be deleted automatically when you log out of it.

     

    Step 2

     

    The purpose of this step is to determine whether the problem is caused by third-party system modifications that load automatically at startup or login.

     

    Disconnect all wired peripherals except those needed for the test, and remove all aftermarket expansion cards. Boot in safe mode and log in to the account with the problem. The instructions provided by Apple are as follows:

     

    • Be sure your Mac is shut down.
    • Press the power button.
    • Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
    • Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

     

    Safe mode is much slower to boot and run than normal, and some things won’t work at all, including wireless networking on some Macs.

     

    The login screen appears even if you usually log in automatically. You must know your login password in order to log in. If you’ve forgotten the password, you will need to reset it before you begin.

     

    Test while in safe mode. Same problem(s)?

     

    After testing, reboot as usual (i.e., not in safe mode.) Post the results of steps 1 and 2.

  • Jean-Marie Allier Level 1 Level 1 (130 points)

    I have the same behavior with Lion 10.7.3, Numbers 2.1 and the Calculator app.

     

    I sent a bug report to Apple for Numbers.

     

    For calculator, as I am French, the standard settings are " " for thousands and "," for decimal. If I change Thousands to "." in system preferences, Calculator will change 123 456,78 to 123,456,78 which is rather confusing... As I have another Mac with 10.6, I checked on this one, and I got 123.456,78 which is fine.

     

    So, there is a bug in 10.7.

     

    Maybe you could try the French settings with a space as thousands separator.

  • Linc Davis Level 10 Level 10 (107,850 points)

    Must be a bug in Lion.

     

    That seems to be true.

  • Linc Davis Level 10 Level 10 (107,850 points)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.