Skip navigation

mail hangs when receiving e-mail

1431 Views 10 Replies Latest reply: May 5, 2012 12:09 AM by Rudi60 RSS
basfromnuenen Calculating status...
Currently Being Moderated
Feb 4, 2012 5:42 AM

Hello communitiemembers,

 

I have a strange problem. For a few days now mail freezes when I try to receive mail from a certain account.

 

Information:

  • I'm using OSX 10.6.8 and apple mail as mail cliënt.
  • I'm using several mail accounts. The problem only occurs to one of them.
  • When I put the certain account to off-line, mail works fine (but then I'm not able to receive  mail from that account)
  • As soon as the certain account is online, mail starts to receive mail, but the activitycenter shows that mail hangs on receiving the last of a couple of e-mails. The only way to stop mail is forced stopping.

Things I already tried:

  • rebuild the postbox (no solution)
  • removed and reïnstalled the certain mailaccount (no solution)
  • reïnstalled apple mail (no solution)
  • deleted ~library/mail/envelope index (no solution)
  • deleted the mail from the inbox via webmail. (this only solves the problem temporarily, as soon as the account receives new messages, the problem occurs again)
  • installed MS Outlook as mail cliënt and installed the certain mailaccount. (in Outlook the problem didn't show up; so it must be a problem that is related to Apple Mail.) Of course I want to use Apple mail an not Outlook for my mail-accounts.

 

Is there anybody who can help me out?

iMac, Mac OS X (10.6.8)
  • kurt188 Level 4 Level 4 (1,325 points)
    Currently Being Moderated
    Feb 4, 2012 6:38 AM (in response to basfromnuenen)

    You didn't say who the email provider is for this problematic account, and that's important to know, along with what kind of account it is (POP, or IMAP).

     

    Did you send any email rrecently with a large attachment? If not, then what did Outlook retrieve that Mail had a problem with (be specific)? If this is an IMAP account, did you login to the web interface to see what that message might be causing the hangup and delete it there (after making sure it wasn't something important)?

     

    From what little info you gave, I would suspect there is something about that email (maybe the encoding) that Mail doesn't like, even though Outlook may not complain about it. We need more details.

  • kurt188 Level 4 Level 4 (1,325 points)
    Currently Being Moderated
    Feb 4, 2012 7:23 AM (in response to basfromnuenen)

    Have you tried creating a new user account for test purposes on your Mac and setting up that account in Mail to see if the problem happens there as well? If not, you should do that, since it would tell us if the problem is systemwide, or just limited to your regular user account.

     

    If the problem isn't happening there, then in your regular user account you should try:

     

    1. Quit Mail if it's running.

    2. Go to Home/Library/Preferences and remove the com.apple.mail.plist file

    3. Restart Mail and setup your accounts again, then wait for Mail to find your existing mailboxes.

    4. Check to see if the problem is still there. If not, then you can delete the old com.apple.mail.plist file you removed; otherwise, if the problem is still there, you can put the old one back if you choose.

  • kurt188 Level 4 Level 4 (1,325 points)
    Currently Being Moderated
    Feb 4, 2012 8:46 AM (in response to basfromnuenen)

    The only other things I could suggest at the moment (since I have to leave for the day), are to change your test user account to your regular user account by moving anything over that you need, or installing any applications in that one, and then once that's done, delete the old, regular user account.

     

    Or, you could also try downloading the 10.6.8 v1.1 Combo Update from the Apple web site and re-applying it. It may or may not "fix" your problem, but it certainly won't do any harm.

  • kurt188 Level 4 Level 4 (1,325 points)
    Currently Being Moderated
    Feb 5, 2012 9:19 AM (in response to basfromnuenen)

    Using the test account as the main account is a bit to complex and risky to my opinion.

    How is that too complex or risky? All you would be doing is using a new account as your regular account, where this email problem doesn't appear.

     

    I restored the folowing files for older ones

    • ~home/Library/Preferences/com.apple.mail.plist
    • ~home/library/Envelope Index
    • entire folder ~home/Library/Mail

    Those aren't the problem, so you're wasting your time restoring those.

  • Rudi60 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 5, 2012 12:09 AM (in response to basfromnuenen)

    Hello

     

    I am faced with the same problem, but couldn't find a solution so far. However there is workaround. I have about 10 accounts, where the problem occured. For each account I created a rule moving the incoming mail into a temp folder and than copy the mail back into the incoming folder..

     

    This works however as I have a mobile account sometimes after a sync  the information to copy the incoming mail back to the incoming folder will be changed to the temp folder.

     

    A check of console gives the following error message.

    05.05.12 08:34:39Mail[2628]An exception was thrown 'CoreData could not fulfill a fault for '0x11e947f10 <x-coredata://E2990679-B14A-4321-9FAC-74E5088A6375/ABCDContact/p160>'' during invocation of -[MessageTransfer _synchronouslyPerformTransfer]. Stack trace:

    (


    0   CoreFoundation                      0x00007fff82fb1784 __exceptionPreprocess + 180

    1   libobjc.A.dylib                     0x00007fff84a61f03 objc_exception_throw + 45

    2   CoreData                            0x00007fff866f5c8c _PFFaultHandlerLookupRow + 940

    3   CoreData                            0x00007fff866f58d7 -[NSFaultHandler fulfillFault:withContext:] + 23

    4   CoreData                            0x00007fff866f3dbe _PF_FulfillDeferredFault + 254

    5   CoreData                            0x00007fff866f7ab7 _sharedIMPL_pvfk_core + 87

    6   CoreData                            0x00007fff8670345e _pvfk_7 + 14

    7   AddressBook                         0x00007fff8976710e -[ABRecord nts_initWithDatabaseImpl:addressBook:] + 253

    8   AddressBook                         0x00007fff89766fb3 +[ABCDRecord copyPublicRecordForClass:withDatabaseImpl:inAddressBook:] + 109

    9   AddressBook                         0x00007fff8976e364 -[ABAddressBook(ABMailPeopleSearch) recordsMatchingMailAddressWithEmail:fullName:firstName:lastName:inSubscribedCon tent:] + 999

    10  Message                             0x00007fff826f76e3 -[ABAddressBook(MailAdditions) bestRecordMatchingFormattedAddress:] + 364

    11  Message                             0x00007fff826f73e1 -[MailAddressManager bestRecordMatchingFormattedAddress:] + 411

    12  Message                             0x00007fff826f7144 -[MessageCriterion _evaluateAddressBookCriterion:] + 148

    13  Message                             0x00007fff826f6372 -[MessageRule doesMessageSatisfyCriteria:] + 471

    14  Message                             0x00007fff826f5f1a +[MessageRouter putRulesThatWantsToHandleMessage:intoArray:colorRulesOnly:] + 481

    15  Message                             0x00007fff827fa802 +[MessageRouter colorForMessage:highlightTextUsingColor:] + 98

    16  Message                             0x00007fff8268d7f0 -[MessageStore(MessageFrameworkOnly) updateMessages:updateColor:updateNumberOfAttachments:] + 763

    17  Message                             0x00007fff8271406c -[LibraryStore appendMessages:unsuccessfulOnes:newMessageIDs:newMessages:newDocumentIDsByOld:f lagsToSet:forMove:error:] + 1495

    18  Mail                                0x00000001000c209f 0x0 + 4295762079

    19  CoreFoundation                      0x00007fff82f8693c __invoking___ + 140

    20  CoreFoundation                      0x00007fff82f8680d -[NSInvocation invoke] + 141

    21  Message                             0x00007fff8266ccb9 -[MonitoredInvocation invoke] + 214

    22  Message                             0x00007fff82653cbf -[ThrowingInvocationOperation main] + 31

    23  Message                             0x00007fff826535ff -[_MFInvocationOperation main] + 275

    24  Foundation                          0x00007fff88569dd0 -[__NSOperationInternal start] + 681

    25  Foundation                          0x00007fff88647bd5 ____NSOQSchedule_block_invoke_2 + 129

    26  libSystem.B.dylib                   0x00007fff86d9bd64 _dispatch_call_block_and_release + 15

    27  libSystem.B.dylib                   0x00007fff86d7a2d1 _dispatch_worker_thread2 + 239

    28  libSystem.B.dylib                   0x00007fff86d79c08 _pthread_wqthread + 353

    29  libSystem.B.dylib                   0x00007fff86d79aa5 start_wqthread + 13

    )

     

    Does gives anybody a clue?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.