Skip navigation

Kernel Panics (x 2) using Disk Warrior 4.4 on latest Lion build

5205 Views 33 Replies Latest reply: Feb 8, 2012 3:01 PM by baltwo RSS
1 2 3 Previous Next
babowa Level 7 Level 7 (22,075 points)
Currently Being Moderated
Feb 4, 2012 10:20 AM

After updating to the latest build (11D50 > 10.7.3), I decided to make a new clone from scratch on one of my external partitions. Erased disk with Disk Utility > made clone using Super Duper (I use CCC on my other clone). Tested clone by booting into it - worked. Booted back into internal and launched Disk Warrior; graph showed directory 37% out of whack. So I hit rebuild. Within 60 seconds or so, first kernel panic. Shut down. Rebooted and everything appeared fine. Sent the kp report to Apple. Decided to try it again: within 60 seconds, the second kernel panic.


KP log is below if anyone can make some sense of it (also sent that to Alsoft this morning):


Interval Since Last Panic Report: -8 sec
Panics Since Last Report: 1
Anonymous UUID: C7B05263-F497-421C-AD7C-B0EC862C2AEF

Fri Feb 3 22:27:12 2012
panic(cpu 3 caller 0xffffff80002c266d): Kernel trap at 0xffffff80002af406, type 14=page fault, registers:
CR0: 0x0000000080010033, CR2: 0xffffff813b63c000, CR3: 0x00000000216a7035, CR4: 0x00000000000206e0 RAX: 0x0000000000016fe0, RBX: 0xffffff813b631020, RCX: 0x0000000000000003, RDX: 0x000000000000aff8 RSP: 0xffffff81620dbcc8, RBP: 0xffffff81620dbcf0, RSI: 0xffffff813b63c000, RDI: 0xffffff813b652fe0
R8: 0x0000000000000000, R9: 0xffffff80008bf5e0, R10: 0xfffffe8001a96360, R11: 0x000000000017bb00 R12: 0xffffff80008df780, R13: 0xffffff802cca2b00, R14: 0x000000000000aff8, R15: 0xffffff8030b369c0
RFL: 0x0000000000010216, RIP: 0xffffff80002af406, CS: 0x0000000000000008, SS: 0x0000000000000010 CR2: 0xffffff813b63c000, Error code: 0x0000000000000000, Faulting CPU: 0x3

Backtrace (CPU 3), Frame : Return Address 0xffffff81620db980 : 0xffffff8000220702 0xffffff81620dba00 : 0xffffff80002c266d 0xffffff81620dbba0 : 0xffffff80002d7a1d 0xffffff81620dbbc0 : 0xffffff80002af406 0xffffff81620dbcf0 : 0xffffff80005e3909 0xffffff81620dbd20 : 0xffffff7f80793da4 0xffffff81620dbda0 : 0xffffff8000654830 0xffffff81620dbdf0 : 0xffffff800029f20d 0xffffff81620dbe20 : 0xffffff8000223006 0xffffff81620dbe50 : 0xffffff8000214829 0xffffff81620dbeb0 : 0xffffff800021bb58 0xffffff81620dbf10 : 0xffffff80002aedb0 0xffffff81620dbfb0 : 0xffffff80002d801e

Kernel Extensions in backtrace: com.alsoft.Preview(4.4)[B016E8B4-FE8A-B791-49C8-6FF01DF285E2]@0xffffff7f8079300 0->0xffffff7f80799fff

dependency:[E0606FD9-7CC1-3E36-BC0A-E0768FF988E4]@0xff ffff7f8076e000 BSD process name corresponding to current thread: DiskWarrior

Mac OS version: 11D50

Kernel version:
Darwin Kernel Version 11.3.0: Thu Jan 12 18:47:41 PST 2012; root:xnu-1699.24.23~1/RELEASE_X86_64 Kernel UUID: 7B6546C7-70E8-3ED8-A6C3-C927E4D3D0D6
System model name: iMac11,3 (Mac-F2238BAE)

System uptime in nanoseconds: 1024244228248
last loaded kext at 1024201863243:

1.0.0d22 (addr 0xffffff7f807a4000, size 36864)
last unloaded kext at 1007434208889:

1.0.0d22 (addr 0xffffff7f80793000, size 36864) loaded kexts:

com.alsoft.Preview 4.4 1.9.4d0 122 3.5.9 1.0.26 2.1.7f9 1.59 2.1.7f9 100.12.42 7.1.8 1.0.0d1 7.0.0 1.2.2 4.7.5d4 1.5.3 3.0 170.1.9 7.1.8 3.0 3.0.1 312 3.0.1

1.0.0d1 1.0.0d1 33 3.0.3 2.0.1 4.8.9 4.5.0 502.60.2 3.0.8b2 1.5.0 2.2.0 4.5.8 1.4 1.4 1.6 1.7 1.4 1.5 167.3.0 3.2.30 1.1 167.3.0 1.0.0d22 152.3 152.3 4.0.3f12 2.1.7f9 1.0.10d0 1.0.10d0 2.2.4 2.8.2f5 80.0 2.1.7f9 2.1.7f9 4.0.3f12 10.0.5 1.8.6fc6 1.3 3.0.16 3.1.1d8 4

Model: iMac11,3, BootROM IM112.0057.B00, 2 processors, Intel Core i3, 3.2 GHz, 12 GB, SMC 1.59f2
Graphics: ATI Radeon HD 5670, ATI Radeon HD 5670, PCIe, 512 MB
Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353637334648302D4348392020 Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353637334648302D4348392020 Memory Module: BANK 0/DIMM1, 4 GB, DDR3, 1333 MHz, 0x857F, 0x483634353155363446393333334700000000 Memory Module: BANK 1/DIMM1, 4 GB, DDR3, 1333 MHz, 0x857F, 0x483634353155363446393333334700000000 AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x8F), Atheros 9280:
Bluetooth: Version 4.0.3f12, 2 service, 18 devices, 1 incoming serial ports
Network Service: Ethernet, Ethernet, en0
Serial ATA Device: ST31000528AS, 1 TB
Serial ATA Device: HL-DT-STDVDRW GA32N
USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfd100000 / 2
USB Device: hub_device, 0x050d (Belkin Corporation), 0x0237, 0xfd140000 / 5
USB Device: iMic USB audio system, 0x077d, 0x07af, 0xfd142000 / 8
USB Device: CTH-460, 0x056a (WACOM Co., Ltd.), 0x00d1, 0xfd145000 / 7
USB Device: Back-UPS ES 550 FW:843.K2 .D USB FW:K2, 0x051d (American Power Conversion), 0x0002, 0xfd141000 / 6 USB Device: Built-in iSight, apple_vendor_id, 0x8502, 0xfd110000 / 4
USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 3
USB Device: hub_device, 0x0424 (SMSC), 0x2514, 0xfa100000 / 2
USB Device: MacALLY USB One Button Mouse, 0x0618 (Chia Shin Technology Corp.), 0x0301, 0xfa130000 / 5
USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfa120000 / 4
USB Device: BRCM2046 Hub, 0x0a5c (Broadcom Corp.), 0x4500, 0xfa110000 / 3
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 7
FireWire Device: d2 quadra (button), LaCie, 800mbit_speed


I may try this one more time later today or tomorrow; if it happens again, I will wipe that clone and re-do it with CCC and then try it again to see if it could possibly have anything to do with SuperDuper (rather than Mac OS or DW).


Edit: This should be in the Lion forum - sorry - will report myself (if I can - don't see a report button) or someone could please have it moved........ thanks.

iMac (27-inch Mid 2010), Mac OS X (10.7.2), i3 12 GB RAM | 10.6.8
  • baltwo Level 9 Level 9 (59,150 points)

    Ran DW 4.4 on 10.7.3 and rebuilt the directory (44% out of whack) for my Lion clone made with CCC; had no issues. Did a search for com.alsoft.Preview 4.4 and couldn't find it on my machine. All I can suggest is to reinstall Lion and run a new copy of DW 4.4.

    27" i7 iMac 10.6.8 , Mac OS X (10.7.3), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • baltwo Level 9 Level 9 (59,150 points)

    Could be. I've not use SD! in four or five years.

    27" i7 iMac 10.6.8 , Mac OS X (10.7.3), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • J.Morris Calculating status...

    I stopped using DW since they are on apparently Verison 4.4 and I've owned it since 4.0 when Snow Leopard was released. That's 3 years and only 4 new builds. That's pretty bad if your product is only updated from the original disc....


    I use Drive Genius from ProSoft Engineering. It seems to be updated on a regular basis,(and since Data Rescue also made by ProSoft is a company that Apple Service Providers offer for HD recovery) and has yet to cause me any issues.


    I'd go with something other than DW....

  • baltwo Level 9 Level 9 (59,150 points)

    Doesn't matter. DW 4.4 works with Leopard through Lion, and Snow Leopard is Leopard on steroids. Lion isn't that much different than SL unless you consider the lack of Rosetta support or iOS gimmickry to be an improvement.

    27" i7 iMac 10.6.8 , Mac OS X (10.7.3), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • boyfromoz Calculating status...

    I just rab DiskWarrior from my Snow Leopard partition (4.4) and it worked real fine on Lion 10.7.3 with no problems so i think it must be compatibal. No diff than running it back in snow l.


    thank you

  • Linc Davis Level 10 Level 10 (107,735 points)

    The panic may have been caused by the kernel extension that Disk Warrior installs:




    In any case, why are you using Disk Warrior at all? It's a recovery tool, not a maintenance tool. Whatever it does can be done better, faster, and cheaper by formatting and restoring from backup. Avoid all commercial "utilities" for the Mac.

  • boyfromoz Level 1 Level 1 (45 points)

    I always used DiskWarrior after major update and always no trouble. I soppose its like some who always repair permissions every time. never upset anything so i feel better to know volumes are in good order. but is each to own I see.


    thank you

  • baltwo Level 9 Level 9 (59,150 points)

    Linc Davis wrote:

    The panic may have been caused by the kernel extension that Disk Warrior installs:


    If that was the case, IMO, it would have crashed for me when I ran it. That didn't happen. As for the kept, even though mentioned in the crash report, I see no evidence of it. There is a preview app inside, that may put that kept in temporarily, but didn't affect my run.

    27" i7 iMac 10.6.8 , Mac OS X (10.7.3), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • Linc Davis Level 10 Level 10 (107,735 points)

    I always used DiskWarrior after major update and always no trouble.


    The trouble is that you're at least $100 poorer (maybe a lot more if you paid for "upgrades") with nothing to show for it. Not to mention the time you've wasted.

  • Linc Davis Level 10 Level 10 (107,735 points)

    The kernel extension is loaded when Disk Warrior launches. It's not permanently installed.

  • baltwo Level 9 Level 9 (59,150 points)

    Thanks for confirming. That was my surmise, but I failed to mention it.

    27" i7 iMac 10.6.8 , Mac OS X (10.7.3), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
1 2 3 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.