1 2 Previous Next 17 Replies Latest reply: Mar 29, 2012 12:28 AM by Roger Wilmut1
jc paris Level 1 Level 1 (0 points)

I've just -stupidely it seems- run the latest security update and I' can't open Appleworks anymore .

I experienced the same problem with Soundtrack some monthes ago after another security update .

It 's simply scandalous that Apple under cover of "security" disables old applications to make you buy new ones .

And what about all the existing docs you can no longer access ?


MacBook Pro, Mac OS X (10.6.8)
  • 1. Re: ALERT !!!!
    Peggy Level 8 Level 8 (38,230 points)

    I've seen mention of the secruity update disabling Rosetta on some Macs, but I am not having a problem running AppleWorks on my Mac mini & OS X 10.6.8. So, I would try the usual troubleshooting steps. Whenever you do an update, it's a good idea to do two maintenance tasks, one for the system (Repair Permissions) and one for AppleWorks (delete preferences). (Thanks to Barry for this way to format this very common answer.)

     

    To Repair permissions, launch Disk Utility, found in the Utilities folder in your Applications folder, click on Repair Permissions.

     

    To delete AppleWorks’ preference files, go to HD > Users > Library > Preferences. Find and delete the file com.apple.appleworks.plist. Find and open the folder AppleWorks in this Preferences folder, then delete all of the enclosed files (with the exception of the Button Bar Preferences if you have customized the Button Bars). AppleWorks will recreate the preference files as it needs them.

     

    Peggy_sig.png

  • 2. Re: ALERT !!!!
    Ronda Wilson Level 8 Level 8 (40,690 points)

    Have you tried printing from AppleWorks, Peggy? I've read that some people can open AppleWorks documents, but are unable to print them.

     

    I haven't updated yet, and don't intend to unless/until this is no longer a problem.

  • 3. Re: ALERT !!!!
    Peggy Level 8 Level 8 (38,230 points)

    I had a hard time finding an AppleWorks file on my Mac mini as I've long-since converted those I could to Pages or Numbers. I did get the same problems others have reported when I tried to print.

     

    Peggy_sig.png

  • 4. Re: ALERT !!!!
    jc paris Level 1 Level 1 (0 points)

    Thank you Peggy for your suggestions , but I already went through all this without success . The only way to recover these apps ( soundtrack that came with FinalCut Express and Appleworks ) seems to be a complete reinstallation of 10.6 from the original DVD and then to update without running the  last security updates  .

    I think it will be easier to spend 12€ on Pages ( french price ) since it apparently allows you to open your old Appleworks text files ...

    And I still persist thinking that it is exactly what Apple wants us to do !!!

     

    Jean-Claude

  • 5. Re: ALERT !!!!
    Ray Craighead Level 1 Level 1 (25 points)

    I agree. If this is intentional on Apple's part, I will boycott them!!! I can open, but not print from my Appleworks files. I've looked for a cos-effective replacement for a simple Mac database, but have not found one. I'm ticked.

  • 6. Re: ALERT !!!!
    1711 Level 1 Level 1 (0 points)

    I too have had the same problem. The 1st Feb security update seems to have disabled Rosette which has been the translator for PowerPC applications to work with SnowLeopard. Appleworks and old word for Mac have been affected oin the ways described below - i.e, files open but crash the application when saving is attempted. Otehr applications may also be affected if they depended on Rosetta.

     

    I have had exellent support from AppleCare and spent most of the day trying various remedies. Ultimately the only easy solution seems to be to reinstall everyting on your hard disk prior to 1st Feb when you installed the update.

     

    Take a deep breath - insert your snowleopard disk 10.6.8 (check that it is grey - if its not I don't know what to do!) Shut down and restart holding down ALT key  then open the disk image and then go to the top menu on the screen (not in the box) and follow instructions from there. It normally takes about two hours, Everything after 31st Jan or when you last updated Time Machine will be lost but everything before that date should be safe. 

     

    You will get a message saying that there is aoftware witing to be downloaded - DO NOT DOWNLOAD IT -  the offered update will be that of the 1st Feb that caused all the grief.

     

    My adviser t Apple told me that it is important to file a bug report with Apple about this. Unless enough people report this to Apple the next security updates will not have been corrected and we shall have to go through all this agony again. I have no idea if and when it will be safe to dwonlod all or part of later security updates. This the option of disabling elements of the update, but my advisor could not give me any ehlp about that. Lets try to keep in touch here and try to make sure that everyone who falls into this trap tells Apple about it to prevent repetition.

     

    i hope this is helpful. f anhyone affected is still on AppleCare please contact them and report the problem. There may be a better way round this but my AppleCare Level 2 expert could not help any further today.

  • 7. Re: ALERT !!!!
    1711 Level 1 Level 1 (0 points)

    URGENT - if you have been caught by this trap and if you intend to use the total reinstall from Time Machine as I suggested - I think you shoild do it soon because otherwise I think you will lose all activity from 1st Feb or whenever you downloaded the infamous security upate. If, like me, you don't run Time Machine frequently, you will lose everyting from your last Time Machine backup.

    .

  • 8. Re: ALERT !!!!
    Peggy Level 8 Level 8 (38,230 points)

    Check Software Update if you're having this issue. Apple has released an updated security update. This does seem to have fixed the problems.

     

    Peggy_sig.png

  • 9. Re: ALERT !!!!
    jc paris Level 1 Level 1 (0 points)

    Thanks a lot for the tip, everything's back to normal as far as Appleworks is concerned . For once, Apple reacted very, very promptly . No mercantile afterthoughts finally....

     

    Soundtrack 1.5 still crashes on opening, but that's another story !!!

     

    Jean-Claude,

    Paris

  • 10. Re: ALERT !!!!
    Louis AIM Level 1 Level 1 (0 points)

    Have you tried to change the field descriptions in an existing Apple Works Data Base? Dos it work for you? Have installed the latest and updated security update. Saving and printing works, but not working on Data Base Fields Definitions (parex for entering a standard, promptet value in a field in order to avoid entering standard data).

     

    Louis

    Italy

  • 11. Re: ALERT !!!!
    jc paris Level 1 Level 1 (0 points)

    I'm afraid I mainly use Appleworks for mails and leaflets so right now it's OK for me .

     

    Jean-Claude

    Paris

  • 12. Re: ALERT !!!!
    1711 Level 1 Level 1 (0 points)

    Well done Peggy!

    The updated security update is called 2012 - 1.1 and, having put level 2 Applecare advisor through the hoops 'just in case', I have installed it with no ill effects that I can detect.

    The future for Appleworks looks bleak because ti cannot run under 64bit Lion. Partitioning seems to be the answer?

  • 13. Re: ALERT !!!!
    Louis AIM Level 1 Level 1 (0 points)

    Now it works great! I cancelled the AppleWorks Preference file and repaired the disk permissions (did already after installing security update so i think the cancelling of the preference file did the job). Ha anybody an alternative for the AppleWorks Data Base for use under Mac OS 10.7? I have tried Bengto and iDatabase but they are poor in features, such as standard field contents, mandatary, calcolation including menu field values, ecc.)

     

    Wish all a nice week end!

    Louis

  • 14. Re: ALERT !!!!
    Roger Wilmut1 Level 9 Level 9 (65,495 points)

    Louis AIM wrote:

     

    Ha anybody an alternative for the AppleWorks Data Base for use under Mac OS 10.7?

    There is really only one option - FileMaker Pro. However it's expensive, and has a steep learning curve; but it's extremely powerful.

     

    Note that it will not open AppleWorks databases - nothing will do that apart from AppleWorks - so you will need to export your datases as ASCII text and import that into FileMaker: you will of course lose all formatting and calculation fields will bring over the result, not the calculation.

     

    More information about this here:

     

    http://www.wilmut.webspace.virginmedia.com/notes/aw/page6.html

1 2 Previous Next