Skip navigation

Wi-fi Connection

1369 Views 6 Replies Latest reply: Feb 12, 2012 12:33 PM by ssdoc RSS
ssdoc Calculating status...
Currently Being Moderated
Feb 8, 2012 12:22 PM

My Macbook Air is not connecting to wi-fi automatically even though my network is in the preferred network list. What shall I do?

  • John Galt Level 7 Level 7 (33,090 points)
    Currently Being Moderated
    Feb 8, 2012 12:26 PM (in response to ssdoc)

    Hi ssdoc, did you install the recent update to OS X?

     

    This longstanding issue has caused many complaints with at least as many suggestions for fixing it. For now make sure you run Software Update.

     

    To learn more, read:

     

    Lion WiFi Connection Problem

  • John Galt Level 7 Level 7 (33,090 points)
    Currently Being Moderated
    Feb 8, 2012 12:40 PM (in response to ssdoc)

    Then you need to run Software Update again. The current relase is 10.7.3.

     

  • John Galt Level 7 Level 7 (33,090 points)
    Currently Being Moderated
    Feb 8, 2012 3:02 PM (in response to ssdoc)

    OK then, you could peruse the thread I provided in my first response, but are over 1800 responses in that thread alone. There are several others about the same issue. You will find a few sucesses, a lot of failures, and an abundance of superstition and urban legend. There doesn't appear to be a definitive answer yet.

     

    The following is a copy of what I posted in one of those threads. Please let me know what your results are.

     

    ...

     

    Here are some things to try that may help, in order of increasing inconvenience:

     

    1. Try creating a new, temporary user account. Log in under that account to see if its behavior is any different. If it is then it will provide a clue toward resolving the problem. Delete the temporary account when you are finished with it.

     

    2. Go to System Preferences > Network. Click the lock to authenticate, if necessary. Then click the gear icon under the network interfaces like so:

     

    Screen Shot 2012-02-02 at 1.14.31 AM.png

    Whatever service order you have set, drag Wi-Fi either to the top (assuming it's not already there) or away from the top if it was already there. Click OK and then Apply. Sleep the system then wake it again to observe any changes.

     

    3. Click Wi-Fi in the above. If "show AirPort icon in menu bar" is not selected, select it. Then click Advanced. Select all the networks your computer has ever joined and delete them with the "-" button. OK then Apply again. Select your network under the AirPort icon to re-join it. Sleep and wake again to see if that did anything.

     

    4. If you have not done so already download and install the 10.7.3 Combo updater. It is a more comprehensive installer than the one available using Software Update, and may fix some problems.

     

    You may have done some or all of these already but perhaps there is something you have not thought of. If nothing helps we may just have to wait a bit longer for Apple to release a fix.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.