6 Replies Latest reply: Feb 12, 2012 12:33 PM by ssdoc
ssdoc Level 1 Level 1 (0 points)

My Macbook Air is not connecting to wi-fi automatically even though my network is in the preferred network list. What shall I do?

  • 1. Re: Wi-fi Connection
    John Galt Level 8 Level 8 (36,365 points)

    Hi ssdoc, did you install the recent update to OS X?

     

    This longstanding issue has caused many complaints with at least as many suggestions for fixing it. For now make sure you run Software Update.

     

    To learn more, read:

     

    Lion WiFi Connection Problem

  • 2. Re: Wi-fi Connection
    ssdoc Level 1 Level 1 (0 points)

    Yes. I have updated the software. My current software version is 10.7.2.

  • 3. Re: Wi-fi Connection
    John Galt Level 8 Level 8 (36,365 points)

    Then you need to run Software Update again. The current relase is 10.7.3.

     

     

  • 4. Re: Wi-fi Connection
    ssdoc Level 1 Level 1 (0 points)

    Sorry, my mistake. The version is indeed 10.7.3. Can I do anything else?

  • 5. Re: Wi-fi Connection
    John Galt Level 8 Level 8 (36,365 points)

    OK then, you could peruse the thread I provided in my first response, but are over 1800 responses in that thread alone. There are several others about the same issue. You will find a few sucesses, a lot of failures, and an abundance of superstition and urban legend. There doesn't appear to be a definitive answer yet.

     

    The following is a copy of what I posted in one of those threads. Please let me know what your results are.

     

    ...

     

    Here are some things to try that may help, in order of increasing inconvenience:

     

    1. Try creating a new, temporary user account. Log in under that account to see if its behavior is any different. If it is then it will provide a clue toward resolving the problem. Delete the temporary account when you are finished with it.

     

    2. Go to System Preferences > Network. Click the lock to authenticate, if necessary. Then click the gear icon under the network interfaces like so:

     

    Screen Shot 2012-02-02 at 1.14.31 AM.png

    Whatever service order you have set, drag Wi-Fi either to the top (assuming it's not already there) or away from the top if it was already there. Click OK and then Apply. Sleep the system then wake it again to observe any changes.

     

    3. Click Wi-Fi in the above. If "show AirPort icon in menu bar" is not selected, select it. Then click Advanced. Select all the networks your computer has ever joined and delete them with the "-" button. OK then Apply again. Select your network under the AirPort icon to re-join it. Sleep and wake again to see if that did anything.

     

    4. If you have not done so already download and install the 10.7.3 Combo updater. It is a more comprehensive installer than the one available using Software Update, and may fix some problems.

     

    You may have done some or all of these already but perhaps there is something you have not thought of. If nothing helps we may just have to wait a bit longer for Apple to release a fix.

  • 6. Re: Wi-fi Connection
    ssdoc Level 1 Level 1 (0 points)

    Thanks John for your advice. I did not do any of these but somehow it seems to have sorted itself out for now. If it starts playing up again, then I will try your above tip.

     

    Many thanks

     

    Siva