Skip navigation

Why are images opened in Preview locked since 10.7.3 Update?

6533 Views 6 Replies Latest reply: Oct 8, 2012 1:47 PM by ring_0 RSS
Brian T. Nakamoto Level 1 Level 1 (70 points)
Currently Being Moderated
Feb 7, 2012 5:15 PM

Since updating to 10.7.3 from 10.7.2, Preview has been complaining that documents can't be saved because the file is locked. If I choose "Save Anyway" then Preview complains that I don't have permission to save the file. My user has Read & Write permission when I Get Info for the file.


I can workaround the problem by using File > Duplicate; however, it's sort of a pain. Also, Preview will always complain that the file is locked at least once when auto-save fails.


Thanks in advance for any help!


1 - Locked.png

2 - Permission.png

3 - Get Info.png

MacBook Pro, Mac OS X (10.7.3), Unibody 15", 6 GB RAM, 500 GB HDD
  • Linc Davis Level 10 Level 10 (107,660 points)

    Boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.


    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.

    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens.


    Select your boot volume if not already selected.


    Select your username from the menu labeled Select the user account if not already selected.


    Under Reset Home Directory Permissions and ACLs, click the Reset button.


    Select ▹ Restart from the menu bar.

  • Linc Davis Level 10 Level 10 (107,660 points)

    Launch the Terminal application by entering the first few letters of its name into a Spotlight search. Drag or copy -- do not type -- the following line into the window, then press return:


    chmod -R -N ~


    If you get an error message about permissions, enter this:


    sudo !!

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.


    Then repeat the steps in my last message.

  • ring_0 Level 1 Level 1 (25 points)

    Thanks Linc. After having repetead weird problems (like Preview displaying old stuff all the time), tried the Cmd-R reset password solution that didn't work.

    But the

    chmod -R -N ~

    (as root) did work.


    Would the problem be linked to a Leopard to Lion upgrade? ACLs being different in Lion?


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.