Skip navigation

most of keywords got deleted.

518 Views 5 Replies Latest reply: Feb 10, 2013 9:04 PM by Badunit RSS
ellenr Calculating status...
Currently Being Moderated
Feb 8, 2012 9:28 PM

I accidentally deleted most of my keywords. Is there any way to find them and get them back? The undo command doesn't seem to have any effect. Is there perhaps a way to quit Aperture without saving the changes, or is this not possible?

  • Tony Gay Level 4 Level 4 (1,625 points)
    Currently Being Moderated
    Feb 8, 2012 9:56 PM (in response to ellenr)

    How long is it since you updated your vault or other backup?

    If recently use your vault to get the keywords back.


    Unsure how to do this, ask before doing anything as you may loose any work you have added to your library since your last backup.



  • Tony Gay Level 4 Level 4 (1,625 points)
    Currently Being Moderated
    Feb 9, 2012 3:12 PM (in response to ellenr)

    What you can do is export the projects added since you backup, reinstate the backup and then import the those projects into the reinstated backup.



  • Badunit Level 6 Level 6 (10,765 points)
    Currently Being Moderated
    Feb 10, 2013 2:42 PM (in response to ellenr)

    Mine got deleted too. I opened the Keyword HUD and a bunch of keywords (folders and subfolders) were highlighted. First time I've seen that happen. I went to drag a keyword to an image and it looked like it was going to drag all the highlighted ones. So I put the mouse back over the keyword HUD and let go. To my surprise, several folders full of keywords (and their folders) got deleted and many of the other keywords were moved out of their folders. I guess ESC would have been the better choice (hindsight is 20:20) but, still, what the heck was that all about?


    My images still have the keywords and the keywords show up in the Search box but if I search on any of those keywords, no images are found. I'm not adverse to keying them all back in again but that doesn't seem to work. I tried re-typing one into the HUD but, again, no images have that keyword (even though many of them actually do).


    I have a relatively recent vault. Rather than restoring everything, how can I restore the keywords only? Can I simply replace the Keywords.plist file with the one from the vault? I'd try myself instead of asking but I don't want to make things worse.

  • Badunit Level 6 Level 6 (10,765 points)
    Currently Being Moderated
    Feb 10, 2013 9:04 PM (in response to Badunit)

    Restoring keywords didn't work.Restored entire library (well,almost ... it is still processing previews). Looks like that worked.  Good thing I back up to a vault every time I add images. I'll check it out tomorrow when it is complete.


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.