10 Replies Latest reply: Jul 15, 2012 12:25 PM by brad129
nicbarker88 Level 1 Level 1 (0 points)

I have a Macbook Pro 13" and have the latest OS X 10.7.3, but have been having problems connecting to wifi.

The wifi tab in the top right says connected, but when I open Safari the page won't load. I have tried almost everything

and don't know what else to do. This problem happens with my home wifi and others, but then again it seems to work at some public hotspots.

Any advice or recommendations?

 

nic


MacBook Pro, Mac OS X (10.7.3)
  • 1. Re: Wifi saying connected, but web pages not loading - advice?
    lclcv Level 1 Level 1 (20 points)

    I have the same problem when I can get connected. I often have no wifi connection but on the random boots when it comes up it shows it's connected and it works well for about five minutes but then it stalls. The bars show that wifi is working but in System Preferences it shows that internet and ISP have failed. So the page hangs forever. All you can do is reboot and hope you get connected again for a few minutes.

  • 2. Re: Wifi saying connected, but web pages not loading - advice?
    HACKINT0SH Level 5 Level 5 (5,755 points)

    Ok, well so we know that it COULD possibly just be a Safari issue. Can you at lease e-mail... or get another browser to run, etc? Details would help to narrow down what's happening here.

  • 3. Re: Wifi saying connected, but web pages not loading - advice?
    wifiguru Level 2 Level 2 (230 points)

    If you launch Terminal and enter:

    ping -c 5 www.google.com

     

    what do you see ? Do you get replies ? Have you checked your DNS settings ? Does refreshing the page in Safari get it to work ?

     

    Also what does the output of this command in Terminal give you:

    scutil -r www.apple.com

  • 4. Re: Wifi saying connected, but web pages not loading - advice?
    nicbarker88 Level 1 Level 1 (0 points)

    This is exactly what I experince, I have tried doing the "System Preferences > Networks > Assist me > Diagnostics route, this works and manages to get a connection for about 2minutes before the ISP, Server and Internet drop again, and I have to go through the process to regain connection (this for a public hotspot). At home this doesnt work at all.

     

    Please let me know if you hear of anything, I'm beginning to think this MBP is just defective and they must just give me a new one

  • 5. Re: Wifi saying connected, but web pages not loading - advice?
    nicbarker88 Level 1 Level 1 (0 points)

    I tried entering those commands in Terminal and got nothing, also tried refreshing the page but also no respone. If it helps the router is a 802.11g and on the box of my mbp it says wifi3 802.11n, does this mean anything? Also I heard someone say something about changing the router channel from 13 to 10 or 11.

     

    The strange thing is that when I bought my MBP it connected for the first few days just fine, now the pages don't load at all. I'd also like to point out that I have OSX 10.7.3

     

    @Hackintosh, its not a Safari issue, definitely a connection one. Not sure if it's the software or hardware.

     

    Thanks for getting back to me guys, any help is much appreciated.

  • 6. Re: Wifi saying connected, but web pages not loading - advice?
    Yan Level 1 Level 1 (0 points)

    I've been having exactly the same problem since I updated to 10.7.3, it's really annoying!! So don't worry is not you MBP, I thing it's something to do with the last software update. I've been researching and we are not the only ones having problems. I hope they fix it soon!

  • 7. Re: Wifi saying connected, but web pages not loading - advice?
    HACKINT0SH Level 5 Level 5 (5,755 points)

    When you are at home, is there any other computer you have hooked up on the WiFi as well? Do they both tend to go out at the same time? Could be an issue with the ISP...?

     

    A DNS complication is one thing that comes to mind but we may be able to totally rule that out soon.

     

    I"m a bit worried it is a bug (or more than one) in Lion though. But too early to say for certain just yet.

  • 8. Re: Wifi saying connected, but web pages not loading - advice?
    Doug Huebner Level 2 Level 2 (200 points)

    I have had the same problem. I know there is a problem with the Linksys modem. Unplugging and replugging cures that problem.

     

    It also happens if I transfer a lot of data between our two computers using the WiFi connection.

     

    And it happens other times for no apparent reason. Sometime resetting the modem works while other times a Mac restart is needed.

     

    When it happens, it is true for Firefox, Mail as well as Safari. Is it possible for Lion to somehow hang the WiFi modem?

  • 9. Re: Wifi saying connected, but web pages not loading - advice?
    SpencerO1089 Level 1 Level 1 (0 points)

    So i didnt take the time to read all the posts and see if someone else said this but I was having this same problem when trying to use the wifi at my house so I went into settings>network>choose a network and chose the one I'm on obviously then went down to HTTP proxy and mine was manual and I put it to Auto and it has been working great since then.  maybe I just got lucky but its worth a try

  • 10. Re: Wifi saying connected, but web pages not loading - advice?
    brad129 Level 1 Level 1 (0 points)

    Under network preference, edit locations, remove existing locations and create a new one with a unique name. Do the same on the remote computer. Use the same WEP security code for all remote devices i.e. Macbook pro and Ipod. You won't need to edit the locations or perform the steps below on an iPod, just change the security code.

     

    Under network preference, advanced,  make sure that airport has the same DNS number as your ethernet connection under the DNS tab. Enter the same DNS number under under, WiFi on remote computer DNS tab.

     

    This cured the problem for me sharing an built in airport connection from an iMac with Snow leopard to a Macbook Pro and iPod.