Skip navigation

Adobe Photoshop Elements 4.0 and Snow Leopard

1133 Views 14 Replies Latest reply: Jan 31, 2013 11:36 AM by Király RSS
Shadow Destroyer Calculating status...
Currently Being Moderated
Feb 6, 2012 4:59 PM

Can someone please help. We recently updated from 10.4 to 10.6 and now everytime I open Photoshop (4.0) it runs for maybe 30 seconds then stops and gives a message that Photoshop unexpectedly quit. I really need this program for my school work

Mac OS X (10.6.8)
  • steve626 Level 4 Level 4 (1,395 points)

    When you installed 10.6, did you also install Rosetta? It is an optional install from the 10.6 DVD. It enables older programs to run on newer Macs.

     

    http://docs.info.apple.com/article.html?path=Mac/10.6/en/27987.html

  • steve626 Level 4 Level 4 (1,395 points)

    You can follow the Apple instructions link in my previous post. (Click on the link.) Basically, you insert the 10.6 install disk and open the "Optional Installs" folder, then double click on the Optional Installs install package. You need to specify the install to disk and then select (check box) Rosetta for the optional install.

     

    Rosetta is needed for Office 2004, I believe. I think Office 2008 and later will work without Rosetta (I think).

     

    I cannot guarantee that Rosetta will solve your problem, but it won't hurt to install it and it's worth a try.

  • Király Level 6 Level 6 (9,470 points)

    If Photoshop Elements launches, you've already got Rosetta installed. No need to install it again.

     

    What happens if you log in to a different user account and open Elements there? Does it still crash?

  • steve626 Level 4 Level 4 (1,395 points)
    Currently Being Moderated
    Feb 10, 2012 10:36 AM (in response to steve626)

    If you have Rosetta properly installed and Photoshop Elements still won't run properly, I would suggest you delete the preferences file(s) and try it again. If that fails to help, uninstall it (hopefully there is an uninstaller on the install CD) and then reinstall it. It should work fine, my daughter has Photoshop CS, Photoshop Elements 6, and Photoshop Elements 3 all installed on her Macbook Air under 10.6.8 and she actually prefers Photoshop Elements 3 over the version 6 of Elements. Anyway, they all work and run fine under 10.6.8, yours should too.

  • steve626 Level 4 Level 4 (1,395 points)

    That software bundle disk is exactly how my daughter got her Photoshop Elements 3 originally (with a Wacom tablet, still in use). It was originally installed on the old iMac G5 PPC (10.5.8) I still use from time to time (like right now), and has survived being migrated to an iMac Intel C2D (upgraded to 10.6.8) 4 years later followed by migration to the Macbook Air (10.6.8). Which is why I am perplexed about your experience, but maybe something is different about Element 4 versus 3. [But we also have Elements 6 similarly migrated on all these machines as well.] We actually have purchased separate copies of Elements 3 and 6 over the years due to having it on multiple machines. Right now, both version are running on 3 machines under 10.6.8, so I think yours should work also! We need to find out how.

     

    To figure out if this a problem with the computer-wide installation or rather a local user-specific problem, try running the program from another user. If you have only one user, please create a new one and then try Photoshop Elements.

     

    If the problem is user-specific (works for users except for one user), then I suggest you move the following three files out of that user's Preferences folder to a safe location, restart, then try the program again:

     

    Photoshop Elements 3.0 Settings (a folder)

    Photoshop Elements 3.0 Paths (a folder)

    com.adobe.Photoshop.Elements.plist (a file)

     

    If the program works, then trash those files/folders that you moved and you are done. If the program still does not work for that user only, some more detective work may be needed.

     

    As for the case where the program won't work for ANY user, you may need to consider reinstalling the software. For that, it is best to uninstall it first, if you have an uninstaller on your install disk (the software bundle disk). If not, one needs to search for and remove all signs of the software (the above files, the software package itself in the Applications folder, etc.). Then reinstall.

     

    If all else fails and you have gotten tired of this, you can purchase a much newer version of Photoshop Elements (version 10, I think) that is much more capable and has been recently adapted for newer computers and operating systems. Probably ~ $100 or so. But I wouldn't give up yet.

  • steve626 Level 4 Level 4 (1,395 points)

    Shadow Destroyer wrote:

     

    Cannon MP460 print/scan/copier. Which in all the "Fun" I've been having with Photoshop not staying open I forgot to mention would print but not scan. Of course the print but not scan issue happened right after upgrade to 10.6.8.

     

     

    On the issue of the Canon MP640, I do have a specific suggestion for you to get that back up and fully functional. I have a Canon MP8120 printer/scanner (which is a wireless print/scan device) and after it was installed and fully working, whenever I upgraded a computer (one from 10.4 to 10.5; one from 10.5 to 10.6) I had to go through the full device setup and install from the original Canon CD, for the upgraded computer, following all Canon's steps precisely in exact order, to get the print AND scan functions all working properly. Just updating the drivers was not enough; I had to do a full setup, initialization, including the step that Canon calls "registering" (which has nothing to do with registering a serial number with Canon, it is a setup step that allows computers on the network to properly access the device). If you do that with your original CD for that Canon printer/scanner, I expect you will have that working again also.

  • steve626 Level 4 Level 4 (1,395 points)

    I did some looking around and did find a number of reports of problems with Adobe PS Elements 4.0 and Snow Leopard:

     

    http://www.ehow.com/list_5984926_adobe-elements-4_0-system-requirements.html

     

    Also numerous posts in Adobe forums regarding issues with Adobe PSE 4.0 and Snow Leopard. Here are couple (there are some suggestions about other files to delete to try to get it working if you still have the patience for this):

     

    http://forums.adobe.com/thread/889895

    http://forums.adobe.com/message/3792642

     

    Sort of looking like a new version of Adobe Photoshop Elements might be the best approach here. Maybe my daughter doesn't complain about her PSE 3.0 because she's now mostly using Adobe Photoshop CS4 which I know works under 10.6.

     

    As for your Plymouth Duster, those are good cars. I had a 1974 Plymouth Duster when I was a student. 360-V8, 4-barrel carb. I actually did a valve job on it at 140,000 miles (due to 7 cyclinders out of 8 firing; the engine was so powerful I hadn't even noticed). When I finally sold it, people were fighting to buy it from me. I kind of wish I had kept it, actually.

  • Nancy Rathke Level 2 Level 2 (165 points)
    Currently Being Moderated
    Jan 30, 2013 11:24 AM (in response to steve626)

    My Photoshop Elements has been crashing for a couple of weeks.  I renamed the Preferences file and now it seems to be working.

     

    However, I found my install disk and tried to re-install but it asked (of course) for the serial number, which I do not have.  Is there any way to get a dummy serial number?

  • Nancy Rathke Level 2 Level 2 (165 points)
    Currently Being Moderated
    Jan 31, 2013 11:18 AM (in response to Nancy Rathke)

    Now I have found my serial number and re-installed Photoshop Elements 4 but it is still crashing.  I tried to re-open a document I had just saved before it crashed and got the following error message:

     

    "You can’t use this version of the application Preview.app with this version of Mac OS X.

     

    You have Preview.app 3.0.9"

     

    What do I do about getting the proper version of Preview.app?

  • Király Level 6 Level 6 (9,470 points)
    Currently Being Moderated
    Jan 31, 2013 11:36 AM (in response to Nancy Rathke)

    Hi Nancy.

     

    Lots more info about your situation is needed. You should start your own thread giving details about your OS X version, what kind of Mac you have, etc. "Jacking" Shadow Destroyer's thread will result in your issue and his issue all mixed up in one thread, which makes this thread more confusing and less helpful to readers.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.