Skip navigation

Can't wake Lion over wifi (or ethernet) using iPad and home sharing.

48135 Views 227 Replies Latest reply: Mar 21, 2014 1:39 PM by IIIMOODIII RSS
1 2 3 ... 16 Previous Next
Jonathan216 Level 1 Level 1 (10 points)
Currently Being Moderated
Feb 12, 2012 1:27 AM

I've upgraded to Lion and everything's fine apart from one problem: using my iPad to access home shared iTunes content on my mac no longer works when my mac is asleep.

 

That's a change in behaviour from Snow Leopard; I used to be able to sleep my mac and then wake it over wifi using either my iPad or iPhone to access all of my home shared libraries.  The mac screen used to light up for ten seconds and then go dark again, but it served me the files.

 

Lion seems to go into a deeper sleep which it can't be woken from.  If I attempt to wake my mac from my iPad within about ten minutes of putting my mac to sleep then home sharing seems to work and lets me use the home share libraries, but if I leave it any longer than that then the mac seems to fall into a coma and can't be woken.  The weird thing is that I still see a "shared library" folder on my iPad, but when I click on it nothing happens.  I think my Time Capsule is listening for wifi access and issuing the magic packet to the mac, but the mac just ain't listening.  

 

I'm using a Time Capsule in bridge mode from an ADSL modem and I've accepted a TC firmware update last week and I'm on lion 10.7.3.  I've tried using Ethernet to connect the mac to the TC (and temporarily disabled the wifi connection) but that still doesn't work.  Also, note I'm NOT suffering from the problem that 10.7.3 seems to be giving a few other people - my mac reconnects to my wifi just fine when I wake it up manually.  For the record, This was an upgrade, so there's still a tick in "wake on network" in power settings and home sharing on iTunes is still configured the same as it was before.

 

Does anyone have any suggestions about how I can get home sharing to work when my Lion mac is asleep please?

 

Jon

iMac 27" i5-760, Mac OS X (10.6.7)
  • fzahn Calculating status...

    Hi,

     

    I have the same problem. Since update to 10.7.3 Wake on demand stopped working.

    Directly after going to sleep it is still possible to wake up the iMac, but not after 3-4 minutes....

    I have a Airport Extreme, which is the Bonjour sleep proxy server and it is not able to wake up my mac anymore.

     

    Very annoying!

     

     

    Regards

     

    Florian

  • LexSchellings Level 5 Level 5 (5,505 points)

    Did you update to 10.7.3 by the Software Update, or did you use the Combo Update? If you did it with Software Update you should reinstall with the Combo Update. If you did it with the Combo Update make sure that you used the Combo Update that came available a few days later than the first Combo Updater.

    That solves a lot of possible issues already.

    I guess doing the following can do it too, when you did the above correctly:

    uncheck "wake for network access" in Energy Saver, restart, then check it again and restart.

  • LexSchellings Level 5 Level 5 (5,505 points)

    Do you really want to wake up via Bonjour (=internet")?

  • fzahn Level 1 Level 1 (10 points)

    @LexSchellings: Bonjour Sleep Proxy server is the part of the TC or Airport Extreme, that allows doing wake on demanad, meaning wake up the imac wirelessly by accessing its ressources from inside the home network.

    It does not mean wide area bonjour, to access services from the internet.

    So Bonjour sleep proxy server is the technical part, that allow Wake on demand and is provided by Time Capsule and Airport Extreme.

     

    I did the delta update and I also tried to install the combo update and I even reinstalled from the Recovery HD.

    The problem still existed after all that: Wake on demand stopped working.

     

    But I think I got it solved by a solution I found here: I replaced the IO80211.kext againt an old one from snow leopard. Now it seems to work fine, but Airdrop (new feature from lion) is not working anymore, because this feature was not supported by the old driver. But I do not need Airdrop, but wake-on-demand...

     

    I use Wake-on-Demand to wake up my mac from either my AppleTV2 or from apart, if accesing its ressources via the "Back-to-my-mac" feature or to access EyeTV or...

    So Wake-on-Demand is very important for me.

     

    Regards

     

    Florian

  • LexSchellings Level 5 Level 5 (5,505 points)

    Jonathan:

    The reworked release of the Combo came available the 2-nd or 3-rd of Feb, if you downloaded 10.7.3 complete after that date it will be OK already, no need to instal the Combo. But you can see the exact number of 10.7.3 in System Information/ Software panel: it should be 11D50b.....

    fzahn:

    I understand, I have TC and Extreme also, no need to set anything. And indeed I understand that it may be important for (as it is for me),

    BUT even if it worked after you replaced the kext, I advise strongly not to read in an old kext over a new one, that may give other issues (you observed one already: Airdrop)... I hope you backed up the Lion one... for example such "replacing" was done in one (lousy) tool called TrimEnabler (to install Trim on a non-Apple SSD in the SnowLeopard OS): it replaced the whole kext. I read that there is a new version for Lion that just replaces the text piece that regards the identification for the Apple SSD's.... I do not dare to use such methods.... I advise to read the kext and compare the two (SL and Lion) and perhaps find a way to just replace the one string that is different (be sure it is precisely the same  lenth in caracters)...  BTW: after every update of Lion you have to do it again probably. Keep searching for a better way to solve your problem.

    Did you do the firmware update of the TC and Extreme already?

    BTW: there are two Airport Utilities for Lion: Airport Utility 5.6 and Airport Utility 6, the 5.6 is the "old" visual but in the new one 6 you can not change as many settings; if you want them both, change the name of the one you already have by putting the version number at the end of its name in Utilities, and install the other one, it will be installed additional not over.

    Lex

  • LexSchellings Level 5 Level 5 (5,505 points)

    Hi Jonathan, just the Software Update (incremental update via the Apple menu) was removed, not the full install or the Combo.

    There is a b after the number in mine.

    There is nothing wrong with running the second version of the Combo Update, it will do no harm.

    Download it here: .. Apple is doing service of this page now... Can come back soon, do not download it but from an apple site.

    Lex

  • LexSchellings Level 5 Level 5 (5,505 points)

    Yes, but these pages are in service at the moment.

    http://support.apple.com/downloads/

    there is only one Combo for Lion to 10.7.3 the first one is withdrawn....

  • LexSchellings Level 5 Level 5 (5,505 points)

    No idea's at the moment. Did you find anything in the "More Like This" threads (on the right of this thread)?

    TC latest is indeed the 7.6.1.

    Just curiosity: did the b come on to the 11D50?

    Lex

1 2 3 ... 16 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.