Skip navigation

cant see my laserjet 2100tn after installing 10.6

271 Views 4 Replies Latest reply: Dec 10, 2012 5:58 PM by geezertech RSS
pants2711 Calculating status...
Currently Being Moderated
Feb 11, 2012 10:05 AM

For some reason since I installed Snow Leopard I can't see my LaserJet 2100TN

I installed the newest drivers ... but when going to print and attempting to add a new printer, nothing shows up to select.

Any help would be greatly appreciated

  • kurt188 Level 4 Level 4 (1,325 points)
    Currently Being Moderated
    Feb 11, 2012 11:12 AM (in response to pants2711)

    Have you tried going to the "Print and Fax" pane of the system preferences, and Control-clicking into the panel at the left that would normally show installed printers?

     

    ´╗┐If not, do that and if the cursor spins, wait until it stops, and the Laserjet 2100TN should show up as a Bonjour Printer. Then click "+" to add a printer, then "more printers" and then select "HP Networking", or something similar to that wording. Then test it to see if you can actually print to it.

  • kurt188 Level 4 Level 4 (1,325 points)
    Currently Being Moderated
    Feb 12, 2012 2:18 PM (in response to pants2711)

    Is it possible that OS 10.6 no longer supports that printer?

    No. If it worked before (and it did, otherwise Apple and HP wouldn't provide drivers for it), then it still works. The issue is something in your configuration that's preventing it from being seen, which we need to figure out.

     

    Have you installed any 10.6.8 updates recently (other than printer drivers)? If not, or if you don't remember, run Software Update to see what's available and hasn't been installed, and then list it in your reply. Don't install anything yet.

  • geezertech Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 10, 2012 5:58 PM (in response to kurt188)

    Ok folks. After 4 days of frustration I finally found a wonderful lady at HP mac support who knew her stuff. If you are having problems connecting to your HP Laserjet (I have an HP Laserjet 3600. I'm told this solution will work for any "older" Laserjet models also) via your network after installing the newest drivers. Here is the solution that worked for me:

    1. Shut down your printer

    2. Connect directly with a USB cable.

    3. Turn on the printer and then select the USB printer in the Print and Fax dialogue.

    4. Print one sheet with the USB.

    5. Now install the Bonjour, IPP and or HP socket option

    6. Test print and you are finished

     

    Now the drivers can find the printer over your network. So far no failures. Oh yeah, don't forget to reserve the IP address for your LaserJet via Airport Extreme:)

     

    Hope this helps a few of you who have experienced similar issues.

    geezertech

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.