Skip navigation

TimeMachine backup problems

2435 Views 25 Replies Latest reply: May 22, 2012 3:24 PM by jokawasaki RSS
1 2 Previous Next
jokawasaki Calculating status...
Currently Being Moderated
Feb 12, 2012 6:45 PM

I'm using a LaCie 2T external HD for backup. I use Carbon Copy to back everything up to a 1.1TB partition, and TimeMachine to back up work (minus apps, music and photos) to a second partion of 250GB. Back uping was going fine until a couple of days ago when a TM message said "TM could not complete the backup. The backup requires 48.97GB but 13.88GB are available." It then goes on to tell me to select a larger backup disk or make the backup smaller.

Given that TM clear says The older backups are deleted when your disk becomes full, I cannot understand why this problem is happening now after it previously returned to the earliest backup after the partion became full. I've tried DiskUnitility's Repair Disk to no avail. Any suggestions to solve the problem, please?

  • Linc Davis Level 10 Level 10 (107,995 points)
    Currently Being Moderated
    Feb 12, 2012 8:26 PM (in response to jokawasaki)

    Launch the Console application by entering the first few letters of its name into a Spotlight search. Select "system.log" from the file list. Enter "backupd" (without the quotes) in the Filter text field. Post the messages from the last backup, beginning with "Starting standard backup." Post the log text, please, not a screenshot. Edit out excessive repeats, if any. Some personal information, such as the names of your files, may be included -- edit that out, too, but don’t remove the context.

  • Linc Davis Level 10 Level 10 (107,995 points)
    Currently Being Moderated
    Feb 13, 2012 6:25 AM (in response to jokawasaki)

    Where do I enter "backupd"?

     

    all_console.jpg

  • Linc Davis Level 10 Level 10 (107,995 points)
    Currently Being Moderated
    Feb 13, 2012 6:50 AM (in response to jokawasaki)

    There isn't enough space on your backup volume for the data you're trying to back up. You don't have any past snapshots at all, and you can't create a new one.

     

    I suggest you start a new backup set on another external hard drive at least 3x the capacity of the partition you're using now. You need more than one backup anyway -- one is not enough. Don't use that drive for anything else. Then repartition the first drive to allow at least three times as much space for TM. If that doesn't leave enough space for your mirror backup, put it on another drive, or just eliminate it. A mirror backup isn't really a necessity, just a convenience. Time Machine volumes are bootable if you back up your system files. If you don't do that, use Lion Recovery Disk Assistant to create a bootable recovery system on a USB flash drive.

     

    OS X Lion: About Lion Recovery Disk Assistant

  • etresoft Level 7 Level 7 (23,905 points)
    Currently Being Moderated
    Feb 13, 2012 7:40 AM (in response to jokawasaki)

    To add to Linc's advice, try to keep Time Machine at default settings. That is how it works best. People who complain about Time Machine almost always have some kind of funky exclusion strategy. People who just turn Time Machine on and let it run don't complain about it as much.

  • Linc Davis Level 10 Level 10 (107,995 points)
    Currently Being Moderated
    Feb 13, 2012 3:25 PM (in response to jokawasaki)

    So does this mean that even 5x the amount of required space is insuffient?

     

    No, because only files that have changed since the last backup are backed up. But I can't tell you how much backup space you need. It depends on your usage pattern. Three times the total current amount of data is just a rough estimate. If you have a lot of large files that change often, you may need much more.

  • Linc Davis Level 10 Level 10 (107,995 points)
    Currently Being Moderated
    May 18, 2012 7:00 PM (in response to jokawasaki)

    Launch the Terminal application in any of the following ways:

     

    Enter the first few letters of its name into a Spotlight search. Select it in the results (it should be at the top.)

     

    In the Finder, select Go Utilities from the menu bar, or press the key combination shift-command-U. The application is in the folder that opens.

     

    Open LaunchPad. Click Utilities, then Terminal in the page that opens.

     

    Drag or copy — do not type — the following line into the Terminal window, then press return:

     

    sudo tmutil compare

     

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.

     

    The command will take at least a few minutes to run. Eventually some lines of output will appear below what you entered.

     

    Each line that begins with a plus sign (“+”) represents a file that has been added to the source volume since the last snapshot was taken. These files have not been backed up yet.

     

    Each line that begins with an exclamation point (“!”) represents a file that has changed on the source volume. These files have been backed up, but not in their present state.

     

    Each line that begins with a minus sign (“-“) represents a file that has been removed from the source volume.

     

    Files that you’ve excluded from backup, or that are excluded automatically, are ignored.

     

    At the end of the output, you’ll get some lines like the following:

     

    -------------------------------------

    Added:

    Removed:

    Changed:

     

    These lines show the total amount of data added, removed, or changed on the source(s) since the last snapshot.

  • Linc Davis Level 10 Level 10 (107,995 points)
    Currently Being Moderated
    May 19, 2012 4:56 AM (in response to jokawasaki)

    The backup volume wasn't mounted. Mount it and try again.

  • twtwtw Level 5 Level 5 (4,580 points)
    Currently Being Moderated
    May 19, 2012 8:59 AM (in response to jokawasaki)

    I'm looking back at your console output in post 5 (before you changed partition sizes) and these two lines bother me:

     

    Feb 13 22:01:43 new-iMac com.apple.backupd[2072]: System files exclusion changed.

    Feb 13 22:01:44 new-iMac com.apple.backupd[2072]: Event store UUIDs don't match for volume: Lacie 1.15 TB general backup

     

    at that time you were backing up to the 250 Gb partition, but backupd was complaining about the 1.1 Tb partition. and in fact, the complaint is that file UUIDs don't match (which would, of course, be why it wasn't deleting old backups - it chooses files to delete based on UUIDs).

     

    I suspect you have some sort of odd interaction with CCC happening.  Are you accidentally making your time machine backups from the clone drive?  I'm asking that because that's the easiest way I can think of to get a file UUID to change; the system may not recognize the cloned drive as a clone and might assign new UUIDs to the files there.

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.