11 Replies Latest reply: May 13, 2013 8:44 AM by MSiep
davida3439 Level 1 Level 1 (0 points)

Brand new, 2011 Mac Mini, i5 model.

 

After it's asleep for a while (I haven't yet figured out how long), when I send the magic Wake-on-LAN packet, the system wakes to what I believe is the new "low-power wake" mode - the light on the front comes on solid.  The machine does not, however, respond to pings or other network services (ssh, logmein, etc).

 

However, as soon as I press a key on the keyboard or click the trackpad, the machine immediately starts responding to pings.

 

Is there a way to fully wake a mac up instead of just waking it up to low-power wake?

 

How can I troubleshoot this to figure out what's going on? I'm a pretty technical person, but I'm relatively new to Macs.


Mac mini, Mac OS X (10.7.3), Mid-2011 Core i5 Model
  • 1. Re: Wake on LAN only results in low-power wake?
    Paul_90 Level 1 Level 1 (0 points)

    Hi,

    I've been having very similar problems with my new Mac mini.

     

    I'm trying to run it without monitor and keyboard and just control it via screen sharing.

     

    Often when it wakes the screen is just black.  After much messing about I think this may be due to the low power wake feature.  There is a kernel boot parameter called "darkwake".  Setting darkwake=0 I think means that the Mac will always fully wake up - which for me is what I want since I have no monitor connected there's nothing to be gained from waking up without the screen coming on.

     

    Would be great if someone can confirm the function of the darkwake parameter and how best to switch it off and on.  Seems you have to manually edit the plist file ?

     

    Paul

  • 2. Re: Wake on LAN only results in low-power wake?
    davida3439 Level 1 Level 1 (0 points)

    Have you tested this?  I will try to test it as well.

  • 3. Re: Wake on LAN only results in low-power wake?
    Paul_90 Level 1 Level 1 (0 points)

    Not yet.  At work today - no Macs just PCs.

     

    All I've been able to do is google it to death.

    Seems some of the plist files are now binary so you need some kind of tool to edit them.

    Not sure if this applies to the

    /Library/Preferences/SystemConfiguration/com.apple.Boot.plist

    I'm hoping I can just do a text edit on that one but won't know until tonight when I get home.

     

    Paul

  • 4. Re: Wake on LAN only results in low-power wake?
    Quelqu Un Level 1 Level 1 (0 points)

    If you install (or have installed) XCode (it's free in the app store), it comes with a property list editor that can edit text and binary plists.

  • 5. Re: Wake on LAN only results in low-power wake?
    Quelqu Un Level 1 Level 1 (0 points)

    This worked for me on my MacPro.

    I did the following (please don't do this unless you're familiar with using vi and editing XML files):

     

    1. Opened a Terminal window.
    2. Changed to /Library/Preferences/SystemConfiguration by typing the following: cd /Library/Preferences/SystemConfiguration
    3. Edited com.apple.Boot.plist using vi under sudo (because the file is owned by root):
      1. sudo vi com.apple.Boot.plist
      2. Moved the insertion point down to the <string> associated with the Kernel Flags <key>
      3. Hit the "i" key to begin inserting text
      4. Typed darkwake=0
      5. Hit the "esc" key to exit insertion mode
      6. Typed ":wq" to save the file and exit
    4. Rebooted the system.

     

    And now the machine turns on all the way when I send it a magic packet.  Now I need to figure out how to turn off the "maintenance wake" feature: I'm really sick of hearing my DVD drive spin up in the middle of the night.

  • 6. Re: Wake on LAN only results in low-power wake?
    FFS, Why do I have to? Level 1 Level 1 (0 points)

    Editing the plist file seems to be working for me too although I'd suggest nano as the editor unless you're already familiar with Vi. Command would become:

     

    sudo nano com.apple.Boot.plist

  • 7. Re: Wake on LAN only results in low-power wake?
    matbro Level 1 Level 1 (0 points)

    Hi,

     

    mac mini purchased 10/2011. Running headless without keyboard/mouse, Lion 10.7.4, wired gigabit. Thanks for the fix in this post as this issue has been driving crazy for some time now. I'm using this box as iTunes server with library on samba Ubuntu server NAS. Thanks again

  • 8. Re: Wake on LAN only results in low-power wake?
    Tyrun Level 1 Level 1 (0 points)

    Thanks Quelqu Un, that fixed it!

  • 9. Re: Wake on LAN only results in low-power wake?
    HRMUser Level 1 Level 1 (0 points)

    You can also disable darkwake without using terminal commands, by following these steps:

    1. As an administrator, edit the following file: /Library/Preferences/SystemConfiguration/com.apple.Boot.plist
    2. Find the KernelFlags key and change it from:
      <key>Kernel Flags</key>
      <string>serverperfmode=1</string> to:
      <key>Kernel Flags</key>
      <string>darkwake=0</string>
    3. Reboot your Mac. Wake on LAN should now work.

     

    If you can't change the permissions. You can try right-clicking the SystemConfiguration folder, click Get info, then near the bottom of that panel unlock the lock and set your permissions there. That will open up the parent folder of the file you need to edit. Make your changes and lock it back up.

     

    Note on OSX server the oringinal content between the <string> is "serverperfmode=1", yours might be different than this.

     

     

    Can someone tell Apple in the forum to fix this issue please?

  • 10. Re: Wake on LAN only results in low-power wake?
    ClemTech Level 1 Level 1 (0 points)

    I just got my first Mac during the weekend and it's a Mac Mini Been using PC since 1990's but familiar with iOS devices (iPhone 4S and iPad2). I have been using PacketCloud app via VNC protocol to remote desktop control my PC (with WOL BIOS and NIC config enable) within the LAN but I have to use another app WiFiSendFree to WOL packet to wake up my PC first, else can not login via PocketCloud app. It has been working very well.

     

    I thought I can do the same to my Mac Mini and since WiFiSend app (paid version) can turn my iPad to a keyboard and mouse pad, I did not buy the original bluetooth keyboard and mouse from apple. Than I encounter the same problem on WOL issue with Mountain Lion OS, the WOL function in WiFiSend app does not work and I am totally logout from the Mac Mini. Luckily I did not throw away my USB PC keyboard.

     

    However, I discover a work around before reading this thread. At first, it got me to think about the bluetooth keyboard and mouse that Apple is using can send signal to the Mac Mini when it's hibernate. So, I just initiate bluetooth connection from my iPad and it woke that Mac Mini up!

     

    Again bluetooth connection has range limitation, thus will try to change the config now. Thanks.

  • 11. Re: Wake on LAN only results in low-power wake?
    MSiep Level 1 Level 1 (0 points)

    For me, the "darkwake=0" solution worked but created another problem that was not acceptable to me: Failure to enter sleep mode after the period of inactivity I specify in System Preferences / Energy Saver.

     

    I've found a workaround which is to enable "Screen Sharing" in System Preferences / Sharing - which enables connection via VNC - and then do the following when I want to connect to my MacBook Pro (early 2011) via TeamViewer:

     

    1. Wake the Mac into the low power wake state with WOL (I use the Mocha WOL app on my iPad)

    2. Connect with a VNC app (I use PocketCloud on my iPad) which fully wakes the Mac.

    3. Disconnect from VNC, since that's not actually how I want to connect.

    4. Connect with TeamViewer, which is what I want to use, but which cannot connect until the Mac is fully awake.