Skip navigation
This discussion is archived

Messenger for Mac does not connect!

24861 Views 29 Replies Latest reply: Jan 8, 2013 6:50 AM by Venkatseh RSS
  • nattles Calculating status...
    Currently Being Moderated
    Jan 22, 2011 8:10 AM (in response to Soleil6)
    Soleil6 - have a look here http://superuser.com/questions/21187/how-to-delete-the-sign-in-history-of-messen germac

    has screen prints showing you where to find it
    Macbook, Mac OS X (10.6.4)
  • Music509133 Calculating status...
    Currently Being Moderated
    Jan 23, 2011 5:44 AM (in response to gio22)
    I had this problem today and fixed it!

    Go to *username/library/preferences/Microsoft and delete the only .plist file.
    Remember to empty the trash to truly delete it.

    Close and reopen messenger and sign in - it worked for me!

    Valerie =)
    iMac 27", Mac OS X (10.6.2)
  • Music509133 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2011 5:46 AM (in response to gio22)
    Just clarifying - the file to delete is the "Microsoft Messenger User Cache.plist"
    iMac 21.5", Mac OS X (10.6.2)
  • lchgmabc Calculating status...
    Currently Being Moderated
    Jan 23, 2011 6:14 PM (in response to Kev-Sex)
    you rock!!! haha ive , i tried everything to log in, it was working till one day just stop connecting but only the windows msn i could connect using adium or Amsn but now i cleared the history and it worked!!! THX!!!!!
    2011, Mac OS X (10.6.6)
  • Reyna Maria Sagastume Bulnes Calculating status...
    Currently Being Moderated
    Jan 24, 2011 9:52 AM (in response to LeGinge)
    Wher is the clear account?
    Mac Book Pro, Mac OS X (10.6.6)
  • ocar379 Calculating status...
    Currently Being Moderated
    Sep 15, 2011 8:41 AM (in response to Music509133)

    Well, I cannot find the file, I tried deleting the account history and nothing!!! I'm kind of desperate because I really need messenger for my work!!!

  • NotUncleAl Calculating status...
    Currently Being Moderated
    Dec 23, 2011 2:31 PM (in response to gio22)

    MS Messenger 8.0.1 running under Mac OS X Lion (10.7.2) cannot login - Login (0) failed with error: (7.0) using Proxy Server.

     

    I'm running Squid proxy server under Ubuntu Linux, doing tail -f on Squid's access.log. When I click connect in Messenger, NOTHING appears in the proxy server log UNTIL AFTER Messenger gives up and pops up the dialog box that says "Sign in to Microsoft Messenger failed because the service is not available or you may not be connected to the Internet."

     

    That most likely means that the socket is being flushed as Messenger shuts-it-down, which smells like Nagle Algorithm is not being disabled on the socket.

     

    Now, there might be some kind of preference that I can set under Lion, (still learning my way around Mac OS unfortunately), but disabling the Nagle algorithm system-wide would not be a smart thing to do. (Lowering the threshold system-wide might work, but also probably not the smartest thing to do). I do get the impression that something changed in OS X Lion that caused this to break.

     

    CONCLUSION:  If you're trying to connect MSN Messenger via a Proxy server, (using HTTP), you are out-of-luck until Microsoft finds, fixes, and releases an update. :-(

     

    Possible work-arounds:

    a) I have had zero luck with version 8.0.1. I did get MSN Messenger 7.0.3 to connect while directly connected to the internet, but I had to delete the .plist file as in the above posts. (Or maybe it was the 'Clear Account History', I tried them all). Sadly, a direct connection is not an option for one of my clients.

     

    b) Adium 1.4.3 works with HTTP, but it has a known bug that apparently causes the socket to close after a period of inactivity. Result: Lost inbound messages, which is worse than having nothing at all.

     

    c) You can login to login.live.com with a WEB browser and use IM there. (But you have to keep your browser open).

     

    Up next: How about a SOCKS proxy. Will Messenger work through a SOCKS proxy? (See Spot. See Spot run. Run Spot, run!)

  • LarryGChicago Calculating status...
    Currently Being Moderated
    Feb 13, 2012 7:44 AM (in response to Kev-Sex)

    Clearing the History worked for me!  Thanks! 

  • Squeakr Calculating status...
    Currently Being Moderated
    Mar 1, 2012 1:46 PM (in response to gio22)

    I had this issue recently as well.  What I found was that Adium was working, but I was having issues with all contacts that were MSN.  I couldn't log into Messenger, but other IM apps (Adium on my Mac and Beejive on my iPhone all worked, but had issues with msn contacts).  The hint about socks and proxy got me to wondering.  I went into my settings and under proxy the HTTP setting had been selected.  De-selected and now all works again.  Not sure how that got checked as I have not been in netwrok settings in ages.

     

    Hope maybe this helps someone or leads them to a resolution for their system.

     

     

    I need to add that none of the prior fixes about clearing history or deleting plists worked, as I did implement them all over the last few days with no resolution.

  • breich99 Calculating status...
    Currently Being Moderated
    Apr 21, 2012 1:26 PM (in response to gio22)

    "When you open microsoft messenger, click sign in

    Next, select 'clear account history'

    Once cleared, quit the app and reopen it"

     

     

  • paulonevesjr Calculating status...
    Currently Being Moderated
    May 5, 2012 1:25 PM (in response to gio22)

    "When you open microsoft messenger, click sign in

    Next, select 'clear account history'

    Once cleared, quit the app and reopen it"

     

    Thanx Kev-Sex

  • Joaogs Calculating status...
    Currently Being Moderated
    Jun 20, 2012 12:54 PM (in response to Kev-Sex)

    Very good! It works!

     

    Thank you Kev-Sex-!!!

  • ahmetan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 31, 2012 12:44 PM (in response to Soleil6)

    Hi, I don't know if your problem solved or not but you can do as below.

     

    The clear history is like this you can do. On the messenger sign in screen, on the bottom side, "sign in with different account or change your online status" please click this, you will see the "clear account history" I did it ans now works fine.

  • Venkatseh Calculating status...
    Currently Being Moderated
    Jan 8, 2013 6:48 AM (in response to gio22)

    I have the same for with my messager internet connecting failure or internet is not connected but when i am using safari internet is connected and i am using mac 1.7.5.

     

    I have done all the above activities but no use

  • Venkatseh Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 8, 2013 6:50 AM (in response to gio22)

    I have the same for with my messager internet connecting failure or internet is not connected but when i am using safari internet is connected and i am using mac 1.7.5.

     

    I have done all the above

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.