Skip navigation

Duplicate songs on iPhone after iCloud download

189002 Views 116 Replies Latest reply: Mar 28, 2014 12:46 PM by bigjohnsta RSS
  • roubaixman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 22, 2011 9:57 AM (in response to gmak911)

    I'm having the same problem.  I get multiple copies of the same song on my 4s even though there is only one in my iTunes library.  Some duplicates each are playable, some are "greyed out" and there is nothing I can do with them.  Some albums I imported from CD, such as old Bowie CDs, just won't transfer to the 4s at all, no matter how I sync.  I've spent hours on the phone with Apple about these and other problems associated with iMatch and the "Cloud" and they have no idea how to fix it.  Their advice is to wait for a fix.  So much for spending hundreds of dollars on Apple Care plans (for my phone and new mac book).  I have thousands of songs and basically have given up - I'm not going to go in and manually delete all the duplicates, as suggested above, even if I could figure out how to do it. 

     

    APPLE- please fix this!!

  • ejb87 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 28, 2011 9:41 PM (in response to bdv91)

    This just happened to me too! This was my solution:

     

    On your iPhone/iTouch:

    Temporary turn off iCloud for Music - Setting > Store > and Automatic Download for Music OFF.

    *Make sure everything you want on your device is on your computer, or you well have to [re-]download that now.*

    Then go to your Music, and Delete songs, albums, or artists by side swiping them (and confirming the delete).

    Next, you will need your USB cable and Sync "the old fashioned way". xD (I'm obviously kidding about it being old fashioned everyone!!!!!)

     

    Duplicates should be gone now; at least it worked for me!   Let me know if it worked/didn't work for you, or you need me to explain steps more!

     

     

    Apple should fix this! Maybe a setting - so if we wanted, we could get a notification asking if we want it to sync "right now" or "later" though iCloud, or "manually" (by a USB cable)!

     

    P.S. Go ahead and take my idea Apple Inc., I know it's a good solution!

    This worked perfectly! Thank you so much. It DOES MATTER, by the way, WHICH DUPLICATE YOU DELETE, so test it before you delete all of them, because you may end up just transferring them all back when you sync next.

  • Papparees Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 3, 2012 3:04 PM (in response to bdv91)

    Or .....

     

    You can simply plug your iDevice into your Mac/PC (assuming you sync to that particular computer), go into the Music tab and uncheck the sync entire library option.  Than sync your phone.  Any songs remaining on your iDevice are duplicates that are not in your computer's library.

     

    NOW ... simply swipe to delete THESE songs.

     

    For safe measure I hard booted my device to make sure everything was clean.

     

    Resync'd the library.  Verified all was good.

     

    Voila. 

  • jkhcollins Level 1 Level 1 (10 points)

    Here's a twist to this problem. I was experiencing the double tracks problem and worked that out. Now, I have 1 double track left that simply will not go away. It only shows up on the iPhone, but it doesn't show up on the iPhone's contents when viewed via iTunes. But wait there's more - The track doesn't even play. It is as if it is a title assigned to a song that doesn't exist. But wait there's more - When I play the whole album straight through, it gets to that track and stops playing all together. The track does not "swipe" to delete and does not show up on iTunes to delete. I have tried deleting the entire album from the iPhone to reload it and that mystery track was still there. Hopefully I will not have to wipe off all 1600 songs from my phone and start again. Any suggestions?

  • opusnbil Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 12, 2012 8:52 AM (in response to ejb87)

    worked to get rid of duplicates, but the songs did not resync from itunes. had to download them again on my iphone, after syncing they seem to be fine. turned off the autosync for good, not worth the hassle...

  • Puffinman Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 14, 2012 8:04 PM (in response to clevercubed)

    I haven't used iCloud, but have occasionally encountered problems after syncing with iTunes on my PC, whereby I get duplicate songs and albums appearing on my iPhone, or even an album split into two with a mixture of both different songs and duplicated ones in each album.

     

    One solution I've found is as follows:

     

    1. Go into iTunes on your computer;
    2. Select the relevant songs, album or even groups of albums, so that you can deal with these multiple items in one go;
    3. Choose "Get Info";
    4. Under the "Options" tab, select the option to set everything  as "Part of a compilation";
    5. Sync with your iPhone.

     

    For me at least, just re-syncing after steps 1-4 sets everything straight. I don't need to delete any tunes/albums from my phone first, do a restore or anything like that. Hope this turns out to be a viable solution for you too.

  • JAS662 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 26, 2012 9:32 PM (in response to clevercubed)

    I am also having this problem i hope there is an update or a fix soon PLEASE!!!!!!

  • ivanfromlosone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 30, 2012 11:21 AM (in response to JAS662)

    I had issues with duplicated songs in my library,

    to fix the issue try a restore of the device.

    It did it for me.

  • ProtonVehiCROSS Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 1, 2012 12:39 AM (in response to bdv91)

    I had this problem also. This was exactly the solution that I found for myself -- hopefully Apple fixes this in a future update for iOS.

     

    bdv91 wrote:

     

    This just happened to me too! This was my solution:

     

    On your iPhone/iTouch:

    Temporary turn off iCloud for Music - Setting > Store > and Automatic Download for Music OFF.

    *Make sure everything you want on your device is on your computer, or you well have to [re-]download that now.*

    Then go to your Music, and Delete songs, albums, or artists by side swiping them (and confirming the delete).

    Next, you will need your USB cable and Sync "the old fashioned way". xD (I'm obviously kidding about it being old fashioned everyone!!!!!)

     

    Duplicates should be gone now; at least it worked for me!   Let me know if it worked/didn't work for you, or you need me to explain steps more!

     

     

    Apple should fix this! Maybe a setting - so if we wanted, we could get a notification asking if we want it to sync "right now" or "later" though iCloud, or "manually" (by a USB cable)!

     

    P.S. Go ahead and take my idea Apple Inc., I know it's a good solution!

  • Annie1639 Level 1 Level 1 (0 points)

    I have avoided iCloud so far, because of all the problems that I see on so many Support Community forums. My question, well one of hundreds, is this: do I actually HAVE to sync my iTunes with iCloud? I don't want 20 gigs of music on my iPhone, my iPad, my MacBook Pro, and my iMac. I have created numerous playlists for each device, because I use those devices in different ways. Will I be still able to just sync "the old-fashioned way" and do all my devices from the USB like we always have?

  • JAS662 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 2, 2012 12:52 PM (in response to JAS662)

    I did a restore and all is well

  • Roobbai Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2012 12:18 PM (in response to clevercubed)

    I just checked my iTunes Media folder and fixed the problem over there.

    I tried the thing with the manage media manually, but didn't fix it.

    So you may check the iTunes Media folder and see whether you can find the problem.

     

    Apparently a part of my albums were set as compilation, that's why it got duplicated.

  • mikepond Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 11, 2012 9:58 AM (in response to jkhcollins)

    I was having the same issue jk with multiple versions some of which would play and some which would not (not all my songs/albums were duplicated). I finally fixed the issue, but to be perfectly honest I am not sure which procedure actually worked so I will tell you what I did. I went through and unchecked all the affected songs/albums in iTunes and then I synced my iPhone with iTunes which removed one of the duplicates (leaving all of the unplayable tracks). I then went in and did the manual swipe across each song/album (note you can delete at the album level as well which is nice for those with a large number of tracks) which allowed me to delete straight from my iPhone. After doing that I had removed all traces of all of the duplicated songs/albums from my iPhone at which point I re-checked those same sons/albums in iTunes and then re-synced with my iPhone. Miracle of miracles it is now working.

     

    If it happens again I plan to take it into the Apple store and have them fix it and will report back to everyone on here. I tried to call about it the other evening when I realized they want me to pay to talk to someone which is ABSOLUTELY ridiculous and unacceptable. An alternative that I might recommend is filing a complaint with your credit card company for the card you used to purchase songs through iTunes since the "product" is faulty. That's sure to get Apple's attention when enough people do it.

     

    Okay I have vented enough on here. Good luck with fixing the issue everyone.

  • MPK01 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 13, 2012 8:12 AM (in response to bdv91)

    thanks BDV91, that solved it for me.  i was having the exact same problem after buying 2 albums this weekend and allowing iCloud to send it to my iphone 4s.  deleted on iphone directly, then synced via usb cable.

  • Christian201061 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 14, 2012 3:43 AM (in response to clevercubed)

    I have the same problem when moving songs from my PC onto my ipad2 via the 'cloud' - very bizarre, apple need to address the error with the particular file structure they are using.  Hopefully soon - IOS5 is great, if a little buggy. Lets hope apple in their quest for world domination are not becoming too corporate/Microsoft-ish releasing stuff before it hasa been properly and exhaustively tested.

1 2 3 4 5 6 ... 8 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (8)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.