5 Replies Latest reply: Feb 14, 2012 3:40 PM by iCare
wooley1000 Level 1 Level 1 (0 points)

After one year my Desktop imac has started to run slow. I have done the usual top ten solutions but no change.

 

Is there a way to scan an Apple for any type of virus that may have slipped under the radar?


iMac, Mac OS X (10.6.8)
  • 1. Re: After one year Imac is all of a sudden running real slow?.
    Allan Eckert Level 8 Level 8 (41,525 points)

    Since I have no idea what top 10 list you used, you are going to have to ennumerate what you did so that I don't repeat them in my suggestions.

     

    As to a virus on a Mac, there are none at this time.

     

    Allan

  • 2. Re: After one year Imac is all of a sudden running real slow?.
    Allan Jones Level 7 Level 7 (30,435 points)

    Are you running any commercial anti-virus or internet security programs? Especially any with Symantec or Norton in the name?

     

    Doing so is like chaining a one-ton weight to your car's bumper and then wodering why it won't accelerlate as is once did.

  • 3. Re: After one year Imac is all of a sudden running real slow?.
    wooley1000 Level 1 Level 1 (0 points)

    Hi Allan,

     

    Thanks for the quick response,

     

    The usual things you check for:

     

    1.Check log in items,

    2. Turn off blue tooth, speech recognition, internet sharing.

    3. System pref. labled others.

    4. Checking language & translator to see if there were other langauges that I don't need.

     

    etc, etc just basic checking stuff.

     

    Thanks for the virus update.

     

    Thanks for your time

    Mark

  • 4. Re: After one year Imac is all of a sudden running real slow?.
    wooley1000 Level 1 Level 1 (0 points)

    Hi Allan,

     

    No not running any anti virus or internet security programmes.

     

    Thanks

     

    Mark

  • 5. Re: After one year Imac is all of a sudden running real slow?.
    iCare Level 4 Level 4 (1,740 points)

    Since you've already tried a number of items without success please give these suggestions a try. Hopefully you can narrow down the issue.

     

    First check the status of your hard driveby launching the Disk Utility application that is located in the Applications/Utilities folder. Click on the Verify Disk option and observe whether it reports any major errors. You can also boot from the Install DVD that came with your system by holding down the 'c' key and then pulling down the Utilities menu bar item to select Disk Utility. Either way will work. If the disk checks out OK then click on theRepair Permissions option.

     

    To get a more detailed picture of the SMART status (hard drive error logging) you can use an application like SMART Utility which can be downloaded here. Obviously downloading a new application could be a problem if you're system is 'hanging' whenever you try to write something, so this may not be an option.

     

    http://www.volitans-software.com/smart_utility.php

     

    If you find any significant errors, make sure you back up your data if you haven't already done so. If there aren't any significant errors then go into the System Preferences and click on Users & Groups. Try creating a new user account and then log into it to see if you have the same issues. Creating a new user for test purposes will help confirm whether you are dealing with some sort of software issue.

     

    If a new user account resolves the issue then log back into the slow user account and open the Activity Monitor application located in the Applications/Utiliteis folders, then click on the CPU button. In the lower left corner you should see a summary listing the % User, % System, % Idle. What are these percentages? If the CPU idle percentage is near zero then you have a process running that is consuming your CPU time. To try and find it, pull down the menu to select 'All Processes', then click on the %CPU column to sort by the percent that each process is consuming your CPU.   The numbers constantly change, but do your best to see if there are one or two processes consuming the majority of the CPU time and post the names. Then do the same test in the new user account. I suspect you may have some process from a previously installed utility, virus checker, etc. that is keeping your system busy. I've included a screenshot from my system below. It doesn't have much going on, and as you can see in the lower left corner the CPU is basically idle most of the time. If I were to launch a CPU intensive app the numbers would change dramatically.

     

    Please share your findings so we can provide additional suggestions as we get more information from you.

    Screen Shot 2012-02-08 at 1.34.40 PM.png