Skip navigation

Mail rules in Lion not working

34590 Views 88 Replies Latest reply: Jan 29, 2014 7:04 AM by Pippin51 RSS
  • pghedges Calculating status...
    Currently Being Moderated
    Feb 6, 2012 3:33 AM (in response to Hazelmark)

    Yep. They work automatically.


    I did assign some of the function buttons, but cannot remember to use them.

  • Peace Freak! Calculating status...
    Currently Being Moderated
    Feb 15, 2012 12:26 AM (in response to phaistonian)

    I started having problems after changing some of my POP accounts to IMAP. Didn't notice it at first but my patience is beginning to get thin so I have sent Apple my 2 cents worth:

  • Standard Person Calculating status...
    Currently Being Moderated
    Mar 1, 2012 6:11 PM (in response to phaistonian)

    If you're upgrading from Snow Leopard, before starting the upgrade copy


    to somewhere safe. When the Lion upgrade has finished, copy this file to



    If you've already finished the upgrade, you should be able to grab the


    file from Time Machine and restore it to


    in Lion.

  • GuillaumeB Calculating status...
    Currently Being Moderated
    Mar 27, 2012 5:02 AM (in response to phaistonian)

    OK I have the same problem as you all.


    For a simple rule like Mark Junk Mail as read > does not work. That's for an Exchange account

  • iamoraal Calculating status...
    Currently Being Moderated
    Apr 12, 2012 1:53 PM (in response to phaistonian)

    I have had this problem since I upgraded to 10.6.8 too. Just talked to support and he sugessted turning the junk mail filter OFF. Almost half of my legitimate email was going into the junk mail folder, bypassing all my rules. So, now, having deleted all my rules, I will re-create the rules and let you all know how it turns out.

  • Peace Freak! Level 1 Level 1 (145 points)
    Currently Being Moderated
    Apr 12, 2012 3:33 PM (in response to iamoraal)

    Look forward to hearing how things turn out.

  • giantELF Calculating status...
    Currently Being Moderated
    Jul 14, 2012 10:45 AM (in response to phaistonian)

    I have the same issue but I am not using Lion.  It happens to the and address.   Before I canceled my earthnk address it was working okay.  The former are IMAP accounts and the latter was POP.


    I was hoping it was because I am using without iCloud and when I upgrade to Mountain Lion it will go away.  But I guess not.

  • giantELF Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2012 10:54 AM (in response to Peace Freak!)

    Here is the reason why we are havingin difficulty:


    If you look at your mail from any place other than Mail on your mac (webmail, iPhone, iPod, Blackberry), the mail rules will not apply. I guess because Mail sees it as a "read" message and only applies rules to "unread" messages.


    found this from here:



    We were not crazy.

  • GrantMacCubed Calculating status...
    Currently Being Moderated
    Jul 31, 2012 11:32 AM (in response to phaistonian)

    Possible Fix to the core issue:


    1. Go into each mail rule and click the "+" sign to add "Every Message" to one of the conditions for each and every rule.


    2. Also as stated earlier in this thread you want to make sure that you don't have a rule early in your list of rules that says to stop evaluating rules (by default Apple mail may have this on your first rule).


    #1 seemed to resolve the issues for me even for "read" messages, that may have been read from another device.  I'm on Lion - but about to go to Mtn Lion.

  • Matt T. Calculating status...
    Currently Being Moderated
    Jul 31, 2012 12:10 PM (in response to GrantMacCubed)

    Wouldn't the inclusion of "Every Message" apply your rule to every message (even messages to which the criteria don't apply; e.g. "Color Green if From Gmail" would color every message green)?

  • GrantMacCubed Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 31, 2012 1:17 PM (in response to Matt T.)

    I am not seeing that behavior.  After trying everything else in this thread and other threads, this one change fixed things for me.


    It should probably be noted: In general on my rules I typically have condition 1 set to measure which email address it was sent to.  Since I use Apple mail with several email accounts, I typically don't want to move a message from one mail account to a folder associated with a differnt mail account.  This is why I always have a condition to check the recipient mail address.  I also generally have the conditions bound by "All" (opposed to "Any").  So it is possible that these other factors serve as error control to the above possibility Matt.  My condition 2 is typically the from address.  My condition 3 (or last condition if I have more than 3 conditions) is the "Every Message" setting.


    Hope this helps.

  • PyroPants Calculating status...
    Currently Being Moderated
    Aug 1, 2012 11:39 PM (in response to GrantMacCubed)

    Thank you, this worked for me!


    I added a line at the end for Every Message, and changed to All conditions, and it worked.


    Been bugging me for a while, so i was delighted to see a fix.

  • GrantMacCubed Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 2, 2012 9:45 AM (in response to PyroPants)

    Good to hear.


    I can confirm also that I've now migrated to Mountain Lion, and Mail Rules are all still working with this method.  This is with an Apple .com (icloud) email account, and a email account that I access via Apple Mail.

  • Remy Leroy Level 2 Level 2 (235 points)
    Currently Being Moderated
    Aug 5, 2012 12:13 AM (in response to phaistonian)

    I'm also having an issue with mail rules and my iCloud mailboxes...

    They work just well EXCEPT for the messages that are already read (if any) directly on the iCloud webpage.


    I can't find a way to have the rules applied on every incoming message whether they are already read or not.


    I have try to add "every message" as the last condition, but it doesn't seem to do the trick (maybe because I use "If any" between my rules and not "ALL conditions")


    The strange thing is that if I select these messages in the inbox and ask to apply the rules (from the cmn-alt-L keyboard shortcut), rules are applied (and the messages are moved to the specific folders according to my rules...


    Any help will be welcome


    Many thanks in advance

  • Remy Leroy Level 2 Level 2 (235 points)
    Currently Being Moderated
    Aug 10, 2012 2:40 AM (in response to Remy Leroy)

    I've tried manythings.... to no avail, yet.


    The simpliest try I did was to create a very simple rule:


    If any condition


         Every message


    Action: move to folder "test folder"



    The rule is correctly applied to incoming messages, EXCEPT the messages that have been already read either from the iCloud Web Page or from my iPhone


    The already read messages, instead of being moved to my "test folder" remain in the INBOX. But if I select them there and manually apply the rule (cmd-shift-L keyboard shortcut), they instantly move to my test folder.




    I can't figure out how I can force the rules to be applied to each incoming message whether it is read or unread


More Like This

  • Retrieving data ...

Bookmarked By (1)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.