Skip navigation

resetting 4th gen ipod touch

346 Views 3 Replies Latest reply: Feb 17, 2012 1:03 AM by AnaMusic RSS
lomondlassie Calculating status...
Currently Being Moderated
Feb 17, 2012 12:12 AM

Hi all hope some1 can help!


I was given an ipod touch 4th gen (i think, it has dual cameras?) anyway, it was reset but now i cant get it to start up! I have wi-fi but it wont find any networks and ive tried connecting to itunes with wire but this doesnt work either on the itunes screen i get an error saying could not complete request unknown error (-9808) please help its driving me mad x

iPod touch


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.