Skip navigation

AirTunes dropouts - what to buy next?

885 Views 6 Replies Latest reply: Feb 25, 2012 6:00 PM by dfbennett RSS
Locomotief Calculating status...
Currently Being Moderated
Jan 24, 2012 2:56 AM

I have had AirTunes dropouts with my Airport Express (g, 2007) since the beginning and haven't used it for this reason for a long time. I am now looking at upgrading our modem/wireless setup and I would like to ask what I should purchase and if that is a guaranteed solution.

 

Current setup is a Thompson ST780 modem/wireless router running at "g", WPA protected. iTunes is running on the current iMac (mid 2011) and the Airport Express ("g", 2007). All are in the same (small) room. Music dropouts occur irregularly, but tend to occur more often in the evening. To try and understand the issue, I made some measurements.

 

The iMac detects 21 other wireless networks. Nevertheless, noise appears to be low (-98 using terminal command), signal strength is -48. These values do not change (much) in periods of dropouts. I did a couple of tests with 1,000 pings to google. Without streaming: packet losses are below 1 percent, average time is around 23 ms, some spikes to 200ms but standard deviation is low (5 to 10%) so these are exceptions. Whilst streaming the major statistics do not change except the outliers approach 300 ms and the stdev increases slightly (<20ms). However, during very bad dropout periods, packet loss rises to 2%, minima are still 19ms but maxima go up to 1841ms, average is now 73ms and stdev 177ms. Needless to say, surfing becomes very slow. Moreover connection to the AE is occasionally lost and it is hard to re-connect. It seems that the AirTunes problems are taking up all wifi bandwidth, as soon as it is unplugged internet works great again. Interesting is also the graph of incoming and outgoing data from the imac. Outgoing is obviously high, incoming low. Around the time of a dropout, the incoming signal goes to zero whilst outgoing remains stable. As the dropout ends, both incoming and outgoing spike for a brief moment, after which they pick up the normal pattern. Looks like buffering the missed data. Btw, I've tried all channels and also WEP incryption etc.. I am also not doing any other heavy-duty internet work, just mail. Any thought on the reason for this problem?

 

The question is, is it save to conclude that the AE will never function flawlessly in this setup and environment? Even if the wireless router is replaced by -say- an Airport Extreme? Or are there any alternatives, like assigning specific IP-addresses? And if I were to replace this unit with the latest n-AE (and obviously get an 'n' router), will the problem be solved for sure?

 

What is irritating about this issue is that technically the device is not broken (I have two, both have the same issue), but it still does not work as advertized.

iMac (27-inch Mid 2011), Mac OS X (10.7.2)
  • chambone01 Level 2 Level 2 (250 points)
    Currently Being Moderated
    Jan 24, 2012 9:43 AM (in response to Locomotief)

    I was going to suggest you check what channels other networks around you are using, but you say you already tried all channels. Anyhow, maybe it's still a good idea to use a wifi scanner and check what channels the strongest networks in your neighborhood are on, in order to configure the AE to stay away from those. If that doesn't work I don't know what else to tell you. Airtunes has become less reliable with iTunes 8 and up, but the above method fixed the problem permanently for me.

  • Mitchump Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 5, 2012 1:51 AM (in response to Locomotief)

    I have a mid 2011 iMac, an "n" Time Capsule and an "n" Airport Express. The Time Capsule is connected to my router (a BT one - I'm in the UK) with an ethernet cable and the iMac is connected to the Time Capsule with an ethernet cable too.

     

    The Airport Express is in the next room and is only used for Airtunes to my HiFi system, streamed from the iMac. I too have been suffering dropouts and these seem to have increased since upgrading to AirPort Utility 6.0 and the latest firmware updates for the TC and AE.

     

    At the moment, the AE is connected wirelessly to the network created with the TC and the iMac's internal WiFi is turned off. I have also tried setting the AE up as a separate network, turning the iMac's WiFi on and connecting to it directly. I have also tried limiting the AU to 5GHz only. In the past I have also tried selecting individual WiFi channels.

     

    None of these actions have cured the problem. I'm coming to the conclusion that the only way to het a really secure connection to the AE is to connect to it with an Ethernet cable, but that sort of defeats the object, doesn't it?

     

    I really wish this would work as it should. It's so nearly brilliant.

  • dfbennett Calculating status...
    Currently Being Moderated
    Feb 18, 2012 10:07 AM (in response to Mitchump)

    If only it were that simple! I've had the airport express G model since 2005 and it's always been troublesome. I thought I finally had the problem fixed when I decided to run an ethernet cable through the floor from one end of the room to the other. It had been working fine that way for months. Fast forward to a few days ago and I got a Airport Extreme Dual Band 5th gen to replace my poorly performing belkin router. Even when connected via ethernet, I'm having constant dropouts on the AE. The only thing that's changed in my setup is that the iMac now connects via 5ghz wireless (I was using ethernet before but I had to move one device to wireless since the Airport Extreme only has 3 ports).

     

    I think the truth is that Airplay/Airtunes is just not a very reliable technology.

  • rogerson Level 1 Level 1 (75 points)
    Currently Being Moderated
    Feb 19, 2012 12:18 PM (in response to Locomotief)

    sorry I have read, but not too technically inclined, but in my case when experiencing dropout on playback on my Airport Express using the Airplay utility (broadcasting from my Iphone), I found the error to be that I had the bluetooth on, on the phone and it seemed that periodically the phone was searching for a bluetooth device within range and dropped the airplay momentarily.  After turning off bluetooth on the phone, all was good, no more dropouts.

  • dfbennett Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 25, 2012 6:00 PM (in response to dfbennett)

    Well I'm about to eat humble pie as they say.

     

    I had thought it was my airport express dropping out all along. However, I remembered that my I'd been having drop out issues with my receivers optical input when my PS3 was connected and I switched the Airport Express to that input a while back.

     

    I ended up connecting the Airport Express with an analog cable and now it's working FLAWLESSLY. Even more surprising, it is even working very well WIRELESSLY running off my Airport Extreme's 2.4ghz network (i have the newest dual band model).

     

    So moral of the story is I was wrong   My receiver is 10 years old so I think it's starting to go and the optical input not working is the first sign of that. I ended up ordering a new receiver today so at least for me, it's not the airport express' fault.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.