Skip navigation

Can't install any printers X10.6

561 Views 8 Replies Latest reply: Feb 20, 2012 9:30 AM by friendlydrag0n RSS
friendlydrag0n Calculating status...
Currently Being Moderated
Feb 18, 2012 7:58 AM

When I try to install any printer in System Preferences>Print & Fax everything goes smoothly -- I click the + sign, find the printer I want then add it. However, it is then listed not by its real name (Canon iP3300) but as Adobe PDF 9.0.

 

If I try to print anything, the job appears for a second in the Print Queue, then disappears; text in the Print box says Starting Distiller, but nothing further happens.

 

If I re-name the printer manually, the icon changes from a generic printer icon to the proper Canon icon, but still nothing will print.

 

I have re-installed the printer, Reset the Printing System etc, still I can't print.

 

Canon have given up on me, saying tht this is Apple's problem, not theirs; Apple have given up on me, saying that it's Canon's or Adobe's problem, not theirs. I've read in the forums that there are problems installing printers under MacOSX10.6.8, but none of the threads seem to address my particular problem.

 

Please, I'm getting desperate here!

iMac (27-inch Late 2009), Mac OS X (10.6.8), Canon Pixma iP3300
  • baltwo Level 9 Level 9 (59,145 points)
    Currently Being Moderated
    Feb 18, 2012 1:42 PM (in response to friendlydrag0n)

    In the Print & Fax prefPane, remove all printers, including the Adobe thing, CONTROL-click on the printer listing and select Reset Printer System. Now, readd your printer.

    27" i7 iMac 10.6.8 , Mac OS X (10.7.3), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • baltwo Level 9 Level 9 (59,145 points)
    Currently Being Moderated
    Feb 18, 2012 2:29 PM (in response to friendlydrag0n)

    Sorry, but I don't have any Adobe apps, except reader, so I have no idea where that's coming from. Since I have no issues with my HP printers, I'm out of ideas.

    27" i7 iMac 10.6.8 , Mac OS X (10.7.3), G4 450 MP 1.5 GB RAM w/(10.5.8/10.4.11/9.2.2)
  • sanjampet Level 5 Level 5 (6,880 points)
    Currently Being Moderated
    Feb 18, 2012 2:55 PM (in response to friendlydrag0n)

    try getting rid of the adobe name and type in the actual name and click +

  • sanjampet Level 5 Level 5 (6,880 points)
    Currently Being Moderated
    Feb 20, 2012 8:47 AM (in response to friendlydrag0n)

    go to sys prefs, printers, and see what printers are in the in list. Do you see the cannon? If so try deleting itusing the  minus key and press add printer type in the printe name and model int printer firl and press + to add.

    Make sure the print que is empty. ppwer down the printer, and the Mac. Then power up the ac, then the printer and see what you get.

     

    All the best

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.