Skip navigation

wifi self-assigned ip

17710 Views 10 Replies Latest reply: Aug 18, 2012 10:38 AM by 50bike50 RSS
Bucht Calculating status...
Currently Being Moderated
Feb 19, 2012 6:47 AM

For some reason my macbook pro, running lion (10.7.3) sometimes seems incapable of getting an ip address. Every ipad and iphone in the house manages to connect to the wifi network but the mac book pro is not able to.  when i hook it up via internet this works fine but when i get on wifi, i get one of those 169 starting ip addresses and the message that the computer cannot get an IP address and cannot access the internet.

 

really frustrating.

 

i tried:

- restarting

- deleting the airport system preference file

- deleting the airport network fin in keychain

- deleting the airport network interface in preferences

 

and still no imporvement.

 

can anyone suggest something?

 

p

  • BobTheFisherman Level 6 Level 6 (10,570 points)
    Currently Being Moderated
    Feb 19, 2012 7:58 AM (in response to Bucht)

    Reboot your router. Change the wifi channel.

  • fane_j Level 4 Level 4 (3,655 points)
    Currently Being Moderated
    Feb 19, 2012 5:34 PM (in response to Bucht)

    Bucht wrote:

     

    i get one of those 169 starting ip addresses

    It's a link-local address. It shows that the MBP cannot lease an IP number from the router. Why? Can't say -- there are many different possible causes. You'll have to troubleshoot it. So far, you've two reasonable suggestions -- if they don't work, look into the router's settings. For instance, maybe it's set to give the MBP a static IP, which is already taken by another device. Also check AirPort's TCP/IP settings, make sure it matches the router's settings.

     

    You must have a great deal of patience to solve such issues, because the answers are not always obvious or intuitive.

  • Momcrna Level 1 Level 1 (5 points)
    Currently Being Moderated
    Feb 20, 2012 6:07 PM (in response to Bucht)

    POSSIBLE SOLUTION!  OK. I had this problem on my sister's macbook pro when I was beside her connected to my macbook!  The problem was the WAN network, but there is a simple solution, you might just have to play around with it.  Try the following. Just one will work. If you try the first and it doesn't work continue down the list.

     

    1. Enter a dollar sign before you enter the password to the wifi network (i.e. $abcd1234)

    2. Enter a zero-x before the password (i.e. 0xabcd1234   OR  0Xabcd1234) The x may be lower case or capital. 

    3. Put the password in quotation marks (i.e. "abcd1234").

     

    Hope this helps. I just spent 30 min on the phone with apple care (that she paid for!) and the guy told me there was nothing I could do but call my internet provider and have them change the WEP to WPA2. While this might not be a bad idea, it was not ideal and did not help with the online work she needed to do tonight for her job as it was after hours for my internet company. The guy from apple care who was surprisingly rude said it was just a know issue that macs had and nothing could be done. Funny how my daughter and I were both on the same network on our MACs! And have always used that network on our MACs! Sorry just had to vent but the above worked for me!

  • fane_j Level 4 Level 4 (3,655 points)
    Currently Being Moderated
    Feb 20, 2012 7:19 PM (in response to Momcrna)

    Momcrna wrote:

     

    POSSIBLE SOLUTION!

    No, I'm afraid this is a different issue.

    The problem was the WAN network

    What you describe has nothing to do with the WAN (Wide Area Network).

    1. Enter a dollar sign before

    You are talking about methods of entering the passphrase required to join an encrypted WiFi network. They are covered here

     

    <http://support.apple.com/kb/HT1126>

    the guy told me there was nothing I could do but call my internet provider and have them change the WEP to WPA2.

    That's very odd. You're saying you're connecting to your ISP via WiFi, which is unusual. The common set-up is to connect via WiFi to a router or access point which connects to your ISP via phone line, CATV, or fibre; the ISP has no control over your WiFi settings.

    change the WEP to WPA2. While this might not be a bad idea, it was not ideal

    You're joking. If your sister's WiFi is protected by WEP she should change it to WPA2 right now. Not soon, not in a short while, but right this minute. WEP can be broken in a matter of minutes with tools easily available on the net -- and, when I say "minutes", I mean single digits. If, indeed, she connects to her ISP by WiFi (which I doubt), and this ISP's WiFi encryption is set to WEP, cancel the contract and change the ISP immediately.

  • PollyHogg Calculating status...
    Currently Being Moderated
    Mar 27, 2012 3:22 AM (in response to Momcrna)

    "I just spent 30 min on the phone with apple care (that she paid for!) and the guy told me there was nothing I could do but call my internet provider and have them change the WEP to WPA2."

     

    ^

    That totally worked for me. I went into my router settings and changed my password to a WPA2 password and now my mac is autoconnecting again!

     

    It stopped autoconnecting about a month ago after I changed the settings on my router. Fixed now, thanks to the above.

  • fane_j Level 4 Level 4 (3,655 points)
    Currently Being Moderated
    Mar 27, 2012 4:37 AM (in response to PollyHogg)

    PollyHogg wrote:

     

    "I just spent 30 min on the phone with apple care (that she paid for!) and the guy told me there was nothing I could do but call my internet provider and have them change the WEP to WPA2."

     

    ^

    That totally worked for me. I went into my router settings

    You say that, "call my internet provider and have them change the WEP to WPA2" totally worked for you. Then you say that you went into your router settings. Which one worked for you—calling your "internet provider and have them change the WEP to WPA2", or your going into your router settings?

  • Jimmy Verner Calculating status...
    Currently Being Moderated
    Jun 5, 2012 4:07 PM (in response to Bucht)

    I spent big chunks of three days messing around with this and was just about to go back to the Borg from Redmond when it occurred to me that I could connect my Lion desktop to the Internet with an ethernet cable to my old laptop which runs 10.4. Works fine, but it is so un-Apple to have such a bad problem persist for so long.

  • 50bike50 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 18, 2012 10:38 AM (in response to Momcrna)

    After trying everything we could think of, we saw this posting.  The $ before the password worked. Why?  Who knows?  But I do not care.  Many many thanks,

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.