Skip navigation

Mail Server Relay Authentication Failure in Server Admin

6894 Views 6 Replies Latest reply: Jul 1, 2013 10:45 AM by Maverick2001 RSS
S.T.Smith Level 1 Level 1 (0 points)
Currently Being Moderated
Apr 25, 2011 9:07 AM

I need to set up Mail Server to relay through my ISP.  I know that I can authenticate to smtp.comcast.net:587 using my account and TLS usnig a mail client.

 

However, when I use Server Admin to configure my server's SMTP to send all outgoing email through this relay (Server Admin>Mail>Settings>General>

 

Rely outgoing mail through host: smtp.comcast.net:587

         Authenticate to rely with user name: user

 

I get the SMTP error:

 

SASL authentication failed: cannot authenticate to server smtp.comcast.net[76.96.62.117]: no mechanism available

 

There are no toggles on Server Admin to specify TLS or SSL or anything for authentication.

 

Does anyone know how to tell Server Admin how to authenticate an SMTP relay to smtp.comcast.net using TLS, which is apparently what comcast expects?

Mac mini, Mac OS X (10.6.7)
  • Fred de Gembloux Level 1 Level 1 (10 points)

    Hi

     

    I'm trying to setup the mail relay for my mail server (Lion Server / Postfix).

    I added the smtp_sasl_security_options = noanonymous parameter in the main.cf, reloaded the postfix config and I still get the "

    SASL authentication failed; cannot authenticate to server relay.dnsexit.com[64.182.102.186]: no mechanism available" error.

     

    I use port 26 to relay as my provider is blocking the 25.

     

    Any help would be greatly appreciated.

    F.

  • Moises R - OMTBA Level 1 Level 1 (0 points)

    I'm having the same problem even after trying all the suggestions... Please help...

  • Camelot Level 8 Level 8 (45,670 points)

    I use port 26 to relay as my provider is blocking the 25.

    What do you mean by this statement?

     

    You can't use port 26 and expect remote servers to connect to you to send mail.

    You can't connect to other servers on port 26.


    Therefore I don't understand what you mean here.

  • spekkie Calculating status...

    I had it fixed by adding the line:

     

    smtp_sasl_security_options =

     

    to the end at /etc/postfix/main.cf

     

    This seems to do the trick where it allows plain text smtp authentication. I think it is a fail in the gui for not having the option to specify the smtp authentication method.

    apple please fix.

  • Maverick2001 Calculating status...

    Just in case this helps anyone, the following worked for me with a similar relay (smart host) problem when Rackspace ended support for CRAM-MD5:

     

    sudo serveradmin set mail:postfix:smtp_sasl_security_options = "noanonymous"

     

    You may want to make sure you're using SSL too but that was not an issue for us.

     

    The changes made through the serveradmin command line utility appear to survive saved changes in the Server Admin app.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.