Skip navigation

How to change entire system permission to my account?

405 Views 7 Replies Latest reply: Feb 6, 2013 1:03 PM by nicholefrommccall RSS
Stoidy Calculating status...
Currently Being Moderated
Feb 21, 2012 4:59 PM

This is driving me crazy - more than usual.

 

Got a new (to me...actually used) Mac Pro.  Signed in as a dummy account on the Lion drive that came with it.  Transferred my old drives to the new computer, then used Migration Assistant to re-create my account on the Lion drive.

 

And now everywhere I turn I don't have permission to do this or that.  I've been overcoming it with Batchmod to a large degree, but now when I put a blank DVD in one of my two drives (I installed a new one) it spits it out and tells me I don't have permission. WHAT?

 

It also drives me crazy to have everything designated as belonging to the dummy account I created! BOO HISS.  NO... the whole **** computer and everything on it is 100% MINE and I want MY ACCOUNT to have ALL the persmissions.

 

Any simple way to do this?  What if I just delete the dummy, will it revert to me?

 

And where is the permission that is not letting me insert a blank disk???

Mac Pro, Mac OS X (10.6.8)
  • Shootist007 Level 6 Level 6 (16,640 points)
    Currently Being Moderated
    Feb 21, 2012 5:20 PM (in response to Stoidy)

    Why not d a Clean install on the newer computer and then copy over your files.

     

    Probably simpler and less time consuming.

  • Linc Davis Level 10 Level 10 (107,840 points)
    Currently Being Moderated
    Feb 21, 2012 5:51 PM (in response to Stoidy)

    You should have used Setup Assistant, not Migration Assistant, to transfer your data. I suggest you start over and do that now.

     

    OSX Tips: Setting-up a new Mac from an old one, its backups, or a PC Using Setup Assistant on Lion

  • Linc Davis Level 10 Level 10 (107,840 points)
    Currently Being Moderated
    Feb 21, 2012 6:48 PM (in response to Stoidy)

    Repairing the permissions of a home folder in Lion is a complicated procedure. I don’t know of a simpler one that always works.

     

    Launch the Terminal application by entering the first few letters of its name into a Spotlight search. Drag or copy – do not type – the following line into the window, then press return:

     

    chmod -R -N ~

     

    If you get an error message about permissions, enter this:

     

    sudo !!

     

    You'll be prompted for your login password, which won't be displayed when you type it. You may get a one-time warning not to screw up.

     

    Next, boot from your recovery partition by holding down the key combination command-R at startup. Release the keys when you see a gray screen with a spinning dial.

     

    When the recovery desktop appears, select Utilities ▹ Terminal from the menu bar.

    In the Terminal window, enter “resetpassword” (without the quotes) and press return. A Reset Password window opens.

     

    Select your boot volume if not already selected.

     

    Select your username from the menu labeled Select the user account if not already selected.

     

    Under Reset Home Directory Permissions and ACLs, click the Reset button.

     

    Select ▹ Restart from the menu bar.

  • Linc Davis Level 10 Level 10 (107,840 points)
  • nicholefrommccall Calculating status...

    Did you get all your permissions taken care of?  I have THE EXACT same issue.  Bought the Mac second hand.  Set up new user, blah blah blah.  I would love to know if this worked.  If not, what have you done to fix your "permissions" ??

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.