Skip navigation

FCPX - Compressor 5.1 Workflow

1293 Views 9 Replies Latest reply: Oct 29, 2012 12:19 AM by Overrider RSS
gh_hausi Level 1 Level 1 (5 points)
Currently Being Moderated
Feb 19, 2012 11:38 PM

My Workflow:

- edit in FCX (with 6 channels)

- export in ProRes 422 --> Result: *.mov with 6 channels (verified via "Get Info")

 

 

- Take exactly this "*.mov" to Compressor

- convert to *.m4v (modified preset "iPAD/Apple TV" - with "include 5.1 Track" checked)

- result --> *.m4v with just Stereo sound no 5.1 Track!!

 

Whats wrong ? What am I doing wrong ??

 

thanks

Hausi

Final Cut Pro X, Mac OS X (10.7.1)
  • dredcomm Level 2 Level 2 (360 points)
    Currently Being Moderated
    Feb 21, 2012 1:40 PM (in response to gh_hausi)

    Hi Hausi,

     

    Assuming your project in FCPX is set to Surround, have you tried Share > Send to Compressor instead of exporting a ProRes QuickTime Movie first?

     

    ~D

  • Voltaic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2012 3:42 AM (in response to gh_hausi)

    So I too have been struggling with this.  I have a video that I mixed in 5.1 and when I select the Apple TV 1080p preset with 5.1, Compressor only spits out a video with stereo.  Coincidentally, a straight Dolby track for DVD works fine.

     

    I'm in the middle of attempting the compression on a straight ProRES from the timeline but am baffled by this as it worked without issue just a few months ago.

     

    Has anyone else experienced this before and found a solution.

  • Voltaic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 6, 2012 6:22 PM (in response to Voltaic)

    Has no one else experienced this issue?  I still can't get a 5.1 track on any of the Apple TV presets (tried the 10mbps 1080p and 720p so far with no success).  This is such a weird thing but I have to believe someone else has seen it.  Please reply so I don't think I'm going crazy.

  • Overrider Calculating status...
    Currently Being Moderated
    Sep 8, 2012 8:57 AM (in response to Voltaic)

    this is a real strange problem. i have it too. and it is very hard to find a solution nor at apple or at the web...

     

    What i found out is, thet if i send from fcpx directly to compressor by choosing the comressor preset in fcpx. that worked.????

  • Voltaic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2012 6:25 AM (in response to gh_hausi)

    Hey everyone, I did a lot of troubleshooting on this yesterday and here is what I have learned.

     

    First let me preface that I am working with two different systems and have recreated the issue on both of them- 2009 13" MBP and a 2011 Mac Mini Server.  The issue a Mountain Lion (I know, shouldn't update production systems and all but it happened so I thought I'd give folks a heads up).

     

    In Lion, if I used any of the Apple TV presets in Compressor and ticked the "Include 5.1 Dolby" check box, viola I had my 5.1 surround.  However, when I attempt this in Mountain Lion, the 5.1 audio is created but never muxed into the final m4v that is created.  I have even gone back to old projects that worked fine with this preset and still cannot create a m4v with 5.1 audio.  Creating a standalone 5.1 mix is possible as I needed to create a DVD as well for this project but then I woudl have to use another program to mux that together, which is not as convenient as just using the preset.

     

    I have submitted this as a bug to Apple but I encourage anyone experiencing the same issue to do the same.

     

    I'm going to start a new thread since I think this issue is different than what originally was posted.

  • Voltaic Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 26, 2012 12:28 PM (in response to Voltaic)

    Hey guys, I've been posting about this in other threads but wanted to provide an update.  I emailed Apple's exec team and received two phone calls today, both stating they have received the bug reports and are reviewing the issue.  No ETA but at least they are aware of it.  I hit the panic button when 10.0.6 rolled out with the same issue.

  • Overrider Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 29, 2012 12:19 AM (in response to gh_hausi)

    FCPX Update 10.0.6 arrived 23. of Oct. with graete hope.

    A lot of nice Changes, espacialy the export has got new buttions and functions.

     

    BUT :-(

    The Dolby digital 5.1 AC3  Export ist still missing. Either in direct export mode or by sending the project to Compressor 4 for further settings. With the Apple-TV 3. Genreation preset, the AC3 dolby digital 5.1 Tracks are not included in the final File. :-(

     

    Or did I missandertand something in the workflow?

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.