Skip navigation

External SMB access not working

4320 Views 17 Replies Latest reply: Nov 20, 2012 1:34 AM by simplic RSS
1 2 Previous Next
MRCUR Level 2 Level 2 (425 points)
Currently Being Moderated
Sep 21, 2011 5:47 PM

Hi Everyone,

 

I have a Lion Server setup running behind an AirPort Extreme which acts as our firewall and router. I'm having an issue getting external SMB (Windows File Sharing as it's called now) working. AFP works just fine for everyone, while SMB is only working on the internal network. Externally, AFP works just fine, but SMB results in the standard "Server cannot be contacted, etc." error - on both Macs and Windows machines.

 

I have tried numerous times to add a port mapping for SMB within the Server app and within the AirPort Utility. It doesn't work in either spot. I've restarted the APE too many times to count, and the same with the server itself. Anyone have any ideas? Have the SMB ports changed in Lion? Any help would be greatly appreciated - I'm pulling my hair out at this point!

 

Thanks,

-MRCUR

Mac OS X (10.7.1)
  • Stress Test Level 4 Level 4 (1,265 points)
    Currently Being Moderated
    Sep 22, 2011 1:25 AM (in response to MRCUR)

    Which ports have you forwarded? 137, 138, 139, 445 TCP&UDP?

     

    I would advise to not share AFP and SMB directly to the internet. Instead configure the VPN service and go through that tunnel for accessing the files! AFP and SMB isn't secured in a single way. So build up a secure VPN tunnel for it.

  • Stress Test Level 4 Level 4 (1,265 points)
    Currently Being Moderated
    Sep 27, 2011 4:13 AM (in response to MRCUR)

    Can you check that ports from outside? Open Terminal.app (Applications > Utilities) and insert

     

    nc -v <ip-address> <port>

     

    like

     

    nc -v publicserver.mycompany.com 137

     

    Do that with the 4 ports. Do you have success on all 4 ports, and have a look if they could be reached from the internet.

  • Stress Test Level 4 Level 4 (1,265 points)
    Currently Being Moderated
    Sep 27, 2011 8:38 AM (in response to MRCUR)

    Just tried it with my server:

     

    Local server: 445 succeeded, the other not, but connecting to the server is fine

  • Stress Test Level 4 Level 4 (1,265 points)
    Currently Being Moderated
    Sep 27, 2011 8:49 AM (in response to MRCUR)

    Yes very wired. Will have a look if there's an other possibility and return here.

  • rgkeating Calculating status...
    Currently Being Moderated
    Oct 13, 2011 3:52 AM (in response to MRCUR)

    Doesn't look like this was fixed in 10.7.2 (Damnit!).  I have been using  http://www.mucommander.com/ since my Lion upgrade.

  • rickblackdog Level 1 Level 1 (5 points)
    Currently Being Moderated
    Oct 13, 2011 7:08 AM (in response to rgkeating)

    So outside your local network I assume you're using VPN?  Surely, as in all other Samba instances VPN is required to connect to a SMB share. 

  • Joe_Rhodes Calculating status...
    Currently Being Moderated
    Feb 21, 2012 8:50 PM (in response to MRCUR)

    Has anyone been able to figure this out?  I'm running into the exact same issue.  I cannot get SMB file sharing to work on a Mac Mini Lion server (10.7.3) with port forwarding done by an Airport Extreme.  (Actually, in my case, it's a Time Capsule, but the built-in file sharing's been disabled.)

     

    I've been able to get AFP (via port 548) working.  But ports 137-139 and 445, though they are forwarded by the AEX, simply don't connect.  I keep getting the "server does not exist..." error message like the original poster.

     

    As has been mentioned earlier, if I'm connected via VPN, it works fine.  Unfortunately, that's not the ultimate solution for me in this case.  And it *should* work without.  Testing the "nc -v hostname.com 139" test mentioned above fails for all ports, 137-139 and 445.  But it works fine for port 548.  I know all the ports, both TCP and UDP are forwarded.  So it pretty much has to be the SMB server running on Lion Server.

     

    I'd love to hear if anyone's got this solved...

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.