Skip navigation

After 10.5 update itunes store won't load...

44255 Views 87 Replies Latest reply: Feb 28, 2012 10:57 AM by Verde Uno RSS
  • 1OMG Calculating status...

    Thanks a million rizalfromsingapore - FINALLY iTunes store is working again!!!!!

  • amberfromperth Calculating status...
    Currently Being Moderated
    Jan 2, 2012 4:48 AM (in response to HandofPain)

    Hi there I am usingwinter net explorer 8 and since updating to version 10.5 of iTunes I can not load the iTunes store?? I don't want to uninstall my iTunes as I have over 2000 songs and don't want to lose them and I do not have time to put them onto a USB!

    Can anyone help me fix this problem? this is driving me insane

    Thank you

  • GatzB Calculating status...
    Currently Being Moderated
    Jan 14, 2012 6:52 PM (in response to HandofPain)

    i was having this problem too, i had geek squad look at it and they couldn't figure it out. I have net nany and it was blocking the internet access compeletly, then after itunes was "allowed" to acess the internet i coudln't log in. What the problem is is that un prefrences and parental, the "disable itunes box" is checked through some fluke with netnanny. Good luck!

  • MsPraise Calculating status...

    It hasn't worked for me.  I'm beginning to think nothing will.  I've even stopped hearing back from the support person that was helping me.

  • vitalsens Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 17, 2012 1:11 AM (in response to MsPraise)

    When all else failed, this worked for me -

     

    This works! A third party software is blocking your connection to itunes store and Safari!

    http://support.apple.com/kb/TS4123

    Once you identify the LSP, google the offending software and you should identify the programme doing the blocking.

    The culprit in my case was my Vodafone Mobile connect data card.

    Deleted this, restarted, itunes stores opens, reloaded latest Vodafone software, everything works.

    Good luck!

  • asenary Calculating status...
    Currently Being Moderated
    Jan 18, 2012 10:08 AM (in response to D528)

    Speed Bit Vidoe accelerator was the culpret. Thanks, it's works now.

  • restorationgirl Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 21, 2012 8:31 PM (in response to peterpaulmary)

    I feel you pain, bro. I've done winsock, installed previous version, uninstalled, reinstalled current version, checked Firewall to make sure apple and quick time have exceptions, followed several Apple website suggestions on how to fix it, internet connection is fine..... I can't even remember how many things I've done over the last week. Very, very frustrating and Apple doesn't seem to care at all about the thousands of people dealing with this - it's up to us to try to help eachother!

  • Alia2624 Level 1 Level 1 (40 points)
    Currently Being Moderated
    Feb 21, 2012 9:40 PM (in response to restorationgirl)

    im having painful slow downloads, a 22 min show thats in SD will take 90 min when it use to take 9 min

    started for me this past friday

  • D528 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 21, 2012 10:30 PM (in response to restorationgirl)

    Do you have a Video accelerator?   For instance, I was using Speed Bit Vidoe accelerator and found out that was blocking the store.

     

    I had to shut Speed Bit Video down and uninstall it.  I still use Download Accelerator Plus though which is also from Speed Bit Video.

     

    At any rate after I shut it down and uninstall it.  That is when I went to the Comman Prompt, right clicked on it to "Run as Administrator"....

     

    Then typed,          Netsh Winsock Reset     and hit Enter...    waited about 15 seconds, then closed Command Prompt and rebooted my computer. 

     

    After the computer reboot was finished....  I launched the iTunes store and it came right up.

  • BseanPT Calculating status...
    Currently Being Moderated
    Feb 23, 2012 12:50 AM (in response to Henryliu)

    Hey thanks to everyone on this thread.  I had the same problems with iPad and iPod not recognized... also had AppleMobleServiceDevice running 100% of my CPU every time I booted up (even when iTunes was not launched) and it ran wild again when I would launch iTunes... then of course I could not load the iTunes store (blank screen).

     

    What was odd was when I opened Itunes, the program would recognize if I downloaded an App from the App store on another device, and it would be added to the iTunes account... but I could not open the store...

     

    I uninstalled every program in the prescribed order and re-installed... no luck

     

    I reset the winsock as described here and it worked!  Now AppleMobileServiceDevice does not suck up CPU power or need to be stopped every time I reboot... and I can see the itunes store!!

     

    I have been fighting with this for months!!

  • Alia2624 Level 1 Level 1 (40 points)
    Currently Being Moderated
    Feb 24, 2012 9:54 AM (in response to BseanPT)

    try Autoruns (for windows)

     

    http://technet.microsoft.com/en-us/sysinternals/bb963902

     

     

    download it and it will open in winRAR

    and run the autoruns.exe and open the tab for winsock and it will show you what other programs are running and interfering with itunes

     

    it was my VPN so all I had to do was uninstall the VPN software and then I reinstalled my VPN and all was good again and I was able to get the itunes store no problem after that.

  • NasreenMunir Calculating status...
    Currently Being Moderated
    Feb 24, 2012 3:05 PM (in response to phr0stbyt3)

    Had a similar problem. I have windows XP SP3. Tried many solutions suggested in forums. That included multiple installs and uninstalls of ITunes removing several components one by one.

     

    Finally stumbled upon a solution suggesting resetting of Winsock. Used the Microsoft repair tool available at the follwoing link:http://support.microsoft.com/?kbid=299357

     

    http://support.microsoft.com/?kbid=299357

     

    It worked well.

     

    Sorry to say that I spent a lot of times with Apple and ITunes support teams, and none led to a straight solution.

     

    I thank several people on this forum who oferred various solution.

  • Verde Uno Calculating status...
    Currently Being Moderated
    Feb 28, 2012 10:57 AM (in response to vitalsens)

    This is EXACTLY the answer to my problem. Follow this one if the Winsock refresh hasn't worked. Turns out that Speedbit Video Excelerator was blocking everything.

     

    Go to this link and follow its instructions.

     

    http://support.apple.com/kb/TS4123

     

    Thanks again for everyone's input. Sometimes it takes the everyday person and not some tech dude just pushing you to other dead ends.

1 2 3 4 5 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (5)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.