Skip navigation

Strange WiFi problem on iPhone 3G after 3.0 update

965662 Views 2,123 Replies Latest reply: Feb 24, 2012 2:47 AM by Rightohh RSS
  • JudasMyGuide Level 1 Level 1 (0 points)

    Hi  I had the same problem.  But i managed to fix it.

     

    first i reset my network settings on the iphone and turned it off.  Then i unplugged my internet router for 20 seconds and let the router reboot.   After it rebooted, i turned on the iphone and  looked for my wifi connection and entered my password.  Lo an behold, I can now get wifi on my 3g.  I think the important thing here is dont just reset your router, you need to unplug it for a bit so it resets the ip

  • steve1989 Level 1 Level 1 (0 points)

    i see all over these forums that its after 3.0 other saying 2.2 and few more. i think alot of people are trying to blame the firmware after a certain time but its alot of different firmware for this to happen to.

    i have been switching from firmware to firmware over the past week from 2/3/4 and it seems that i caused this problem from upgrading firmware but not by any paticular one. obviously i don't claim blame for this. apple has forgotten their responsibilities and someone should make this obvious for future apple customers eg: channel 5 new lol.

     

    but back to the point i personnally dont blame a certain firmware but the process of putting a new one on my iphone. i have done alot of changes plus jailbroken my phone with all kinds of software and tried many workarounds. but so far nothing. basically i think you have to take it to a professional and have them replace the wifi chip or do it yourself.

     

    no point wining about spilt milk now cuz ya <edited by host> mother aint gonna come clean it up (thats apple)

    do yourself a favour and sell it for spares/repair and buy yourself a blackberry or htc. atleast microsoft try to fix your shiz for you

  • Mrsfoot Level 1 Level 1 (0 points)

    Oh well, it looks like I am joining the hundreds of you with this stupid update issue.

     

    Daughter has 3g 8gb. From updating it to os 3.1 ifi no longer works.

     

    Emailed cpw (where it was purchased), was told they know of no issue and that Apply do not know of any issue either. Now, either cpw and Apple cant read or they are lying....you choose!

     

    I have spoken to a number of consumer programmes who may be interested in this. So, if you have been affected by this and you are happy for reporter etc to ask you some questions then please email me at sue-lightfoot@hotmail.com with your details.

     

    Apple dont know about the issue??...they will soon!

     

    Sue

  • pianoplayerjohn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 15, 2011 12:59 PM (in response to Mrsfoot)

    Hi Mrsfoot,  I was having similar issues by the wifi on my  iphone being greyed out.  I have 2 iphones both 3g one for my wife and one for myself. I jailbroke and unlocked both of them because neither of us like AT&T and wanted to use T-mobile instead.  On one iphone, wifi showed up with the network address but the other one did not. Both have been upgraded to 4.2.1 and 6.15 firmware.  After hours of seeking a solution by making sure airplane mode was off and restoring the networks and lots of other things without success, I found that indeed my wifi was working when I clicked on Safari and went to my home page and other sites with no problems. Kinda weird but thankful my wifi works.

    I thought I'd share this just in case some of you might be in the same boat and have wifi even though the iphone says you don't.

     

    I hope Apple fixes this problem at some point and I thank you for your efforts. Hope this helps someone...

  • Goodmandeepinside Level 1 Level 1 (0 points)

    I was having this issue everyday and had to do a hard reset each day to make it recognize wifi.

    Got to thinking it started happening only after afew days of installing Facebook app on the phone!

    So I removed that, and believe it or not - NO problem since that day- its been aweek now

    Me happy again. :)

  • neverapplicable Level 1 Level 1 (0 points)

    I wish that was my case. I've tried basically everything and opted out of using any apps other than the basics to see if miraculously it was an app problem.. but no Why does this have to happen to all of my apple touch products.

  • jimbob18 Level 1 Level 1 (0 points)

         I have a similar problem...but a different explanation. My iPhone 4 with iOS 5 will drop my wifi connection (with 2 strength bars) and try to switch to 3G. When I am at home I turn off 3G so I will get a notification box saying "Cellular Data Is Off". As soon as I go to "Settings" it miraculously picks up wifi again!!!!!

         This is obviously a ploy by the carrier to rack up excess data charges. They don't make money when we use wifi and the fact that it picks back up AT THE EXACT MOMENT THAT I GO TO NETWORK SETTINGS is very, very SUSPICIOUS!

         I realize that you dedicated Apple types would NEVER accept collusion between Apple and the carriers but 2 months ago you never would have accepted Carrier IQ either.

  • Cedricsav Level 1 Level 1 (0 points)

    OK so it appears clear that the problem is not an isolated case, that Apple clearly knows that people can't use their phone to connect to the Internet, and that this rotten company refuses to even admit that there is a problem.
    Then it is clear that consumers such as myself, even after buying 3 Mac Book Pros and iphones will buy Samsung next.
    Thanks for making your own products unusable and making us spread the word that you'd have to be a fool to buy Apple products...

  • Rightohh Level 1 Level 1 (0 points)

    I have read most of these posts..

     

    I never post but, THIS WORKED for me..

     

    I put the ipone 3g in the deep fridge (on some plastic) left it in there for 15 minutes.

     

    BOOM WIFI worked a couple of minutes later.. But then stopped..when the phone warmed up..

     

    30 minutes later i placed the the iphone outside in the sun (hot sun) wrapping mostly in a white hanky except for the bottom of it, so covered about 2/3rds of the phone with a hanky leaveing the bottom one third exposed to sun rays..That didnt work..But...

     

    Anyway a couple of days after about 1 year of trying everything, and i mean everything..WIFI works all day every day.. Go figure..

     

    Maybe it was the fridge, or combination of both methods.. In any event i HAVE A WORKING WIFI..

1 ... 138 139 140 141 142 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.