Skip navigation

iSight does not work with online Flash-based chat sites

112801 Views 96 Replies Latest reply: Feb 24, 2012 12:51 PM by EZ Jim RSS Branched to a new discussion.
  • EZ Jim Level 7 Level 7 (21,255 points)

    anestisfromcambridge wrote:


    Well I can't get it to work.  I dont know if it's driver based or not.  What I tried was install bootcamp, put a version of windows 7.  Boot up on the PC side.  Installed the latest flash with the latest firefox and it STILL doesn't work.

    Same stuff happens on BOOTCAMP (PC) side as the mac osx side....


    I guess you have decided not to start your own topic, so I will try to offer suggestions here.  However, first, a bit of information, please:


    (1) The last post previous to yours is from user hellomauro at


    Please clarify whether the "it" you cannot get to work is hellomauro's suggestion to retreat to  Flash 10.3.


    If not, pleases explain what will not work for you.


    (2) Post as much specific info about your problem as you can including:


         (a) What Mac and Mac OS you use

              (unless you have added it to your profile )

         (b) The specifics of your problem including what browser app(s)

               and which Flash version you are using

         (c) List installed third party (non-Apple) browser software or plugins

              (sometimes called tools or toolbars?)

         (d) Whether the problem is EXACTLY the same when you test

               in more than one user account.

         (e) Whether you have noted ANY other problem with your Mac

              during the time of this trouble.


    (3) We will offer specific suggestions based on the details in your reply.



    EZ Jim



    Message was edited by: EZ Jim





    Mac Pro Quad Core (Early09) 2.93Ghz OSX 10.7.2   24" LED Cinema Display
    iPad2 iOS 5.0.1                               5th Gen AEBS
    MBP 15" i7  (Early'11) OSX 10.7.2               External iSights
    13" MBP (Mid'09) 2.26GHz OSX 10.7.2              iBook SE 366MHz OSX 10.3.9

  • k.pu110 Level 1 Level 1 (0 points)

    How exactly would you go about downgrading?  What are the steps to do so?

  • EZ Jim Level 7 Level 7 (21,255 points)

    k.pu110 wrote:


    How exactly would you go about downgrading?  What are the steps to do so?

    I would:


    (1) Restart Mac


    (2) Use Disk Utility to repair permissions


    (3) Uninstall current version.  Click ->here<- for Adobe's uninstall instructions.


    (4) Download older version.    Click ->here<- for Adobe's available archived versions.


    (5) Install the older version.    Click ->here<- for Adobe's detailed install help.


    (6) Repair permissions again.


    (7) Test older installed version.





    Message was edited by: EZ Jim




    Mac OSX 10.7.3

  • Joel Sidwell Calculating status...

    I don't know if the original issue was ever resolved, but I'll throw my 2 Cents in as I was dealing with this problem as well. After installing and re-installing several recent versions of the flash player, I decided to have it clear out all the stored information that had accumulated. The version I am sticking with for now is (running Lion). Then, I set the Camera and Mic setting to "ask me" when a site wants to use them, then specifically "allowed" the camera and mic for the sites I was having problems with. Here are the results, by browser.


    Chrome: Problem persists as before. Site can read isight but camera stays off.


    Safari: Camera actually activates and works properly with the site, but strange "double keystroke" happening in the chat box.


    Firefox: Camera works properly, as does sound and there is no typing issue. *Yay!*


    I think Chrome's problem is that it internally updates its own copy of flash to the latest version regardless of what you install in the system.


    Good luck! I hope this helps someone.

  • EZ Jim Level 7 Level 7 (21,255 points)

    Today I applied the latest Flash update ( for my Macs running the latest (10.7.3) Lion update.


    Flash works properly for me with both the latest (5.1.3) Safari and the latest (10.0.2) Firefox.


    I don't use Chrome.




    Message was edited by: EZ Jim



    Mac Pro Quad Core (Early09) 2.93Ghz OSX 10.7.3   24" LED Cinema Display
    iPad2 iOS 5.0.1                               5th Gen AEBS
    MBP 15" i7  (Early'11) OSX 10.7.3               External iSights
    13" MBP (Mid'09) 2.26GHz OSX 10.7.3              iBook SE 366MHz OSX 10.3.9

  • richard52 Calculating status...

    Hey Mr. EZ & Joel:


    I had to drop a note - downloading the older version of flash (10.3) solved the problem on Manroulette - the new version of flash was fine on all the other sites I visit).  It was a little tricky for a "greenhorn" like me to find it but I did.  I can only speculate that Manroulette is not yet set up to work with the latest version of Flash but acutally that's useless since I have no idea what I'm talking about. 


    Anyway, thanks you so much.  It was driving me crazy and I couldn't do anything else (such as something important like going to work).  But i will say, the joy of the problem being resolved is almost worth the aggravation of the problem in the first place.


    Yes, I am neurotic.   Thanks again.!!!



  • EZ Jim Level 7 Level 7 (21,255 points)
1 ... 3 4 5 6 7 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.