Skip navigation

Anyone finding Fast User Switching crashes Lion with Screensaver?

8309 Views 40 Replies Latest reply: Sep 25, 2012 3:31 PM by Kenny Velez RSS
  • Mark C. Dorison Calculating status...

    I am experiencing the same issue. Not using Parallels or Bootcamp.

  • Rainer Fux Calculating status...

    Same problem here. After all users are logged out and only the roor user is logged in, i can log out the root. But after hitting the log out button i got a grey screen and have to hard reboot.

  • Kenny Velez Level 1 Level 1 (70 points)

    Just adding myself to the troubled. I have the screensaver on the login screen locking up, sometimes beachballs. Sometimes it goes black after I get it to start up and log in. Putting my computer to sleep by hitting the back button on my imac, then waking it up usally fixes it but it shouldn't be like this. This didn't happen before I started fast user switching. I haven't tested it to see if it happens only when someone is logged in the background but I suspect it is.

  • dougfromaustin Level 1 Level 1 (0 points)

    I have the same issue.  Lion mac mini server directly from Apple.  Screen locks and turns grey when trying to switch users using fast user switching.  It waits until you enter the password and then just hangs.  Unable to press cancel but it is still possible to change focus to the finder in the background.  Very annoying bug in Lion.  I will try the suggestions of putting it to sleep by the button and then waking it by keystroke or using CTRL + F2.  I was having many SBBOD problems and that may be solved now.  I entered Lion Recovery mode, entered terminal, and typed "reserpassword" and then reset the password for all users making sure any antivirus or other processes are using the same password as the admin.

     

    APPLE please fix this annoying bug!

  • Andy Young Calculating status...

    Thanks for the Ctrl-F2 tip - very helpful. I've been running into exactly this problem.

  • BergerT Calculating status...

    I have the same problem with 10.7.4 on my new MacMini (i7 with TB).

    And today I got a call from a user - and the XServe I had updated two weeks ago to 10.7 had the screen saver running (Flurry) and the beachball. I have the same issue - Flurry running and beachball on my old Mini - and on the new one. As I never use Flurry - this is a bug - because it only happens when no user is logged in and therefore my screen-saver setting has not (yet) taken effect. IMHO it may be screen saver related !

    no solution though.

     

    NOTE: I am NOT using boot-camp; DO NOT have a BC partition. I am NOT using parallels. I do not have FUSE installed (as was suggested). The Mini runs iTunes in one account - and OSX Mail + Safari in another. NOTHING ELSE. The XServe is used as server. So it has 10.7 server installed - and nothing else. It has external VTRAK disks attached with fiber-channel. All machines (MacMini as well) are used as servers (iTunes for aTV); so they have custom screen savers "Machine name", and they have "disks never spin down" in energy settings.

  • BeekSays Calculating status...

    Same beachball occurred when switching between users. Normally works fine for me.  Quickest way out for me was the Log Out Current User keyboard shortcut:

     

    Shift+Command+Q

     

    That popped the beachball, logged out the user I was switching from (shutting down the apps that user had open gracefully), and left me at the Login Screen, from which everything then worked fine.

  • hdlbq Calculating status...

    Same beachball of death for me.

    Mac Mini Server, 10.7.4, no iTunes, no BootCamp. Expensive for a domestic server.

    I think Apple returned to its old daemons: bugged versions of OS....

    And since they revamp every time their authentification mechanisms and other stuff, no 3 party way like linux server. Darwin is open-source based isn't it ?

  • dougfromaustin Level 1 Level 1 (0 points)

    I have a mac mini server straight from Appple ( mid 2011 ) with 10.7.4.  I was using the second drive for Time machine back-up but recently added so many photos that it could no longer fit on the 500G drive.  I switched over to using an external USB2.0 3T Seagate drive and now it seems the system is much faster and is not hanging.  Can you confirm if you are doing Time Machine backup to any of the internal drives?  Thx

  • hdlbq Level 1 Level 1 (0 points)

    Hello,

    thanks for your suggestion.

    Unfortunately, I don't use Time Machine.

     

    By the way, I also tried to switch to icons for the fast switching menu, and the "magical fsck" mentionned previously, without any change.

    Best regards.

  • Kenny Velez Level 1 Level 1 (70 points)

    Maybe mentioned already but I found an easy way to wake it up instead of putting it to sleep like I was doing, the volume buttons on the keyboard does it. Of course this doesn't solve why it gets stuck in the first place.

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.