Skip navigation

TrackPad won't turn on after batteries were changed.

11944 Views 43 Replies Latest reply: Apr 11, 2014 6:57 AM by Jeop86 RSS
1 2 3 Previous Next
Will Wyatt Calculating status...
Currently Being Moderated
Jan 21, 2012 3:08 PM

Yes, they are good batteries.

 

Yes, they are the same type.

 

Yes, they've been installed correctly.

 

Yes, I know where the on/off button is.

 

When I push it, nothing happens: no light, no nothin'.

 

Thanks goodness I still have my Magic Mouse.

 

Any ideas?

Magic Trackpad, Mac OS X (10.7.2)
  • X423424X Level 6 Level 6 (14,190 points)

    Not sure what to tell you.  I would have suggested you try to re-pair with the bluetooth preferences if it were not for the fact you said you don't see the light on the TP when you pushed its switch.

     

    So some obvious question about what you said.  Did you try another set of batteries for comparison purposes?  Did you push the button long enough?

  • Rikki88 Calculating status...

    I suddenly have the same problem. I have had the Magic TrackPad for a while but I don't use it as much as my Bluetooth Magic Mighty Mouse (the original more ergonomic one not the latest almost slimmer version) – now suddenly the Magic TrackPad won't work. I find it hard to believe it is already worn out since I don't really use it regularly – hardly at all. After replacing batteries the green light will come on but only momentarily then off. I also tried to reset the Bluetooth connection however the Magic TrackPad will not be "discovered". I don't get it – no magic left in this trackpad. Running OS 10.6.8 on a MacPro Quad-Core Intel Xeon 2.8 GHz.

  • l_elephant Level 2 Level 2 (375 points)

    can you guys have access to another mac to try it on, just to see if the problem follows the pad?

  • Rikki88 Level 1 Level 1 (0 points)

    I tried the Magic TrackPad with two systems AND changed batteries and battery brands (DuraCell and Energizer). The green liight blinks, the Bluetooth setup says it recongnizes the TrackPad but when I click "Continue" to finalize the connection – I get an "Unsuccessful" message. I retried and retried but no luck.

  • l_elephant Level 2 Level 2 (375 points)
    Currently Being Moderated
    Feb 27, 2012 5:05 AM (in response to Rikki88)

    do you have any other blutooth devices on?

  • Rikki88 Level 1 Level 1 (0 points)

    Yes, I use a Bluetooth Apple Wireless Keyboard and Mighty Mouse (the rounded mouse - though I have the new multi-touch Apple Magic Mouse [don't use it] and I wear a Bose Bluetooth Headphone Series 2 with my iPhone 4S which I keep next to me all day as I work (however when I tested the trackpad I was not wearing my Bose bluetooth).

     

    My small business is wired using a broadband cable connection. Our AirPort Extreme Base Station and Time Capsule is in my back office – we also have 3 small AirPort Express stations and all devices use 802.11n.

    Only two of our computers depend on bluetooth input devices, no Bluetooth used with my iPad or our three other computers. iPod nano Gen 5 uses a NikePlus bluetooth receiver (I use daily but I disconnect when I'm not out on a run).

     

    Probably TMI but I thought you might like to know all the "wireless" signals in our office.

  • Joseph Kriz Level 5 Level 5 (5,045 points)

    Sounds like it is defective.

     

    How old is it?

    Did you buy it with your computer or separately?

     

    If you bought it with your computer and it is under a year old, it is still under warranty.

    If you have 3 year AppleCare, then it would also be under warranty if less than 3 years old.

  • Rikki88 Level 1 Level 1 (0 points)

    I bought it shortly after it was first announced. I rarely used it (I mean almost never). I thought I would but we've been so busy I just never had time to become accustomed to it — so that's really why I am surprised it seems now suddenly to be broken… it's not like I wore it out.

     

    Oh well, when I think I need it and more probably when I upgrade to Mountain Lion, I'll buy another one. Most of our Macs and Apple hardware last forever; we normally end up just decommissioning them because they can't be upgraded or have become to slow — so as mentioned I was surprised at this Trackpad failure after virtually no use.

     

    Thanks for trying to solve it, I appreciate it.

  • HACKINT0SH Level 5 Level 5 (5,750 points)
    Currently Being Moderated
    Feb 27, 2012 11:33 PM (in response to Rikki88)

    Well i've only seem stuff like this happen when the track-pad has been dropped. Perhaps it is just bad luck. But if no green light even shows, and you swear you've done all correctly, I'd get it replaced by the warranty.

     

    Do you have an AppleStore near by? Make appointment, stop by and trade it for a new one.

  • Vali31 Level 1 Level 1 (5 points)

    Hello, im having the same problem but with my magic mouse, all worked fine till batteries went off , i went to the store and got new rechargeable batteries same tipe and the mouse wont turn on, if i put with normal batteries the mouse works perfectly ! I tried different rechargeble batteries with no memory effect but same problem , wont work ! Im thinking of going back to the store and replace the mouse . I simply cant buy 1 bilion batteries just cuz my mouse wont recognize rechargeable. See if u have the same problem , coulb be the batteries and still its a problem of the mouse/ trackpad

  • RoyalsMan Level 1 Level 1 (0 points)

    I have the same problem after a new battery and it won't recognize.  ...Is there really no one on here who has the answer!?!?!

  • Rikki88 Level 1 Level 1 (0 points)

    A point of clarification: I was not using rechargeable batteries — just good quality DuraCell and Energizer. So I don't think the problem is necessarily related to rechargeable batteries.

     

    I get a Green light but the TrackPad doesn't get recognized by my computer's Bluetooth. Or I turn the TrackPad on, the Green light lights-up but will not stay lit. I use a Bluetooth keyboard and mouse with no problem so it is the TrackPad.

     

    I don't have time to take the TrackPad into an Apple Store and wait for a Genius to tell me it won't work but it is now past the warranty period so I will have to buy a new one. I can do that without leaving the office.

  • HACKINT0SH Level 5 Level 5 (5,750 points)
    Currently Being Moderated
    Apr 11, 2012 4:42 PM (in response to Rikki88)

    The light does not stay lit because it is NOT SUPPOSED TO DO THAT.

     

    Helps to read the manual first....

1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.