Skip navigation

Samsung SCX-4300 Scanner doesn't work after v.2.3 driver update

2410 Views 2 Replies Latest reply: Apr 13, 2012 6:51 AM by Loukik RSS
Lamella Level 1 Level 1 (0 points)
Currently Being Moderated
Feb 27, 2012 4:02 PM

After performing an update to the Samsung printer drivers (to these ones), my scanner for the Samsung SCX-4300 stopped working. When I load the scanning software (print and fax), all I receive is a grey screen. The Apple page for the Samsung printer software now says that the SCX-4300 can only print, not scan (see here). Reinstalling an earlier version of the driver from the Samsung website doesn't help. I cannot revert to an earlier system because I don't have Time Machine activated (I know this is kindof stupid on my part, but in my many years of computer I've honestly never needed it before).

 

I realize this problem has been addressed already in a few other discussions (see here and here). I don't want to be redundant, I just want to know if anyone has spoken with Apple or Samsung and if they have received any information about whether or not there will be another driver update that will fix this issue.

MacBook Pro, Mac OS X (10.6.8)
  • Loukik Calculating status...

    Hi there,

     

    I had the same problem, which I fixed by following a mix of instructions from this forum. The latest update from apple included samsung drives which created the problem once again and I repeated my steps to fix it again.

     

    Here is what I did:

    1. Disconnect scanner cable from computer

    2. Close image capture and all scanner/printer associated software.

    3. Using activity monitor (spotlight is your friend), terminate/quit any samsung scanner programs. No worries if there are none running. Sometimes I have noticed some leftovers

    4. Follow instructions from Mazomat here and delete Samsung Scanner.app from /library/ImageCapture/devices

    5. If you use Mackeeper, it usually alerts you to delete some more files related to Samsung scanner.app

    6. Empty trash

    7. Download samsung scanner software from website. I had downloaded v2.2 for OS X 10.7.3 and have reused it, which does the job. The latest version seems to be v3.0 I think, which I haven't tried out yet.

    8. Extract and install above software. Installation will require all applications to be quit and a restart once installed

    9. After restart, scanning through image capture and normal print works for me like a charm

     

    Hope that helps.

  • Loukik Level 1 Level 1 (0 points)

    BTW. Here is the link to v2.2 of the driver.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.