Skip navigation

Drafts multiple copies of message in Mail Drafts

25760 Views 50 Replies Latest reply: Dec 11, 2013 4:13 AM by ColinDW RSS
1 2 3 4 Previous Next
Tor Lundgren Level 2 Level 2 (235 points)
Currently Being Moderated
Feb 25, 2012 11:33 AM

Hi there,

 

This is an issue that I've noticed for a long time (years), but I wanted to check to see if there were any new ideas.

 

I often see multiple copies of messages in my drafts box.  Sometimes, these are messages that I have already sent, sometimes not.

 

Typically, I just delete them and don't worry about it.  Occasionally, I have to check to see if there a message was, in fact, sent, even though it is still in 'drafts'.

 

Really, this is more or less just a nusences, rather than a problem.

 

Any thoughts?

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Feb 28, 2012 11:42 AM (in response to Tor Lundgren)

    Uncheck to store draft messages on the server. They are syncing to the IMAP folder while you're composing a message. They won't delete like it does while storing drafts locally.

  • Glenn Leblanc Level 5 Level 5 (5,935 points)

    Sure you can. If you start a draft you need to finish later, you just have to drag or copy it from the local draft folder to the IMAP draft folder located under the main IMAP folder for that account in the sidebar.

     

    I haven't seen anyway to stop this behavior. So unless someone else knows how to change Mail's behavior on this, it's the only option other than just leaving it create the copies automatically like it's doing.

  • bug00 Level 1 Level 1 (45 points)

    I've always stored drafts on the server for years, and never had this happen until very recently (maybe the last month or so).  I was assuming it was a behavioral change with the Mail.app in the most recent Lion update, but apparently not?   Very strange. 

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Feb 29, 2012 9:52 AM (in response to bug00)

    I don't normally store drafts on the server, but I have noticed this happing in the earliest versions of Lion. So, it's not the recent update.

    I'm not sure about SL. I don't have a working SL OS to test with. I'm curious to know if it's the same in SL.

    Hope someone will test.

     

    Let me also note that if you can compose a message and send it before the IMAP folders sync, they it will be deleted from the local draft folder before it get copied to IMAP.

    So, it's a question of speed and timing.

  • John P. Level 4 Level 4 (1,145 points)

    The issue is hitting Send while Mail is saving the updated draft to the server. It happens most of the time when sending attachments, large ones are the biggest culprits.

     

    There are three fixes...err...workarounds for this:

     

    a) Uncheck "Save Drafts to Server" <–– This is hands-down the easiest way to avoid this annoyance.

     

    b) Wait for the updated draft to save to the server before hitting Send. <–– Open the Mail Activity window on the bottom-left of Mail, underneath the Mailbox List. If there is a progress bar showing, wait until it is finished before clicking "Send."

     

    c) Use webmail to send anything that has a large sub-20MB attachment.

     

    I've had this annoyance with iCloud, MobileMe, Yahoo, and Gmail. The problem isn't the IMAP server but rather Mail trying to stop the draft save while being sent. My guess is Apple engineers decided to err on the side of a duplicate message rather than delete it just in case the connection is interrupted, the end user doesn't lose the e-mail.  Apple is known to make these types of design considerations so it would come as no surprise if this was one of them.

     

    Anyway, you can test it for yourself: Compose an e-mail, attach a document somewhere between 10-15MB in size (with attachment). Open the Activity Monitor (not to be confused with the one I mentioned earlier), it's located under the menu bar "Window > Activity Monitor" and place this window to the side where it can be seen outside of Mail. Draft a composition, wait for mail to start sending draft change to the IMAP server. If you click Send on the message anytime before the draft is completed transferring, the mail will send, and you will have a duplicate Draft copy on the server.

     

    It can indeed happen when drafting a large e-mail with no attachment but it's rare to hit Send at the same time the updated draft is being saved to the server.

     

    Hope that helps!

  • bug00 Level 1 Level 1 (45 points)
    Currently Being Moderated
    Apr 3, 2012 4:37 PM (in response to John P.)

    Thank you for that solution.  I hope it helped the original poster. 

     

    Unfortunately, my problem is a bit different than this solution allows for.  I am getting multiple copies of ALL emails that I compose, regardless of size or attachments.  I honestly don't think it has anything to do with the timing of my hitting send, because it is not just keeping one draft copy that would have occurred with simultaneous "sending".  Literally, each time I check my drafts folders there are about 15-20 copies of EVERY email I have sent that day.  Any ideas for a workaround under these circumstances? 

     

    I am really hesitant to uncheck "save drafts to server" because occasionally I do want a draft that I have saved on my desktop to be editable in my iPad or iPhone (and vice versa).  So that is a tough feature to give up.

  • bug00 Level 1 Level 1 (45 points)
    Currently Being Moderated
    Apr 5, 2012 10:33 AM (in response to bug00)

    I believe I have found a solution in my case:

     

    As previously mentioned, my IMAP account was generating multiple duplicate drafts in the Drafts folder of the Mail application. 

     

    Yesterday, after removing about all the errant drafts from the Mail application's Drafts folder, I decided to take a look at the Drafts folder through the *webmail* option from the hosting company (GoDaddy).  There, I discovered an email draft contained in their webmail Drafts folder that had NOT been appearing in my Mail application's Drafts folder.  That was suspicious to me (plus it was also highly coincidental that the date of that email draft was very similar to when this problem began for me a few months ago).

     

    So I tried to trash the mysterious email draft within webmail.  After several attempts, the webmail interface was unable to simply trash this particular email...it kept reappearing.  So, instead of using the "trash" command, I tried using the "purge" command (which I believe is designed to permanently delete the email, rather than move it to the Trash folder).

     

    This worked.  The mysterious email was gone.

     

    It's been over 24 hours, and I have had NO further multiple drafts storing up in my Mail application's Drafts folder.  It is now behaving properly.  Usually within this amount of time, I would have anywhere from 100-150 repetitive drafts.  I'm very hopeful that removing this odd email draft that was only visible through the webmail interface, has somehow reset the little brain of the server's Drafts folder, and now it is communicating correctly with Mail.  YMMV...but I hope this might help someone in a similar situation.

  • bug00 Level 1 Level 1 (45 points)
    Currently Being Moderated
    Apr 8, 2012 12:51 PM (in response to bug00)

    Just an update to the above information:  it's now been 4 days since I purged that strange draft email that was only visible through the webmail feature of my IMAP account, and I have not had one single errant email draft appear within my Mail application.  So this definitely seems to have worked! 

  • iDolt Level 1 Level 1 (0 points)

    This helped me, but I can't find where to uncheck "save draft to server"

  • Glenn Leblanc Level 5 Level 5 (5,935 points)
    Currently Being Moderated
    Sep 3, 2012 3:23 PM (in response to iDolt)

    Open Mail's preferences. Click on the Account tab, select the account in the list, and click on the Mailbox Behaviors Tab.

  • Andree Level 1 Level 1 (0 points)

    Woohoo!  I had the same problem precisely and Gelnn's advice solved it in one click.  All phantom drafts immediately disappeared from my sent box.  THANK YOU!!!

  • lschaaf Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 10, 2012 7:15 AM (in response to bug00)

    I'm going to try this, I'd rather keep drafts on server because I do use multiple computers!  Though I dont have some strange draft email online....

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.