1 6 7 8 9 10 Previous Next 253 Replies Latest reply: May 15, 2014 4:29 PM by Mr Rezistor Go to original post Branched to a new discussion.
  • 105. Re: Can't Drag and Drop Anything
    paragsj Level 1 Level 1 (0 points)

    Open "Force Quit" from system menu and relaunch "Finder". This will fix the issue quickly.

  • 106. Re: Can't Drag and Drop Anything
    realcanadrian Level 1 Level 1 (0 points)

    I can confirm the virtual display driver issue, but with a piece of software that hasn't been mentioned yet. I installed the virtual display driver in Splashtop Streamer so that I could use my iPad as an external monitor via the Splashtop XDisplay app, and it caused the same issue many are experiencing here. After uninstalling the virtual display driver portion of Splashtop Streamer and rebooting, I can now drag and drop again. I have opened a ticket with Splashtop (referencing this thread), and I am posting the Splashtop details here so it may be of help to others experiencing the same issue.

     

    Looks like either Apple has a bug in the OS that conflicts with most/all virtual display drivers, or most/all purveyors of virtual display drivers have the same bug in their code. Regardless of whose fault it is, I'm sure we can all agree it should be fixed as soon as possible.

  • 107. Re: Can't Drag and Drop Anything
    ethicalid Level 1 Level 1 (0 points)

    Sleep/wake wasnt working for me so I pressed <Command> + <Alt> + <esc> to launch force quit and from there i relaunched finder, and it worked for me.......... God knows when are they going to fix it

    -Akash ANand

  • 108. Re: Can't Drag and Drop Anything
    belosh Level 1 Level 1 (0 points)

    Someone had mentioned it before, but I can't seem to find it again. If your issue is related to DisplayLink, they did release a beta 5 driver that does an auto-sleep/awake, which has been a great stop-gap for me.  I've not had any issues with it in the couple of months I've been using it.

     

    http://www.displaylink.org/forum/showthread.php?t=1276

     

    Still, it's a bad Apple bug, but this is at least one workaround.  It also fixed any empty login screen that may occur with DisplayLink being active.  At least in my experience.

  • 109. Re: Can't Drag and Drop Anything
    supersarper Level 1 Level 1 (10 points)

    hmm force quit/relaunch didn't fixed

  • 110. Re: Can't Drag and Drop Anything
    realcanadrian Level 1 Level 1 (0 points)

    By the way, the Splashtop team responded to my support ticket:

     

    Splashtop XDisplay, Jan-08 19:44 (PST):

    hi Canadrian

    Thanks for your feedback of Splashtop XDisplay and we apologize to you for the inconvenience!

    We can reproduce the issue you encountered .Our engineering is trying to find the root cause.We will let you know if this is solved in the next release. Please be patient with us.

    Should you still have any problems, please don't hesitate to write back again for assistance.

    Thanks for using the support service.



    Regards,
    Splashtop Support Team

  • 111. Re: Can't Drag and Drop Anything
    lmflora Level 1 Level 1 (0 points)

    Hello,

     

    Realcanadrian,  thanks, I had the same sticky icon problem, uninstalling the virtual display driver from splash top fixed the problem. I appreciate you posting you discovery!

     

    Cheers,

    ;-)

  • 112. Re: Can't Drag and Drop Anything
    Tibaal Level 1 Level 1 (0 points)

    I can confirm that it is some sort of display related kernel extension causing this under lion. I was using something called screen recycler. Used for five minutes, didn't like, forgot, and just remembered now. Uninstalled the kext and bam, no more sticky drag. (I can only imagine the sheer frustation of the people here who had this problem for much longer than just a couple days.)

     

    Just a side note; I did a little research, and on the Air Display website, they have this

     

    —————————————————————————————————————————————————

    IMPORTANT NOTE ABOUT AIR DISPLAY ON LION

    The Air Display host software runs well on Lion, except for Mac models with dual NVIDIA GeForce 9400M & 9600M video adapter. The Air Display driver is incompatible with these specific machines.

    Affected Mac models include:

    • 15" MacBook Pro (late 2008 and mid 2009)
    • 17" MacBook Pro (early and mid 2009).

    —————————————————————————————————————————————————

     

    at the bottom of their page. (Also, the screenrecycle app I was using was still in beta, maybe indicating a similar issue)

     

    My machine is one of the affected ones; and from what I can tell, everyone in this thread who mentioned system specs falls in this category.

     

     

    ***************************CONCLUSION********************************

    If you are on Lion, and have a late '08 / early '09 model with 9400m/9600m gt switchable,

    you will have the drag/drop issue with most, if not all screen extension drivers.

  • 113. Re: Can't Drag and Drop Anything
    MrTroyG Level 1 Level 1 (0 points)

    Putting the Mac to sleep and then waking it is a temporary solution, but it doesn't solve all issues.

     

    The problem is caused by an external display kext from 3rd party screen sharing apps like ScreenRecycler, Air Display, etc..

     

    To permanently fix the problem:

     

    1. Uninstall the offending 3rd party screen sharing application using App Zapper or Clean My Mac.

    2. Navigate to /System/Library/Extensions

    3. Wait for Finder to load all the .kext files.

    4. Delete the kext from whichever screen sharing app you had installed (i.e. ScreenRecycler.kext)

    5. Restart

     

    That should fix it.

  • 114. Re: Can't Drag and Drop Anything
    Tea Girl Level 1 Level 1 (10 points)

    Hello!

     

    I've just recently started experiencing this problem with dragging and dropping after a software update. I click on anything, files, pictures, in applications, online, and it all seems fine until I go to drop the thing. It simply won't drop.

     

    I am using a MacBook, not MacBook Pro, purchased in June 2011, currently running Mac OS X 10.6.8. The problem didn't start until January this year. I didn't have any files in my extension folder, and deleting the only .kext files on my hardrive did absolutely nothing.

     

    Does anyone have a solution for those of us who don't have issues with Kernal Extensions? It's really, really frustratingly hard to work my computer without being able to drag & drop anything.

  • 115. Re: Can't Drag and Drop Anything
    Kloogi2 Level 1 Level 1 (0 points)

    Try relaunching finder Applelogo-Forcequit-finder-restart-restart It worked for me on lion mbp 13inch mid 2010

    Hth

  • 116. Re: Can't Drag and Drop Anything
    starrygirl2112 Level 1 Level 1 (0 points)

    I'm using Windows, but I was having the same problem, and I seem to have figured out a way to fix the problem. 

    I went to the "summary" section of my iPod after clicking on the device on the left side of iTunes.  I checked the box that allowed me to "manually manage music and videos" and applied this option.  The songs are syncing!  And, yay, they're playing on my iPod now!  Hopefully, this helps anyone else who might have this problem.  There might be other issues, but this is working for now.

  • 117. Re: Can't Drag and Drop Anything
    bp21 Level 1 Level 1 (0 points)

    I had the same problem, but the sleep/wake thing didn't work. So, I hit cmd+option+esc (Force Quit), and relaunched Finder. Fixed it immediately.

  • 118. Re: Can't Drag and Drop Anything
    pentimento Level 1 Level 1 (65 points)

    Thanks! Relaunching the finder worked for me!

  • 119. Re: Can't Drag and Drop Anything
    Bill Bogard Level 2 Level 2 (215 points)

    Another twist. Problem for me started with an app called AirParrot, now drop and drag is totally messed up.  At first the drop function was broken (icon stuck to cursor).  I tried everything.  I do not have AirDisplay or any of the display kexts in extensions.  Finder relaunch unstuck the cursor from the icon, but problem came back immediately.  I reinstalled 10.7.3, no luck.  Sleep and wake function worked for a few minutes. Opened AirParrot, now Drag function is not working (cannot drag any icon).  Deleted AirParrot and its kext extension.  Still no drag. Restart does not work, Finder relaunch does not work, Sleep and Wake does not work.  Universal Access trackpad changes do not work.  AirParrot worked with Apple TV.. could the issue lie there perhaps??  I'm about to give up & tear my hair out.

     

    I'm running MackbookPro 2.66 Core 2 Duo OS 10.7.3 synching with iPad2 and iPhone 4.  Not sure what to try next.

1 6 7 8 9 10 Previous Next