1 11 12 13 14 15 Previous Next 366 Replies Latest reply: Jan 31, 2014 2:45 PM by polgriz Go to original post Branched to a new discussion.
  • 180. Re: Unable to purchase.
    Michael Mancuso Level 1 Level 1 (25 points)

    As I said, since the Supremes thought he noticed faster responses from the APP STORE after he deleted the file, I wanted to try.

  • 181. Re: Unable to purchase.
    Christofer Karlsson Level 1 Level 1 (0 points)

    Hats off for the tip about trashing the sqlitedb file! I've been free of the "could not be purchased at this time" bug for a week now. Before that I tried reset from backup, reset settings, delete and re-install apps (quite a few times), but the tip presented in this thread seem to be the only working solution. Thank you!

  • 182. Re: Unable to purchase.
    littlestar714 Level 1 Level 1 (0 points)

    For the record, I am having this same problem as well with the Unable to Purchase pop up. I read most of the posts here and it seems like the latest idea has fixed the problem. (Knock on wood). So I am going to try that. But about the problem returning, that is a good point and Apple needs to do something about it. Also for the record, the unable to download message started about a week ago, not in January. Also around the same time, my updates list started not showing. My updates badge was working, so I click it on but then there is nothing at all showing on the updates list. Nevertheless, I still click the "Update all" button and it updates whichever programs needed to be updated. The only way I can figure out which ones are updating is if I go back to the main screen right after hitting "Update All" and check to see where the blue "loading lines" are. Anyway. I dont know if this even has anything to do with the Unable to purchase popup but figured I';d throw it in there anyway because this happened around the same time as that did. Most distressing, Well, hopefully this latest idea will help as it seems to have helped many others.

  • 183. Re: Unable to purchase.
    kemajor Level 1 Level 1 (0 points)

    I have continued to work with Apple support and they sent me a new procedure to follow to see if it resolves the problem.  This is the latest...

     

    ------

    1) Tap Settings.

    2) Tap Safari.

    3) Tap Clear History.

    4) Tap Clear Cookies and Data.

    5) Then try again.

     

    It is also best if you quit App Store in multi-tasking before doing the steps above.

    -----

     

    I did this on my iPhone and iPad 2 days ago and haven't seen the error since.  Based on experience that is not long enough to say it is permanently resolved but it is a good start.  If you try this please report back with your results.  I will report back one way or the other.

     

    - KEM

  • 184. Re: Unable to purchase.
    Julius Lopez Level 1 Level 1 (45 points)

    The problem may that you have iTunes WiFi Sync enabled. I just experienced this and after reviewing some of the post realized that my iPad is set to sync with my iMac. But I was not on the same network as my iMac and iTunes WiFi Sync was enabled.

     

    With iTunes WiFi Sync enabled, your device uses your computer to sync up apps, it won't go to the App Store for them. So it goes that you can buy new apps, but when it comes to updates, it's looking for your computer for those.

     

    A few people wrote that they had noticed their devices showing up as being connected to iTunes but their device was not physically attached to the computer. This is iTunes WiFi Sync in action. So long as you have iTunes WiFi Sync enabled, your device(s) and your computer are on the same network and you have iTunes running, then your device will display as "connected" to iTunes.

     

    You have two options: Turn off iTunes WiFi Sync, or make sure you device(s) and you computer are on the same network.

     

    I'm pretty certain this should solve the mystery. Open to suggestions or corrections if I have it wrong.

  • 185. Re: Unable to purchase.
    Claidheamdanns Level 1 Level 1 (0 points)

    I'm pretty sure that's not the whole solution, because I get the problem, and my device and computer are on the same W-Fi network.

     

    The only thing that solved it for me was deleting the corrupt database file.

  • 186. Re: Unable to purchase.
    kemajor Level 1 Level 1 (0 points)

    I have tried every variation of WiFi sync settings for my devices without any success resolving this issue.

     

    The solution I posted a few messages back is still working and seems like the safest option that has had any success so far.  If I don't see the error for a week or so I'm going to consider it fixed.

     

    - KEM

  • 187. Re: Unable to purchase.
    gleff Level 1 Level 1 (0 points)

    I've been getting the Unable to Purchase error as well.. I followed the advice in this thread and it's worked great.  Thanks to everyone that discovered and advised of the fix.

     

    To help others, i've created a quick tutorial.

     

    http://www.blog.gleff.com/2012/03/app-store-unable-to-purchase-fix/

  • 188. Re: Unable to purchase.
    kingmajong Level 1 Level 1 (0 points)

       It's not related to wifi sync....   and disable wifi sync can't stop this error.

  • 189. Re: Unable to purchase.
    Lungs Level 1 Level 1 (0 points)

    This worked for me, thank you. JB

  • 190. Re: Unable to purchase.
    ThanePeters Level 1 Level 1 (0 points)

    @kingmajong's solution worked for me (iphone 4s, Mac)

     

      Finally I try new way...hope it works permanetly.

     

    I open  Itune on PC. conenct to iphone.

     

    - go to iTune store > log in APPLE account > choose your account -name on top right. > click it and put in password again

     

    -  You will go to Account information page...look down and you will see tab " reset warning all buying and download item"

     

    click it and sync iphone again...

  • 191. Re: Unable to purchase.
    TheSupremes Level 1 Level 1 (0 points)

    Well, over a week later and no more pop-ups. Thank God.

  • 192. Re: Unable to purchase.
    tdowling Level 1 Level 1 (40 points)

    FYI, for those who did happen to jailbreak their iPhones and are trying to find the database file with iExplorer, it's located in Root/private/var/mobile/Media/Downloads

  • 193. Re: Unable to purchase.
    tdferreira Level 1 Level 1 (0 points)

    This is a bug with WiFi Sync, that's almost for sure.

    I've been syncing my iPhone 4S with iTunes via USB cable, the first time I synced it via WiFi Sync, the "Unable to Purchase" error came back.

     

    This time I realized that the error contained a number of apps that were "Unable to Purchase", and that number was exactly the ammount of apps that I had updated in my iPhone after the sync (so iTunes didn't have the most recent version of those apps).

     

    So, I would bet it's a WiFi Sync problem.

     

    I've tried the iExplorer method, now let's wait and see if this is a permanent fix.

  • 194. Re: Unable to purchase.
    tdferreira Level 1 Level 1 (0 points)

    duplicate msg

1 11 12 13 14 15 Previous Next