Skip navigation

How to remove my phone number from iMessage?

133027 Views 59 Replies Latest reply: Apr 11, 2014 3:37 PM by MikeFarbr RSS Branched to a new discussion.
1 2 3 4 Previous Next
LeeBrenda Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 2, 2012 8:34 AM

Hi. I recently gave up my iPhone to switch to a non-Apple device.  While I had the iPhone, my phone number was used for iMessage.

 

Now when my friends using iPhone try to send me a message, it automatically select iMessage as Apple recognises my mobile number as an iMessage number even though I don't have an iPhone anymore.  Is there any way to remove my phone number from Apple's iMessage database?

iPhone 4, iOS 5.0.1, iMessage
  • wjosten Level 10 Level 10 (91,280 points)
    Currently Being Moderated
    Mar 2, 2012 8:42 AM (in response to LeeBrenda)

    If you registered your phone with Apple & your Apple ID, you can remove the phone from your support profile. If you didn't do that, other than putting your sim card in another iPhone & turning iMessage off, I'm not aware of any way to stop this.

  • wjosten Level 10 Level 10 (91,280 points)
  • wjosten Level 10 Level 10 (91,280 points)
    Currently Being Moderated
    Mar 2, 2012 9:11 AM (in response to LeeBrenda)

    Sorry, other than what I've told you, I don't know of any way to fix this.

  • randers4 Level 9 Level 9 (53,010 points)
    Currently Being Moderated
    Mar 2, 2012 9:45 AM (in response to LeeBrenda)

    LeeBrenda wrote:

     

    No phone number listed.

    You're looking for your old phone, not a phone number.  If the phone is listed, click Edit Products, then click the x that appear to the right of the phone to delete it.

  • mikejs75 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2012 12:30 PM (in response to LeeBrenda)

    I have exactly the same problem. I ported my number to an Android phone, and kept my iphone to use as an Ipod touch. I have taken the sim card out, wiped the phone. put the sim card back in to restore and turned off imessage completely. Nothing works. Its like my phone number is stored on some Apple imessage server somewhere and any of my friends iphones automatically see my number as an iphone still and default to imessage. Then the messages they send are never received by anything. My only course of action is to ask them to turn their imessaging service off. It is deeply frustrating.

     

    I also tried to check if it was registered but it apparently never was (I had bought a refurbished iphone from AT&T). If I login to my apple profile their are no products registered.

     

    Apple needs to get this fixed pronto, because some of us are still customers even though we may have switched our phones. And I am not a very happy customer right now.

  • evanm978 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 10, 2012 1:09 PM (in response to LeeBrenda)

    SO has this been fixed? I am having the same issue which is extremely annoying. The fact that my profile does not show any products on my profile, shows that apple has serious bugs in their system. I own an ipad and macbook .. neither are showing up there either. Apple really screwing up big time on there end with this.

  • craig9100 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 6, 2012 9:21 PM (in response to evanm978)

    this is exactly the problem I have...I move my SIM from a 3GS Iphone to Android phone, and now people with Iphones can't SMS me (as the message goes via Imessage / icloud (whatever))... I did remove my number from support profile 15min ago .. but I still not getting SMS..

     

    Regards

    Craig

  • impulse88 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 4, 2012 7:45 PM (in response to LeeBrenda)

    I have this same problem. I went to an S3 because I felt it a superior phone and now I cant get messages from two very good friends.

  • Patrick Foley III Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 6, 2012 6:36 PM (in response to LeeBrenda)

    My wife went to an S3 today I figured out how to fix this problem

    Have your friends or any one you know delete you from their phone.

    Have them restart their phones (power down then back on completely)

    Have them text your number

    Make a new entry for you.

     

    This worked for me. However your milagros may very. Or just have them reboot their phones and see if that works

    If it doesn't you will need to put your sim in their phone and turn iMessage off from your sim. If they are All on another network other than AT&T then I am at a loss however you may be able to go into AT&T and use one of their iPhones. To do this. If you are on a anything other than AT&T this also probably will not help.

  • Darklord1488 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 11, 2012 1:17 AM (in response to LeeBrenda)

    what a joke this is, i also switched to an S3 (best choice ive made!) and now i cant get texts from anyone from an iphone

     

    this is absolutly unacceptable

     

    ive called apple and they simply said 'go to messages and turn off imessage, which clearly doesnt work

     

    what a stupid product

  • craig9100 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 11, 2012 2:23 AM (in response to LeeBrenda)

    Hello all,

    I contacted Apple support, they are pretty useless.

     

    But now I found online the fix couple of weeks ago.. luckily I still had my old 3GS in the bottom of the junk draw.

     

    Steps:

    • Put the SIM back in the iMobile.
    • Startup the phone, let it register with the carrier
    • Turn ON Imessage: under Messages menu there is an option for Imessages . (if already on, turn off, and then on again)
    • Turn OFF Imessage: Messages menu etc..
    • DONE

     

     

    During this process the Iphone will send a couple of SMSs in the back ground, when the mobile changes Imessage status.. so it will cost money..

     

    Cheers

    Craig

1 2 3 4 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.