Skip navigation

Address book auto adding first and last names to company listings

752 Views 7 Replies Latest reply: Feb 27, 2013 8:13 PM by homerjsimpson8 RSS
ARod130 Calculating status...
Currently Being Moderated
Mar 3, 2012 7:35 AM

How do I get Address book to stop auto adding first and last names to company contacts?

iMac (21.5-inch Mid 2010), Mac OS X (10.6.8)
  • kurt188 Level 4 Level 4 (1,325 points)

    You would have to stop Mail and Address Book from communicating in the background, but if you do that, you'll lose the Previous Recipients address history feature, too. Are you sure you want to do that?

     

    You could just create contacts for everyone at a company that you correspond with, and assign their first and last names to each contact. As long as it matches what's in their To: header, Address Book shouldn't change it.

  • kurt188 Level 4 Level 4 (1,325 points)

    If you have a contact in Address Book and their name fields differ from what's in the From: line of their email (yes, I know I said the To: header in my previous post, but that was a typo), then your first new email from that person will add that information to the contact, even if it duplicates names.

     

    But if you have no contact card, then nothing will be added by default.

  • homerjsimpson8 Level 1 Level 1 (0 points)

    I am getting the same results as Arod130. Similarly, I have setup multiple email addresses for the same Company contact for the same reason of limiting the number of contacts that I have in my Address Book.

    The only workaround to this issue that I can see is to amend the following setting:

    Mail | Preferences | Composing | Addressing | Untick "Automatically complete addresses"

    Unfortunately, the result of this is that you lose the obvious funtion of automatically complete address when composing new emails.

    Does anyone know how to stop Address Book from automatically entering the First and Last Name fields for Company contacts without losing the function of automatically completing addresses?

     

    FYI, I am using OSX 10.7.5 (Lion) and will be upgrading to Mountain Lion in the near future to see if this fixes it for me.

  • homerjsimpson8 Level 1 Level 1 (0 points)

    Upgrading to Mountain Lion did not resolve the issue.

  • homerjsimpson8 Level 1 Level 1 (0 points)

    Try this from the Terminal:

     

    defaults write com.apple.mail SuppressAddressHistory -bool true

     

    Credit to: http://apple.stackexchange.com/questions/29788/how-to-prevent-mail-app-to-update -address-book-on-its-own

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.