Skip navigation

iPhone 4S will not autoconnect in car

16401 Views 21 Replies Latest reply: Apr 7, 2014 4:12 PM by Justin.. RSS Branched to a new discussion.
1 2 Previous Next
Pir800 Calculating status...
Currently Being Moderated
Oct 19, 2011 9:16 PM

This is very annoying. My iPhone 4S will not autoconnect to my cars Bluetooth while my iPhone 4 would autoconnect with no issues. To clarify my iPhone 4 (CDMA) has had every beta build including iOS5 GM and it never had any Bluetooth issues. I understand that Bluetooth 4.0 was introduced, but why would this affect the autoconnect?  The 4S will connect if I manually connect it under Bluetooth settings, but this is not something I should ever need to do especially when I paid a premium to own a 4S.

  • Shalimarlexia Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 20, 2011 12:50 PM (in response to Pir800)

    I am having the same problem. I however had a blackberry and never had an issue. My husband has the 4G and never had an issue in my car either. Now it connects for a second and automatically disconnects. No idea what it is.

  • wkcarp Calculating status...
    Currently Being Moderated
    Oct 21, 2011 2:25 PM (in response to Shalimarlexia)

    I have been struggling with this issue for a week.  I have a blackberry and a nokia paired to my car and both have worked flawlessly.  My new iphone 4s will pair but the bluetooth never connects it just circles forever!

  • HadiM Calculating status...
    Currently Being Moderated
    Jan 4, 2012 8:13 AM (in response to Pir800)

    I am having the same issue with my iPhone 4S. It will not reconnect automatically to my 2011 Subaru Forester stereo.  I had an iPhone 3GS that worked flawlessly.

     

    I have contacted Subaru and opened a case with them as well, but they do not seem to have such problems reported before.

  • HadiM Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 6, 2012 7:47 AM (in response to HadiM)

    I have finally figured out the reason why I was having this problem:

     

    Before pairing the new phone to the car's stereo, I made sure that I deleted the old phone entry from the car as well as the car entry from the phone. 

    I have restored the phone a couple of times from backup and from scratch and nothing seemed to make any difference.

     

    I finally noticed that every time I restored the phone, I was always using the same name. This is also the same name I was using for the old phone.

     

    So, I deleted the entries on both devices, renamed the phone to a completely different name and paired the 2 devices ...et voila!!!

     

    The new phone works flawlessly.

  • Lawrence Finch Level 7 Level 7 (24,530 points)
    Currently Being Moderated
    Jan 6, 2012 8:36 AM (in response to HadiM)

    @HadiM, congratulations on your insight.

  • jeanniefromup Calculating status...
    Currently Being Moderated
    Jan 11, 2012 7:02 PM (in response to Pir800)

    I have simalar issue.  My iphone 4s will connect but when someone call that is not in my system, they

    cannot hear me even though I can hear them.  Any suggestions?

  • alain c Calculating status...
    Currently Being Moderated
    Mar 6, 2012 7:07 AM (in response to Pir800)

    I have the same car and the same issue. Tried exactly what was proposed but the phone still doesn't autoconnect. It's a pain when you forget to select it as you can't while the car is moving. Anyway, did this solution work for you? Otherwise all the rest is fine, just need this to get working ASAP.

  • Lawrence Finch Level 7 Level 7 (24,530 points)
    Currently Being Moderated
    Mar 6, 2012 7:14 AM (in response to alain c)

    It worked for HadiM, as stated. It's also necessary to clear other pairings on both the iPhone and in the Subaru system. That should be the first step.

  • HadiM Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 6, 2012 7:15 AM (in response to alain c)

    Did you try the following steps:

    - Unpair the phone

    - On your Iphone: Go to Settings - About - Name, and change the phone's name

    - Pair the phone to the car's system

     

    This worked for me, and resolved the autoreconnect issue

  • alain c Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 6, 2012 7:56 AM (in response to HadiM)

    Been there done that, as the expression says - more than once.

    Found this on a subaru forum; will go try it in a few

     

    Before using the Hands-free system, it is necessary to register a cell phone in the system. Perform the following procedure to register a cell phone.

     

    1. Press the OFF hook switch .

    2. Select “ENGLISH”/“FRANÇAIS” by operating the “TUNE/TRACK/CH” dial. Then “WELCOME!” will be displayed.

    3. Press the “TUNE/TRACK/CH” dial or the talk switch .

    4. Select the “RECORD NAME” menu.

    5. Say the name to be registered.

    6. Select the “CONFIRM” menu. After “CAR M_MEDIA” is displayed, a pass key is displayed.

    7. Input the displayed pass key into the cell phone while “PKY: ****” is displayed. If you input the correct pass key, “PAIRED” is displayed and the registration procedure is finished. If you input an incorrect pass key, “FAILED” is displayed and the registration procedure was not successful.

  • alain c Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 6, 2012 11:09 AM (in response to Pir800)

    Pir800, try the steps (if your subaru system is the same as mine - I have a WRX) that I have posted earlier to add/pair your phone from the voice command functions or better yet refer to your owner's manual at the end of the audio section - it's a longer process but it worked.

    I went through the steps, deleted my previous phone (vocally) and added the new one and paired it.

    When I restarded my car, my iPhone 4s autoconnected HOURRA for me...

1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.