1 2 Previous Next 28 Replies Latest reply: Apr 26, 2014 4:08 PM by djunicho
calgurl855 Level 1 Level 1 (0 points)
My spell check in pages 09 is not working. It gets the very first misspelled word but after that it does not catch any of them. I am a notoriously bad speller, I copied and pasted the document into my email and there were red marks all over the place. The proofread seems to work fine. Spell checked worked fine before it just stopped working in the last couple of days. Anyone have any ideas as to how to fix this? I am a college student that desperately needs spell check!

Macbook, Mac OS X (10.6.4)
  • 1. Re: Spell Check not working
    Peggy Level 8 Level 8 (38,230 points)
    Welcome to the Apple forums

    Since it's working in Mail that points to a problem with Pages that is due to corrupt preferences. Go to HD > Users > (your account) > Library > Preferences, delete the com.apple.iwork.pages.plist, empty the Trash & then restart Pages.

  • 2. Re: Spell Check not working
    Dudester45 Level 1 Level 1 (10 points)
    I have the same problem, but its only in SOME pages documents. New documents have no problems. Currently I have 2 documents(that I know of) that will not spell check misspelled words. Spell Check is on and I've deleted the iwork.pages.plist file.
  • 3. Re: Spell Check not working
    David Robson Level 1 Level 1 (0 points)
    Check Spelling problem and work-around:

    PROBLEM

    A. Select Edit > Spelling > Check Spelling as you Type.
    B. Open Inspector > Text > More; set Language to English.
    C. Click back in the document text and watch the Language reset itself to None!
    .

    WORK-AROUND

    [1] Same as step A, above.
    [2] Enter a few words of text in the document, then Select All (Cmd-A).
    [3] Set Language to English, as in B, above
    [4] Click back in the document text and continue typing; it stays set on English and Spell Checking works.

    This is what worked for me in Pages 09, version 4.0.5. When I did this it also seemed to set the preferences so new documents are created with 'Check Spelling as you Type' active.

    Let us know if it works for you...

    Message was edited by: David Robson
  • 4. Re: Spell Check not working
    Gael Level 1 Level 1 (65 points)
    Thank You. I was having the same frustrating problem with spell check.
  • 5. Re: Spell Check not working
    dubipod Level 1 Level 1 (0 points)
    I had the same issue and it was caused from importing a google doc into pages - google doc didn't have that preset.
  • 6. Re: Spell Check not working
    Level 8 Level 8 (41,760 points)
    David Robson wrote:
    Check Spelling problem and work-around:

    PROBLEM

    A. Select Edit > Spelling > Check Spelling as you Type.
    B. Open Inspector > Text > More; set Language to English.
    C. Click back in the document text and watch the Language reset itself to None!


    It's the perfect behavior.
    You selected nothing before triggering the Inspector so you applied the style to nothing.

    Select All and repeat what you described.
    This time, as you would have done things correctly, what a surprise, the Language will be English.

    Reading carefully *_Pages User Guide_*



    you wouldn't did this error.

    Yvan KOENIG (VALLAURIS, France) vendredi 25 mars 2011 15:52:54
  • 7. Re: Spell Check not working
    Eliza Level 1 Level 1 (5 points)

    I had the same problem after importing documents from google docs.  This fixed it!! Thanks Dave!

  • 8. Re: Spell Check not working
    jason343 Level 1 Level 1 (0 points)

    I had this exact same problem and your work around explanation was great and fixed it perfectly.

     

    Thank you.

  • 9. Re: Spell Check not working
    robertofromtucson Level 1 Level 1 (0 points)

    I am having the same problem when highlighting a word I can not get the dictionary to work. Deleting the com.apple.iwork.pages.plist as suggested did not fix the problem. Can someone help?

     

    Any help would be very much appretiated.

  • 10. Re: Spell Check not working
    ScottSF Level 1 Level 1 (25 points)

    Nice! This fix worked for me using Pages '09 4.1. Thanks, David.

     

    One note: As my language was already set to English, after selecting all, I had to switch to another language (say, Deutsch) and then switch the setting back to English.

  • 11. Re: Spell Check not working
    phoo Level 1 Level 1 (10 points)

    I had the same problem both importing from Google docs and importing from Word. In one case the language kept reverting to "none". In the other, in kept reverting to British English. This fix worked in both cases.

  • 12. Re: Spell Check not working
    charliem2019 Level 1 Level 1 (35 points)

    Click edit, scroll over spelling, and make sure check spelling as you type is has a check mark next to it. If it dosen't, click on check spelling as you type and the menu will go away. Then type a bunch of random letters to make sure it is working.

     

    Charlie

  • 13. Re: Spell Check not working
    Traveling Rae Level 1 Level 1 (0 points)

    Changing the language of the document to a language other than English and then putting it back to English solved this issue for me. What an easy solution. Thank you, Scott SF.

     

    Rae.

  • 14. Re: Spell Check not working
    PeterBreis0807 Level 7 Level 7 (29,620 points)

    You can't "change the language of the document". Language is a text attribute.

     

    You can change the System Language in System Preferences and restart Pages.

     

    Peter

1 2 Previous Next