Skip navigation

PDF file will not print properly in 10.6.8 but will in 10.5.8

3013 Views 10 Replies Latest reply: Mar 8, 2012 12:20 AM by fane_j RSS
johnnyappleseedisback Level 1 Level 1 (0 points)
Currently Being Moderated
Mar 6, 2012 3:04 PM

PDF file will print out just fine in 10.5.8 and Acrobat 8, but not in 10.6.8 and Acrobat 8. Tried two different PDF files and one did print out from 10.6.8, but it contained Type 1 fonts with Ansi or Custom encoding. The second PDF file did not print out in 10.6.8 and this one contained Type 1 (CID) fonts with Identity-H encoding. Same content in both files, just encoding of fonts was different, and subsequently, the ability to print properly seemed to become compromised. Any thoughts or help would be appreciated.

Mac OS X (10.6.8)
  • ds store Level 7 Level 7 (30,305 points)

    Same hardware and drivers for both operating systems right?

     

    Have you tried printing in Preview or the free LibreOffice (also makes PDF's).

     

    I like LibreOffice as it's very open and wants to be very compatible, it might print your file just fine in either operating system.

     

     

    I should warn you that Apple isn't suppying security or stability updates for 10.5 (and likley will cut off 10.6 this summer when 10.8 is released), you need to pull your Diginotar Root Certs by hand.

     

    http://ps-enable.com/articles/diginotar-revoke-trust

  • fane_j Level 4 Level 4 (3,655 points)

    johnnyappleseedisback wrote:

     

    PDF file will print out just fine in 10.5.8 and Acrobat 8, but not in 10.6.8 and Acrobat 8.

    What printer driver? What printer? Is it a PS printer?

    Type 1 (CID) fonts with Identity-H encoding.

    Example? If I happen to have the font, I can try to see if it works on my system. I assume you've already checked that there are no duplicate fonts or other fonts conflicts on SL.

    Any thoughts

    Isolate the problem. You can't print the PDF from Acrobat 8. Any changes if you modify font embedding settings? Can you print it with Preview? Does Preview display it correctly? etc

  • sanjampet Level 5 Level 5 (6,890 points)

    make sure software is up to date

  • ds store Level 7 Level 7 (30,305 points)

    johnnyappleseedisback wrote:

     

    Yes, file will print out fine in Preview. To clarify, both files print out from Acrobat, it just that the text  prints out incorrectly in the CID version in 10.6.8. All the text characters stack up on top of each other on the left hand side of the page.

     

     

    Have you cleaned your font caches?

     

    Download the free OnyX and run all the initial checks, maintainance and then all the cleaning aspects (reboot at the end)

     

    http://www.titanium.free.fr/

     

     

    This will give your 10.6.8 system a enema of sorts and let it rebuild all the caches (corrupted) which might be responsible for your issues.

     

     

    If your still having issues, then:

     

     

    Have you uninstalled and re-installed Acrobat?

     

     

     

    Have you tried a OS X 10.6 over-write + update? 

     

    backup user data off the machine, c boot off the 10.6 disk, simply reinstall 10.6, reboot and Software Update to 10.6.8 again, reinstall any program not working from fresh sources and update

     

    (If you get a hang upon boot, hold the shift key down to disable kernel extension files and update all third party software for 10.6.8.)

     

     

    Have you tried printing the file from Acrobat from another user account on the same machine?

     

    (system preferences> accounts, use the Shared folder on root level "/" to transfer files between users)

  • ds store Level 7 Level 7 (30,305 points)

    johnnyappleseedisback wrote:

     

    I realize moving to 10.7 might solve the issue, but it just is not possible at this point.

     

    Upgrading to 10.7 won't necessarily solve this issue, just introduce new ones.

     

     

    And it seems Apple is not acknowledging this as being an actual issue.

     

    Your the only case I've seen of this, so it stands to reason it's more of a individual issue of something wrong on your machine. (corrupted file, corrupted font cache, issue with Acrobat, issue with your OS X)

     

    If it was a widespread issue, the forums would be filled with people having the same problem.

     

    Most computers have hard drives and the data on the sectors can fail, depending where they fail results in strange behaviors like yours.

     

    If it occurs in the font caches, you could get garbled text, if it occurs in Acrobat it could result in strange behavior just in Acrobat, if in OS X it could cause strange behavior all over. Sometimes it could be a support file in the User account, which creating another user account helps isolate it.

     

    So the object is to find out in the general area where it's occuring and re-write that affected area with the correct data. Font caches, program, OS X or finally User account.

     

    These bad sectors failing with your data on it is why it's important to either make a option key bootable clone of  your boot drive regularly (daily updates if your making files) or use Apple's TimeMachine (not bootable) so you can restore your machine yourself.

     

    Read more here

     

    https://discussions.apple.com/message/16276201#16276201

  • ds store Level 7 Level 7 (30,305 points)

    I just realized another possibility for your issues, you could have used a font(s) from someplace that are infected with Windows malware.

     

    Since the malware won't affect OS X, but it still can result in corrupted fonts files.

     

    Try all the other steps first, if it comes down to the third party fonts files themselves being the issue, then you'll need to reinstall them from original sources or remove them.

  • ds store Level 7 Level 7 (30,305 points)

    Well it seems you have narrowed down the issue, all I can suggest is to contact Adobe about it for a workaround or use something else that will print the PDF's besides Acrobat.

     

    I've never liked that program, too insecure too.

     

    Well good luck anyway.

  • fane_j Level 4 Level 4 (3,655 points)

    johnnyappleseedisback wrote:

     

    Epson Stylus Pro 4000

    Not PS.

     

    Tested with an Epson ME330 (multifunction, no PS of course). Doc w/ CID fonts (Century and Heiti Std).

     

    InDesign → print: no problem

    InDesign → PDF → Acrobat Pro v9.4.6 → print: no output, no error message

    InDesign → PDF → Preview → print: no problem

     

    If CIDs replaced with Type 1 (Minion Pro) → no problem with any option

    Here is some light reading, the one from TidBITS is particularly on point.

    I'm fairly certain that this issue is not the issue discussed in the TidBITS article. Different font types are involved, different symptoms (there the display, as well as printout, was defective), and that problem was resolved by an update

     

    <http://support.apple.com/kb/HT4605>

     

    I haven't figured out what the problem is. It must be related to CID (Century is OT/TT, Heiti is OT/PS) -- but does it also occur with PostScript printers? Or non-Epson printers?

     

    I did notice two curious items which might be connected.

     

    First, however I changed ID settings in both Prefs > General and in PDF export, I couldn't get ID to embed an entire CID font in a PDF doc. This seems to be a bug. (According to Font Book, both Century and Heiti are embeddable.)

     

    Second, in Acrobat > Advanced > PDF Optimizer > Fonts, the CID fonts do not appear in the Embedded fonts list -- only non-CID fonts do. This also seems to be a bug.

     

    This suggests that it is possible that the problem could be related to the way Adobe software handles CID fonts.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.