Skip navigation

Lion WiFi Connection Problem

667131 Views 2,667 Replies Latest reply: Apr 19, 2014 9:11 AM by gphonei RSS
  • Carlo TD Level 3 Level 3 (550 points)
    Currently Being Moderated
    Mar 8, 2012 4:53 PM (in response to Sentrix_)

    ok,... thinking about it ... maybe it is not a problem... but for a.goodwin... that is definetaly a problem...

  • Carlo TD Level 3 Level 3 (550 points)
    Currently Being Moderated
    Mar 8, 2012 4:59 PM (in response to Sentrix_)

    Could you post the last section of this report... it seems to be cut off...

  • Carlo TD Level 3 Level 3 (550 points)
    Currently Being Moderated
    Mar 8, 2012 5:28 PM (in response to Sentrix_)

    Look at your transmit rate of 11. That is terrible. That is like before they had the 54 Mb routers

     

    Message was edited by: Carlo TD

  • Carlo TD Level 3 Level 3 (550 points)
    Currently Being Moderated
    Mar 8, 2012 5:59 PM (in response to Carlo TD)

    In case it is related to the Atheros chip, you could find out more information here for yours if your computer has one... http://www.qca.qualcomm.com/technology/technology.php?nav1=47&product=85

     

     

    i have it and have no problem.

     

    Message was edited by: Carlo TD

  • Sentrix_ Calculating status...
    Currently Being Moderated
    Mar 8, 2012 6:25 PM (in response to Carlo TD)

    I'm set to 11 as I'm using B, it says B as I'm using B, I can set it to use N however it then means I have to manually reconnect every few mins to the wireless. Using B means I only have to do this every hour, not ideal. I have an appointment booked for the apple store tomorrow and I'll be shouting quite a bit if I don't get another machine/fix or they try and fob me off and say it's my router. I shouldn't really have to debug this, it should just work.

  • Carlo TD Level 3 Level 3 (550 points)
    Currently Being Moderated
    Mar 8, 2012 6:49 PM (in response to torndownunit)

    I am thinking... this might..be the pattern (emphasis on "might be"). I have found this:  {In my iMac} The AirPort Extreme (0x168C, 0x8F) (wifi) card firmware version is a Atheros 9280: 4.0.61.5-P2P. {In my MacBook Pro} The AirPort Extreme (0x14E4, 0x8D) (wifi) card firmware is aBroadcom BCM43xx 1.0 (5.100.98.75.19). Both of these work well. But @Sentrix_ your firmware version is this: AirPort Extreme  (0x168C, 0x9A) (wifi) card firmware version Atheros 9380: 4.0.61.5-P2P.

     

    I went to the Qualcom web site and looked at the difference between my chipset and your chipset...

    my chip looks like: http://www.qca.qualcomm.com/technology/technology.php?nav1=47&product=85

     

    Your chip looks like: http://www.qca.qualcomm.com/technology/technology.php?nav1=47&product=88

     

    I do not think a down grade of the firmware is the correct solution even though it might work... but it looks like the firmwares (or chipsets - not sure) are utimately different.

     

    Ok, if this is a software issue, then a firmware upgrade or downgrade will be needed. If this is a hardware issue, because it looks like the 9380 uses RF switches, and the 9280 does not, and it turns out something is wrong with the RF switches, then it is possible a replacement chip will be needed.

     

    (Although it seems the Atheros 9380 appears only in iMacs) I searched around quickly and found at least 2 other people (including @Sentrix_) having problmes with the Atheros 9380 firmware.  The other sites I found with something with a similar firmware as @Sentrix_ were these sites. (there might be other similarities, or differences but this is what I saw only cause I was looking at the Atheros 9380 firmware).

     

    http://forums.macrumors.com/showthread.php?t=1329406&page=2

    and

    https://discussions.apple.com/thread/3767053?start=0&tstart=0

    and

    http://eu.battle.net/wow/en/forum/topic/3429907301

  • Landon12 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Mar 8, 2012 6:56 PM (in response to lrogersinlv)

    Same thing happens to me. Delete your airport wifi connection and make a new one with a password, do this every time this happens.

  • kyp@stsci.edu Calculating status...
    Currently Being Moderated
    Mar 9, 2012 6:38 AM (in response to Carlo TD)

    I too am having problems with Lion with my wireless connection dropping off, not being able to connect to preferred wireless connection points even though they are "seen" by the laptop. The behavior is very sporadic sometime working correctly for hours, only to have it go up and down like a yo-yo in a few minutes.

     

    In my case I have a new MacBook Pro, so I'm dealing with new HW and SW.  My old MacBookPro with Snow Leopard worked flawlessly for years in the same environment.

     

    One thing that I've noticed is that there a lot more available wireless connection points visible to my laptop. As shown by the Airlock widget or show from "Join Other networks".  Airlock shows that the channel that I'm using is also being used by other routers.  I'm switching to a different channel to see if that helps...

  • Sentrix_ Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 9, 2012 6:45 AM (in response to kyp@stsci.edu)

    Got off the phone from Apple and it appears it's a hardware problem with the wireless card. Judging by the number of people who also have the problem it could be a faulty batch of wireless cards. You need to take it in to the apple store or post back or something so they can fix it.

  • torndownunit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 9, 2012 7:16 AM (in response to Sentrix_)

    Sentrix_ wrote:

     

    Got off the phone from Apple and it appears it's a hardware problem with the wireless card. Judging by the number of people who also have the problem it could be a faulty batch of wireless cards. You need to take it in to the apple store or post back or something so they can fix it.

    The problem is people are reporting this problem with different compuuters, different cards, and different firmware.  Without an official statement from Apple it's kind of hard to know what machines you should be taking in.  In my case, I have to lug 27" iMac to the store which is an hour away.  So the last thing I want is to do that and be told there is no problem like what  has happened to many other people in these threads.

  • pbarnes@internode.on.net Calculating status...
    Currently Being Moderated
    Mar 9, 2012 11:37 PM (in response to torndownunit)

    "a hardware problem with the wireless card" doesn't come close to explaining why machines which had rock solid connections when they had the Snow Leopard OS suddenly cannot hold a connection for more than a few minutes as soon as Lion OS is installed. Same hardware, new software, guess where the problem is.

  • a.goodwin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2012 6:16 AM (in response to Carlo TD)

    My iMac Airport card is:

     

              Card Type:                                   AirPort Extreme  (0x14E4, 0x88)

              Firmware Version:                         Broadcom BCM43xx 1.0 (5.10.131.36.11)

              Supported PHY Modes:              802.11 a/b/g/n

     

    using the TIme Capsule distributing:

     

              PHY Mode:          802.11n

     

    --------------------------------------

    My Mini Airport card is:

     

      Card Type:                        AirPort Extreme  (0x168C, 0x86)

      Firmware Version:          Atheros 5424: 2.1.14.9

      Supported PHY Modes:          802.11 a/b/g

     

    using the Time Capsule distributing:

     

              PHY Mode:          802.11a

     

    Ergo, my Time Capsule is distributing on all frequencies; a/n - b/g/n (confirmed in the Airport Utility.

    The Airport card should automatically negotiate the best protocol it can in a mixed 802.11 a/b/g/n environment.

    So, I'm wondering if I can try to get my Mini to use 802.11b or 802.11g instead to see if that improves the connection before I downgrade the firmware. I sense that some Terminal hacking might be required….

  • Carlo TD Level 3 Level 3 (550 points)
    Currently Being Moderated
    Mar 10, 2012 6:19 AM (in response to a.goodwin)

    I really dont think terminal hacking is the way.

  • a.goodwin Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 10, 2012 6:26 AM (in response to Carlo TD)

    There appears to be no GUI for setting an Airport card to use a specific channel/frequency. However I believe it can be done with Terminal. If so then being able to switch it back would be via the same method.

  • sulako Calculating status...
    Currently Being Moderated
    Mar 10, 2012 6:27 AM (in response to lrogersinlv)

    Horrible wifi drop outs! At first I thought it is 10.7.3 to blame. I did have problems in 10.7.2 but with update it became just unacceptable.

     

    One more thing though. I have NOOK (electronic book) with WiFi. Guess what? It has the same problems. I mean the moment my MacBook Air starts to give me hard times the same happens to NOOK. Then as soon as MacBook gets connected my NOOK gets connected too! Strange.

     

    So, after all it may be router problem….? At least in my case.

    WRT54GC ver.2.0

     

    Here is my WiFi tech. info:

     

    Software Versions:

      CoreWLAN:    2.1.1 (211.3)

      CoreWLANKit:    1.0.1 (101.1)

      Menu Extra:    7.0.1 (701.2)

      configd plug-in:    7.1.1 (711.1)

      System Profiler:    7.0 (700.3)

      IO80211 Family:    4.1.1 (411.1)

      WiFi Diagnostics:    1.0.1 (101.1)

      AirPort Utility:    6.0 (600.92)

      Interfaces:

    en0:

      Card Type:    AirPort Extreme  (0x14E4, 0xE9)

      Firmware Version:    Broadcom BCM43xx 1.0 (5.100.98.75.18)

      MAC Address:    28:37:37:19:3c:28

      Locale:    FCC

      Country Code:    GB

      Supported PHY Modes:    802.11 a/b/g/n

      Supported Channels:    1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140

      Wake On Wireless:    Supported

      AirDrop:    Supported

      Status:    Connected

      Current Network Information:

    linksys_nostromo:

      PHY Mode:    802.11b

      BSSID:    00:22:6b:dd:c5:10

      Channel:    1

      Country Code:    GB

      Network Type:    Infrastructure

      Security:    None

      Signal / Noise:    -49 dBm / -91 dBm

      Transmit Rate:    11

Actions

More Like This

  • Retrieving data ...

Bookmarked By (80)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.