Skip navigation

my macbook pro does not detect external display anymore

432285 Views 350 Replies Latest reply: Mar 31, 2014 2:28 AM by iDinev RSS Branched to a new discussion.
  • brianwee Calculating status...

    This worked for me too. Thanks

  • acribb Calculating status...

    I was having the same issue.  Everything was working fine and then as of the 10.7.3 update, (maybe .2), my HP ZR24W stopped working with my 2010 MBP i7 2.66.

     

    What ended up fixing the problem was doing what another suggested- plug in your cable then power off your display with the display's power button and then power it back on.

     

    Now everything is working again.

     

    Hope this works for someone else.

  • apluser Level 1 Level 1 (0 points)

    I finally figured out my problem.  I just broke down and bought a new HDMI cable and everything works perfect now.  I really never would have believed this was the problem...but it was.

  • nottscientist Calculating status...

    HI, I had the same problem after upgrading to 10.7, tried everything, different adaptor, resetting various things, fix permissions etc etc So my monitor would work as a secondary screen (at 1440x900, but not it's native 1680x1050), but wouldn't work at all as a primary screen ie upon closing the MBPro lid when using external mouse & KB. On looking around I tried the demo of SwitchResX - made everything work fine, but is only good for 10 days, so I bought it.  All fine now - it seems I now have two settings for my Samsung W2242 at 1680x1050- one which works (appeared with installing SwitchResX), and one that doesn't (was there as the default setting  before 10.7 upgrade)  so clearly not a cable issue, just some minor difference in the parameters to drive the screen - so fixed, but not right that I have to get third party stuff to make it work, come on Apple.

  • svax Calculating status...

    i'm having the same problems with my MBP i7.

    Using a minidisplay to VGA doesn't work since upgrading to Lion. My LG goes to sleep without detecting a signal, MBP won't detect a display and even my Sony LCD TV gives me a 'No Signal' message via VGA.

     

    Strangely enough, my old white macbook running the same OS detects every possible display in the house using the same connectors.

     

    I tried every option found on the internet without succes.

    Any idea how to read the functioning of the minidisplay connection in the OS?

     

    'Apple, it used to simply just work.'

  • julio antonio Calculating status...

    I'm having the same issue and don't know how to fix the problem . I tried all the tips and tricks that i read on this thread but my samsung syncmaster is not detected anymore. Thiis is my first and last mac....

  • nottscientist Level 1 Level 1 (0 points)

    Did you ry the resX demo, I don't like  greeting 3rd party solutions to a bug any more than anyone else, but I needed to be back in business with my screen...and it worked.

  • julio antonio Level 1 Level 1 (0 points)

    Thank you for your kind suggestion. Anyway even resX can't detect my external display.

  • CAV0K Calculating status...

    How many of you are running gfxCardStatus? - Those of you who are not really should get it, its amazing the increase in battery life you achieve

     

    I have found that if you force your Macbook Pro to run its Intergrated graphics card with the above program, it will not detect my external display, however if I change it to Discreat or Dynamic switching it will run my external monitor.

     

    Just my two cents.

  • califromarmonk Calculating status...

    Same problem here going to apple store.

  • snash13 Calculating status...

    Report on how that goes and tell us if that helps...Thanks

  • califromarmonk Level 1 Level 1 (0 points)

    So I missed my appointment, which for me isn't common.  I bought the same Moshi Mini DisplayPort to HDMI adapter that I had before

     

    I just plugged the old one in and it did the same thing, first time it didn't recognize it, then i unplugged it in and out again and the screen flashed and I got sound and display for a second.  Again and again, no avail.


    Then I tried the new Moshi and first time I plugged it in it works perfectly.


    My advice you do the same, I had the same symptoms as everyone else and tried everything.


    Time for the old switch a roo.

  • emgsilva Level 1 Level 1 (0 points)

    Hi Everyone.

     

    Been fighting with this issue for a while (I have worked with at least 4 external monitors latelly). After many suggestions, readings, and experimentation I think I got a systematic way to solve the problem (at least on my Macbook pro 15, early 2011, ATI graphics card). It consists of two simple steps:

     

    1) Install gfxCardStatus;

    2) Make sure you sellect "Discrete Only" mode when you are connecting to external monitors (you can do it before you connect, but for me it also worked after I connect to the external monitor).

     

    Aparently the "Integrated graphics" (Intel-based) does not allow to "output" signal correctly to external displays... I use to have "Dynamic Switching" selected on the gfxCardStatus, which would be "Integrated" on battery, and "Discrete" on power... I think this was the reason why I would get very weird behaviors, namely the same monitor would work some times, and other times it did not work...

     

    I hope this helps... Still, it would be nice that Apple would take care of this, we should not use such tricks to make it work, given the price we pay for such machines!

     

    Best regards!

  • Benthem Calculating status...

    Hi,

     

    I also have this problem.

    I know every thing works because when Ubuntu is on my mac the screen is regoginised.

    I can also get everything working with other screens but not mine!!

    My screen is 6 day's old just as my adaptor, it just stopt working (mac software 10.7.3)!!

    for 5 day's it worked fine day 6 everyting stoped? even windows can do this better!

    My mac is 5 month old ( the latest version) I'm going crazy!!

     

    APPLE PLZ FIX!

  • emgsilva Level 1 Level 1 (0 points)

    Have you checked my post https://discussions.apple.com/message/18028302#18028302 ?

    This solution worked in many external monitors (I tried 4 different ones)... Aparently this has to do with the graphics mode you are using when connecting external displays... Follow the instructions, I hope it helps!

     

    Cheers!

1 ... 6 7 8 9 10 ... 24 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (12)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.