Skip navigation

Can't wake Lion over wifi (or ethernet) using iPad and home sharing.

48136 Views 227 Replies Latest reply: Mar 21, 2014 1:39 PM by IIIMOODIII RSS
  • Rayced Level 1 Level 1 (5 points)

    IIIMOODIII wrote:

     

     

     

    @ Rayced: I have had no issues with wake on demand with either manual sleep or timed sleep until i installed 10.7.3 from 10.7.2 and likewise with airport firmware 7.6.1 from 7.6.

     

    Ok do you actually remember if you've installed 10.7.3 combo update or delta update? Do you also remember if you've first installed the OS update and after that airport firmware or vice-versa?

     

    You might as well check your /Library/Receipts/InstallHistory.plist file to recall that. Probably you'd first installed the new airport firmware since it was released sooner than OS X 10.7.3 update.

     

    Probably we first have to cleary understand if it's a 10.7.3 issue or airport firmware issue.

  • Rayced Level 1 Level 1 (5 points)

    Jonathan216 wrote:

     

    Gentlemen; be nice to each other, life's too short.  I still have the same problem.  I just thought I'd update you with what I've tried recently (which doesn't include anything to do with terminal or config files - I'm not messing with what I don't understand)

    1. Rolled back time capsule firmware to 7.5.1.  Didn't work.  Back to 7.6.1.  Still doesn't work.

    1a tried changing DHCPl lease on adsl modem from 1 day to 7 days.

    2. Reinstalled lion using recovery partition.  Interestingly, it said "downloading additional components for lion" and then took two hours to d/l.  When it rebooted, I had build 11D50 again, not 11D50b as provided by combo update.  Remote wake doesn't work still.

    3. After the reinstall, iTunes had reverted from 10.5.3 to 10.5.1 - remote wake doesn't work though.

     

    Just to recap my exact symptoms:

    1. Sleep mac with iTunes homeshare set up on both mac and iOS devices (exact same apple ID)

    2. If I use iPod on iPad within a few minutes, it will wake up the mac and serve me my files

    3.....but it then goes to sleep again and the stream stops a minute later when the buffered stuff has played.  It it stops mid- song or mid-movie.

    4. If I leave it any longer than a few minutes then the mac won't wake and shared library isn't shown on ipad

    5. After (3) has happened, if I go back to the iPod iPad the shared library has either disappeared or, if it's still there (which seems to happen randomly) then the spinny clock dial only ever gets to half way before it times out and the shared library disappears.

     

    Here's how it should (and did) work on 10.6:

    http://support.apple.com/kb/HT3774

     

    I'm of the opinion that the EFI update is the culprit here - I've changed everything else that can be changed.  I suspect that iTunes tells the TC what's available and the TC tells my iPad.  But I think that the EFI update is causing my mac to go into a deep sleep and just before it does, iTunes tells the TC to clear its list of what's available.  The EFI update is preventing the mac from hearing the magic packet from the TC, I'm convinced of it.  I'm sure that there must be an update in the pipeline, but it's bloody annoying meanwhile.

     

    Jon.

     

     

    Outstanding report.

    The issue with wake on demand also applies to all other kind of shares: smb, afp, ssh, vnc, http, not only to iTunes. At least that's what I could test.

     

    EDIT: I've forgotten to mention that I'm having this issue on an iMac 8,1 (2008) which wasn't subject to any EFI update lately.

     

    Message was edited by: Rayced

  • IIIMOODIII Calculating status...

    Jon, you're quite right. Apologies all, we should be helping each other not bickering on semantics (of which I hold my hands up to being a culprit )

     

    Rayced, from what I can recall (not actual in front of the Mac) I did do a standard software update followed by the 7.6.1 airport update followed by a combo update after reading this thread. I have however rolled back to 7.6 which had no effect on the problem so I'm now back on 7.6.1.

  • MirkoW Calculating status...

    Jonathan216 wrote:

     

    Gentlemen; be nice to each other, life's too short.  I still have the same problem.  I just thought I'd update you with what I've tried recently (which doesn't include anything to do with terminal or config files - I'm not messing with what I don't understand)

    1. Rolled back time capsule firmware to 7.5.1.  Didn't work.  Back to 7.6.1.  Still doesn't work.

    1a tried changing DHCPl lease on adsl modem from 1 day to 7 days.

    2. Reinstalled lion using recovery partition.  Interestingly, it said "downloading additional components for lion" and then took two hours to d/l.  When it rebooted, I had build 11D50 again, not 11D50b as provided by combo update.  Remote wake doesn't work still.

    3. After the reinstall, iTunes had reverted from 10.5.3 to 10.5.1 - remote wake doesn't work though.

     

    Just to recap my exact symptoms:

    1. Sleep mac with iTunes homeshare set up on both mac and iOS devices (exact same apple ID)

    2. If I use iPod on iPad within a few minutes, it will wake up the mac and serve me my files

    3.....but it then goes to sleep again and the stream stops a minute later when the buffered stuff has played.  It it stops mid- song or mid-movie.

    4. If I leave it any longer than a few minutes then the mac won't wake and shared library isn't shown on ipad

    5. After (3) has happened, if I go back to the iPod iPad the shared library has either disappeared or, if it's still there (which seems to happen randomly) then the spinny clock dial only ever gets to half way before it times out and the shared library disappears.

     

    Here's how it should (and did) work on 10.6:

    http://support.apple.com/kb/HT3774

     

    I'm of the opinion that the EFI update is the culprit here - I've changed everything else that can be changed.  I suspect that iTunes tells the TC what's available and the TC tells my iPad.  But I think that the EFI update is causing my mac to go into a deep sleep and just before it does, iTunes tells the TC to clear its list of what's available.  The EFI update is preventing the mac from hearing the magic packet from the TC, I'm convinced of it.  I'm sure that there must be an update in the pipeline, but it's bloody annoying meanwhile.

     

    Jon.

     

    That discribes exacly the problem.

    Setting darkwake=0 this problem seems to be solved at my configuration, but a couple of days later i must admit this is not the case. My imac can be reached longer with this setting but over night it falls into coma too.

     

    i can also second that: if i turn my mac to sleep manually i can wake it remotly, but letting it fall asleep by itself it seems to be not reachable (with darkwake=0 not set).

     

    i called apple via express line and they told me to do many things (HCxy Reset (didn't rember the name), Booting in safe mode with shift, renaming SystemConfiguration folder, delete all password entries for my timecapsule ...) but nothing worked. So they send me a diagnostig tool, which i had to execute after the problem occured. But i never heared anything about it anymore until now. 

    so i don't think apple really has an idea where the problem is and i'm not sure 'there must be an update in the pipeline'

    my be you all should call apple too?

  • Rayced Level 1 Level 1 (5 points)

    IIIMOODIII wrote:

     

     

    Rayced, from what I can recall (not actual in front of the Mac) I did do a standard software update followed by the 7.6.1 airport update followed by a combo update after reading this thread. I have however rolled back to 7.6 which had no effect on the problem so I'm now back on 7.6.1.

     

    Well it seems it's the "big cat", though.

    The mess with the two 10.7.3 update versions speaks by itself.

    At this point let's hope that by 10.7.6 every issue is gonna be fixed.

  • Rayced Level 1 Level 1 (5 points)

    MirkoW wrote:

    Setting darkwake=0 this problem seems to be solved at my configuration, but a couple of days later i must admit this is not the case. My imac can be reached longer with this setting but over night it falls into coma too.

     

     

    Well then that's not even a workaround. I don't think that messing up with that setting is such a good idea too.

    If I remember well, setting it to 0 will not let the mac do "snapshots" of the system before going to sleep.

  • MirkoW Level 1 Level 1 (0 points)

    apples Tier 2 Technical Advisor told me to make a new partition and install Lion completly new with all updates and no other software. So i did. And the problem still occurs. So i have no idea neither apple seems to have one.

     

    do anybody use 5 Ghz WLAN?

  • LexSchellings Level 5 Level 5 (5,505 points)

    yes, several. with several computers, osx sl, osx lion, windows xp, windows 7.

  • Rayced Level 1 Level 1 (5 points)

    Jonathan216 wrote:

     

    I've disabled icloud email because my snow leopard mac can't pick it up, but i don't care because I've resurrected my old email address from my ISP (which is also my Apple ID) and I'm using that on all three devices.  I don't care about documents in the cloud.

     

    However, contacts and calendars now only sync on 2/3 of my devices due to Apples decision to pull MobileMe and not provide snow leopard with iCloud functionality (even though they provide it for Windows!!).  That's a pretty clear message from Apple so I'm going to build myself a nice new (and upgradable) PC and flog this iMac thing to someone coming the other way.

     

    Jon

     

    You can use 10.6.8 Mail version to fetch iCloud mail account. There's a plethora of tutorials on-line made by people who are doing that. I too had set it up on 10.6.8 on my iMac before switching it to Lion.

     

    About syncronization you can use rsync to sync a lot things locally, otherwise you have to switch to Dropbox. Either ways you have to spend time on it, and both aren't so Mac-like solutions.

  • MirkoW Level 1 Level 1 (0 points)

    Jonathan216 wrote:

     

    MirkoW, I think you might be right and that everyone with this issue should contact Apple in order to get this cat waking up properly.  Can I ask you MirkoW, do you have to be still under (extended) warranty to use the express lane, or can anyone use it?  Also, can I ask why you are asking who uses 5Ghz?  Do you have a hunch?  Share!

     

     

    Yes, i have brought apple care.

    They contacted me several times and i had to record my system with a special diagnostic programm.

    I had to set my system new up on a second partition. And not install any third party programm. But the problem still occours. So i have heard nothing for 2 weeks.

    I'm very disappointed. So i have no good news for you.

     

    May be it would be better if you all  report to apple too since it is probably easer so find the problem if they can look what we (our systems) have in commen.

     

    kind regards

    Mirko

  • Rayced Level 1 Level 1 (5 points)

    This issue hasn't been solved still.

    Probably the thread shouldn't be marked as answered either.

1 ... 3 4 5 6 7 ... 16 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (10)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.