Skip navigation

Cannot Sign In to Mac App Store - Tried Every Way Possible & No Progress.

104937 Views 186 Replies Latest reply: Mar 1, 2014 5:48 AM by aries1776 RSS
  • Kellyfromaz Calculating status...

    YES! for me it was Nortons firewall the whole time!!!  tried next to everything on here until (perhaps stupidly) Ichecked Nortons setting, sure enough it was.  here's how it went down:

    1) try loging into the appstore-you will now establish the "block" history in norton.

    2) got to norton firewall application and under the status tab, view history...you will see recently allowed and blocked items...you may also noticed (as was my case) that the app store application, storeagent, etc were just blocked.

    3)  if certain items were blocked, go to the firewall tab, click on the configure button on connection blocking, click add application, then select the app store, etc to allow connections click done

    4) still in firewall tab, click configure on application blocking, scroll down the various application paths and find the items that were recently blocked (for me I allowed the storeagent and submitdiaginfo-as those were just blocked per my history)

    5) try the app store-hopefully the window now pops up for you

     

    if this doesn't work for you, just start at page one of the thread and work the solutions until it clicks-mine ended up being stupidity on my part-but there seems to be TONS of issues that cause this same problem.

     

    chalk one up for the computer illiterate

  • xeoron Calculating status...

    Different approach to solving this proglbme. I do not have APE or FruitMenu. My problem was the firewall settings on my Mac OS Lion machine. In my case it was a rule setting for "App Store" in the program Hands Off! by allowing network & writing access. But, it could easily be a rule on a router or the Mac OS X firewall

  • Allan Eckert Level 8 Level 8 (39,305 points)

    Isn't it amazing the amount of trouble that the antivirus software can cause.

     

    What I really find amazing is that it serve no useful purpose on a Mac.

     

    Allan

  • luisretoucher Calculating status...

    I tried Terminal solution without sucess, sorry to say. Also I can't get my Sotware Update to check for updates either. A message says I have a Network problem, I claims SUpdate can't connect to the internet, try to fix my connection, but obviously I'm connected right now, aren't I?

    I turned Airport off and connected to my ethernet port and nothing either.

    My Developer log in works with my browser and so does my Mail App. If it is a network issue I don't know what to make of it.

    My router IP ends in 1 and my MacBook's ends in 2, my other laptop on 3.

    Luis

  • freshfruit1 Calculating status...

    this solution (part 1) worked for me. Snow Leopard 10.6.8 no APE or fruitmenu

    http://scheyeniam.blogspot.com/2011/08/how-to-revive-mac-app-store-when-its.html

  • luisretoucher Level 1 Level 1 (0 points)

    First of all, Thank You.

    It turned out my case was an issue with the firewall.

    I turned it off and my problems vanished. I turned it back on afterwards but I'm still curious what I need to set up so the firewall can be left enabled.

    Luis

  • Adonsa Level 1 Level 1 (0 points)

    After spending over 6 hrs. trying suggestions in this and about a dozen other websites, this worked for me:

     

    This may or may not help you, but it's worth trying before indulging in all the time consuming steps throughout this message thread.

     

    Coolest wrote:

     

    "Enable the Mac App Store hidden Debug menu

    Precautions aside, here is how to enable the hidden Debug menu options:

    • Quit the Mac App Store
    • Launch the Terminal (located at /Applications/Utilities/)
    • Type the following command into the Terminal and then hit return:

    defaults write com.apple.appstore ShowDebugMenu -bool true

    • Relaunch the Mac App Store, the Debug menu is next to “Help” in the menubar"

     

    Simply enabling the debug menu fixed the problem, it wasn't necessary to reset the cookies or do any of the commands offered by the debug menu,

     

    Cleaning up the mess and putting things back after fixing App Store took a bit of time;

    I put Little Snitch back, resumed blocking the port 80 items in Little Snitch,

    Reinstalling Applcation Program Enhancer, APE,

    Removing the mods to the com.apple.Boot.plist, and putting it back to original status.

     

    App Store has got to be Apple's most convoluted application ever, in terms of the eclectic requirements to troubleshoot, all of which apply differently to different users.

     

    Recommendation to Apple executives and engineers:

     

    -- Counsel the beta testers, teach them how to do their jobs.  It is astounding that beta testers didn't notice.

    -- Re-write the App Store source code to run cleaner, use iTunes source code as a guide.

    -- Add error checking to the application to alert users of compatibility or other conflicts, specifically.

    ----- If the non-performance of App Store is caused by Little Snitch, the error returned should say so.

    ----- If the non-performance of App Store is caused by a Unsanity Corporation product, say so.

    ----- If the non-performance of App Store is caused by failure to activate the debug menu, say so.

    ----- If the non-performance of App Store is caused by failure to modify the  com.apple.boot.plist file, say so.

    ----- Provide the app store application with the Debug menu always enabled, this might help a lot of users.

     

    Error checking should be built into App Store to alert the user why he can't sign in.  If that's too hard to do, then publish a detailed troubleshooting flow chart, incorporate it into the help menu, and articulate all the eclectic remedial actions taken within this message thread.

  • Applemacster Calculating status...

    Adonsa,

     

    I had exactly the same problem: able to type in the login details, but it wouldn't log in. Enabling the Debug menu worked a treat! Thanks very much!

  • lightspeedMc Calculating status...

    Enabling connections for storeagent in Little Snitch worked for me. Thanks donalexo!

  • phatpharm06 Calculating status...

    Thank you everyone.. thank you.

     

    I tired the

    rm ~/Library/Preferences/com.apple.appstore.plist

    rm ~/Library/Preferences/com.apple.storeagent.plist

    rm -rf ~/Library/Preferences/ByHost/*

     

    at first because the person was working out of lion but it kept saying not found, but I did everything else here next.  I added the debug thing and didn't work but I didn't.  Then I deauthorized my computer iTunes and reauthorized then signed in and out. Did not work. I then ran the permission  part of Utilities and then ran the repair.  after this I copied all three lines together pasted them into Terminal.  After that it worked.    I am so happy right now.  I think I had to repair the disc to get it right.  I wrote everything I did incase it was a combination of every thing.    Thank you thank you thank you. 

  • rukirichel Calculating status...

    I have a mac pc and thats fine i downloaded mountain lion now im trynna download it on my mac book pro and it says when i sign in to the app store "your device or computer could not be verified.contact support for assistant ??? what the ****

  • cwoller Calculating status...

    I have done everything listed in this thread.  Nothing has helped.  The only thing that I can think of that is unique to my situation is I removed the optical drive and installed an SSD.  I now have two HD's.  The system disk has all apps and the second disk has all my files, media, etc.  I have even been to an Apple store to meet with a genious.  Stumped him as well.  Any other ideas?

  • peterfromtotnes Level 1 Level 1 (0 points)

    Have you tried the solution described on the attached link. It worked well perfectly for me.

     

     

    http://b.rthr.me/wp/?p=356

     

    regards

     

    Peter

  • peterfromtotnes Level 1 Level 1 (0 points)

    Also note:

     

    This worked for me as well, I had 4 blue crosses showing. They only disappeared after a shut down & start, rather than a re-start.

     

    One variation I had was that I additionally had to set up a new admin user & delete my old one, sign in then worked perfectly.

     

    I have been frustrated with this problem for the last 6 months & can at last move on to Mountain Lion.

  • cwoller Level 1 Level 1 (0 points)

    Thank you so much.  That did the trick.  It is now working.  Your help with this is very much appreciated!

Actions

More Like This

  • Retrieving data ...

Bookmarked By (3)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.