1 2 Previous Next 19 Replies Latest reply: Nov 15, 2013 8:18 AM by fitzyjoe Go to original post
  • 15. Re: Can't view properly StackOverflow code with Safari Versione 5.1.4 (7534.54.16)
    Linc Davis Level 10 Level 10 (117,970 points)

    You should briefly see a dark gray progress bar on a light gray background during startup.

  • 16. Re: Can't view properly StackOverflow code with Safari Versione 5.1.4 (7534.54.16)
    enzoses Level 1 Level 1 (0 points)

    Ok, I did. So far It works only with the Guest Account

  • 17. Re: Can't view properly StackOverflow code with Safari Versione 5.1.4 (7534.54.16)
    Linc Davis Level 10 Level 10 (117,970 points)

    Back up all data if you haven’t already done so. Before proceeding, you must be sure you can restore your system to the state it’s in now.

     

    Last warning: DO NOTHING unless you have a backup and you know you can restore from it.

     

    Quit Safari if it’s running.

     

    Step 1

     

    In the Finder, press the key combination shift-command-A to open the Applications folder. Select the Safari icon in that folder and press the key combination shift-command-I to open the Info window. There’s a checkbox in the Info window labeled Open in 32-bit mode. If that box is checked, uncheck it. Close the Info window and the Applications folder.

     

    Open the Library folder in your home folder as follows:

     

    If running Mac OS X 10.7 or later, hold down the option key and select Go ▹ Library from the Finder menu bar.

     

    If running an older version of Mac OS X, select Go ▹ Go to Folder… from the Finder menu bar and enter “~/Library” (without the quotes) in the text box that opens.

     

    Delete the following items from the Library folder (some may not exist):

     

    Caches/com.apple.Safari

    Caches/com.apple.WebKit.PluginProcess

    Caches/Metadata/Safari

    Preferences/com.apple.WebKit.PluginProcess.plist

    Saved Application State/com.apple.Safari.savedState

     

    Leave the Finder window open. Try Safari again.

     

    Step 2

     

    If it still doesn’t work right, quit, go back to the Finder and move the following items from the open Library folder to the Desktop (some may not exist):

     

    Cookies/Cookies.binarycookies

    Cookies/Cookies.plist

    Preferences/com.apple.Safari.LSSharedFileList.plist

    Preferences/com.apple.Safari.plist

    Preferences/com.apple.Safari.RSS.plist

    PubSub/Database

    Safari

     

    (Note: you are not moving the Safari application. You’re moving a folder named “Safari.”)

     

    Try again. This time Safari should perform normally, but your settings will be lost.

     

    If the issue is not resolved, quit Safari again and put all the items you moved to the Desktop back where they were, overwriting the newer ones that will have been created in their place. You don’t need to replace the files you deleted in step 1. Stop here and post again.

     

    If Safari is now working normally, look inside the “Safari” folder on the Desktop for a file named “Bookmarks.plist”. Select File ▹ Import Bookmarks from the Safari menu bar. Import from that file. Recreate the rest of your Safari settings. You can then delete the items you moved to the Desktop.

     

    Note: This step will remove your Safari Extensions, if any, and their settings. If you choose to restore them, do so one at a time, testing after each to make sure you haven’t restored the problem.

     

    If you don’t like the results of step 2, you can undo it completely by quitting Safari and restoring the items you moved or deleted in that step from your backup, overwriting any that were created in their place.

  • 18. Re: Can't view properly StackOverflow code with Safari Versione 5.1.4 (7534.54.16)
    enzoses Level 1 Level 1 (0 points)

    It seems to work just unchecking the Run in 32 bit flag! Perfect!

  • 19. Re: Can't view properly StackOverflow code with Safari Versione 5.1.4 (7534.54.16)
    fitzyjoe Level 1 Level 1 (0 points)

    For me, I fixed this by

     

    - Quit Safari

    - Check the 32-bit checkbox in Properties (it was originally unchecked)

    - Running Safari by double-clicking on /Applications/Safari

    - Notice that the page will load properly, but you want 64-bit, don't you?

    - Quit Safari

    - Uncheck the 32-bit checkbox in Properties

    - Run Safari and celebrate that the page still loads.

1 2 Previous Next