Skip navigation

Screen Flicker with External Monitor

71780 Views 188 Replies Latest reply: Apr 14, 2014 11:01 AM by mloseke RSS Branched to a new discussion.
  • dcoplan Calculating status...
    Currently Being Moderated
    Nov 7, 2011 7:27 PM (in response to Mattharris19)

    I don't have a 24", I have a 23" HD Cinema Display. Doesn't indicate if it's compatible with both or not - just specific to the 24". Don't want to screw anything up by installing the wrong firmware - things are screwed up enough as it is.

  • elctronyc Calculating status...
    Currently Being Moderated
    Nov 8, 2011 8:06 PM (in response to Wycliffe)

    It is sad that after trying to stay away as much as i can from windows now I have to go back to it to organized my pictures.  I guess I will use lightroom 3 in windows until they fix the external monitor issue.  If they ever fixed of course.    Come on apple you always say that mac osx is the best OS in the world.  Right now for me this Big Little Issue make me think different.

  • BurneyFM Calculating status...
    Currently Being Moderated
    Dec 3, 2011 8:08 AM (in response to Wycliffe)

    This issue really annoys me. I have a Dell U2711 connected to my 2010 13" MBP (Geforce M320) with a miniDP-2-DP-Cable. I see a flicker every 1-2 sec an this is really distracting - will there ever be a real solution? I don't have the issue, however, running the screen at 1080p instead of 2560x1440.

  • surferboi Calculating status...
    Currently Being Moderated
    Dec 6, 2011 5:26 AM (in response to BurneyFM)

    Hey folks,

     

    I have solved my problem!!!!

     

    I've been having the same problem with my 15" MacBook (circa 2010) and my older Cinema HD display connected via a DisplayPort > DVI adapter.

     

    The trick for me? Turn off "Spaces" so that I'm only using one desktop, and turn off "Automatic Graphics Switching" for the Power Adapter setting (which doesn't matter when you are at your desk not using your battery anyway.)

     

    I have been struggling with this since the 10.6.5 update from last year, but now, not a flicker for over a week now.

     

    I suspect that there is some sort of memory problem with the GPU's interaction with Spaces. Maybe keeping those virtual desktops in memory causes an overflow when connected to an external monitor?

     

    Discuss!

  • Leoparder Calculating status...
    Currently Being Moderated
    Dec 6, 2011 5:49 AM (in response to surferboi)

    Hi,

     

    This looks very interesting since one of my biggest issue appens when I switch to the "iTunes space" (iTunes in full screen).

     

    Are you on Snow Leopard or Lion.

    Beacause in Lion there is nothing to disable Spaces etc.

     

    I found nothing on the web neither

  • surferboi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2011 5:50 AM (in response to Leoparder)

    My mistake. Meant to mention I was on Snow Lep 10.6.8. Can't upgrade to Lion until I get my old devices replaced so I can use iCloud.

  • BurneyFM Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 6, 2011 6:01 AM (in response to Wycliffe)

    I am using Lion and disabling Mission Controll/Spaces is no option for me because it really cuts down my productivity. I also think the issue is related to the GPU-memory management as 1080p does not display any kind of flickering. Only at 2560x1440 i see constant flickering. Using Bootcamp, however, the setup works just perfect on the same machine.

     

    For people using GPUs with more than 256 MB of VRAM: Do you experience the same issues? What about nvidia/amd (nvidia 320M for me)? What about dedicated VRAM instead of spared RAM? Is there any way for OSX to display the GPU/VRAM-load?

  • MD Wong Calculating status...
    Currently Being Moderated
    Feb 28, 2012 10:45 PM (in response to Wycliffe)

    I'm running 10.7.3, MBP 15inch with 2g i7, 8gb mem (lower end graphics currently available) with 24 inch ACD

     

    Turned off "Automatic Graphics Switching" and it has solved the problem for me.  It was occuring at least one an hour and I haven't experienced it since the switch - about 12 hours of continual use.

     

    I've noticed that it happened more when using the power source directly from the monitor.  Seems to have something to do with the way the grpahics processor handles power usage and downscaling graphics peformance when its not taking a charge. 

     

    Go to Settings -> Energy Saver -> remove check from Automatic Graphics switching.

  • JWP1991 Calculating status...
    Currently Being Moderated
    Mar 7, 2012 10:26 AM (in response to MD Wong)

    I had this problem with external HP monitor and a 15 inch macbook pro, fully updated Lion. I took it to a local apple store and got it sent for examination. Came back with a new motherboard installed (under warranty). No problems since. Maybe this is a possible fix?

  • huisuizh Calculating status...
    Currently Being Moderated
    Mar 11, 2012 9:19 PM (in response to Wycliffe)

    I have the same issue here. MBP 13 late 2011, not work well with my Dell 24 inch monitor. But I don't have the issue with my 11 inch MBA, same late 2011. Annoying experience....

  • surferboi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 12, 2012 6:34 AM (in response to huisuizh)

    I think Apple has a deeper problem than they are admitting to (and I'm NOT an Apple hater by any measure).

     

    I have a 2010 MBP, and I am on my 2nd motherboard, and a new Samsung monitor, and I still have screen flicker. I had to ditch my Cinema Display connected via DVI, and now my HDMI-connected Samsung is also showing the same problem.

     

    I had no problems with my MBP until 10.6.8 update, and then the flickering started. I have been on a wild goose chase every since, and am getting a bit ticked off that there seems to be no solution.

  • tsvernon Calculating status...
    Currently Being Moderated
    Mar 15, 2012 10:17 AM (in response to surferboi)

    I had the same problem with my old Duo Core MBP & just purchased a new quad core MBP (8GB ram, 1GB AMD Radeon HD) and plugged it in to my 24" cinema display and the problem has actually gotten worse. Whereas in the past it would flicker every hour or so, now it's every 5 minutes. I'm now running OS 10.7.3, my old MBP was running 10.6.8.

     

    I disabled Spaces and unchecked Automatic Graphics Switching and there has been no change.

  • surferboi Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 15, 2012 11:00 AM (in response to Wycliffe)

    Ok...so here's an update.

     

    In our last episode, I was on my second motherboard, and my new Samsung was showing the same problem. Having just upgraded to Lion, it didn't occur to me that I should try to turn off Mission Control/Spaces again. I already have the graphic card swithing turned off.

     

    Now that I've done that, smooth sailing for my beloved Cinema Display. And my Samsung isn't a waste; it got banished to PC Land to live on my work laptop.

     

    Still a very very bizarre thing though. the 2010 MBP isn't THAT old, and the problems started showing up in the late 10.6.x days. Also, one of the "big" features for Lion is rendered useless (didn't like it anyway...if you have a dual monitor setup, who needs it.)

     

    Repeated calls to Apple didn't fix the problem, but this community had the answer. Yay us!

  • tsvernon Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 16, 2012 8:15 AM (in response to surferboi)

    I spent some time on the phone with applecare yesterday to no avail and went to the genious bar as a last resort. My genious was able to come up with the below link which appears to have fixed the problem. It appears to be a thunderbolt issue with the cinema display which necessates a firmware update. Good luck.

     

    http://support.apple.com/kb/TS4045?viewlocale=en_US

  • snash13 Calculating status...
    Currently Being Moderated
    Mar 19, 2012 10:39 PM (in response to Wycliffe)

    Same exact problem...

Actions

More Like This

  • Retrieving data ...

Bookmarked By (9)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.