Skip navigation

Netflix Audio/Video Out of Sync

108366 Views 63 Replies Latest reply: Feb 15, 2014 1:57 PM by xulpix RSS
  • Robert McPherson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 9, 2011 9:18 AM (in response to Randall Glass)

    I have the same problem.  I found a couple of things out today.

     

    1. This problem does not seem to be happening on TVs that are 720p. I know this, because I have a 720p tv in my bedroom and all the shows and movies work great. Most of the time.  I have had issues with MadMen a couple of times, but only on one episode in the 4th season.

     

    2. It seems to be only the HD shows and movies that are affected, but not all of them.

     

    I tried Michael Allbitton's suggestions and I watched SGU successfully, however, when I tried to watch Walking Dead series, I failed miserably. 

     

    I also tried to watch How The Universe Works and Steven Hawking's Universe.  When I tried the latter two, at first, I had no sound.  I power cycled my tv and lo and behold, I had sound. I did try it on WD and Caprica and some HD movies as well and it was not successful.

     

    I have tried new HDMI cables and had my ATV replaced yesterday, to determine where the problem lies.  It's NETFLIX. Though I doubt they will ever admit, that it's their issue, I firmly believe this is the case.  THey need to at least address that it "could" be an issue and try to troubleshoot the problem, rather than just pawn it off on Apple and say there's no way it could be them.

     

    I hope they fix it soon or another company finds a solution.  I would gladly switch to a service that works, than deal with this for the next however many years to come.

     

    If I discover a solution, I will gladly post it here in the future.

  • Adam HH Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 2, 2012 5:52 PM (in response to Robert McPherson)

    It sounds like you've discovered the solution: Turn off the HD stream, or change the resolution of your viewing monitor down to 720p.

     

    That worked for me!  Since my monitor is 1080i only, I am watching the standard def stream (booo) but it's in sync.  I'd rather watch crappy quality video than melt my brain with out of sync audio!!

  • DSL_Steve Level 1 Level 1 (45 points)
    Currently Being Moderated
    Mar 16, 2012 12:49 PM (in response to Adam HH)

    I'm dredging up an old post because since updating my AppleTV2 to iOS 5, Netflix audio and video are constantly out of sync. The only way to make it temporarily stop is to pause the movie, go back to the Movie listing in Netflix and start playing it again.

  • rachierose22 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 11, 2012 1:50 PM (in response to Der Det)

    I've been having the same problem on my Nook Tablet - I know that this is an Apple forum, but the point of my post is that I just spent an hour on the phone with Netflix and they deny that there is any problem is on their end.  They blamed it on my connection speed, the device, the weather, you name it and it was everybody's fault but their own.  All of my devices are working off of a very strong broadband connection and the only problem I have with streaming video is their app.  B&N advised me that it's a Netflix issue since all other streaming sites/apps are working fine on my devices.  I've seen so many posts from people across many different devices having this same issue and still Netflix seems so unwilling to acknowledge that there is a problem. 

  • Lateralus11235 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 29, 2012 9:12 PM (in response to Der Det)

    Here is my deal.  I have an apple TV2, latest OS, connected to a 1080p TV via HDMI.  I have digital out connected to a Mac Pro, and I use a freeware program called LineIn to get the digital in to play through the line out on the Mac to a Dolby THX speaker system. 

     

    If I play TV show, move, 1080p, 720p or Netflix show, after some time (45 min to 1 hour) the sound gets out of sync.  If I go into the settings on the ATV, under audio and video, and switch the audio output to 16 bit and back to auto (I've tried leaving it on 16bit - doesn't matter), and go back to the show I've just paused, it is back in sync.

     

    While this "fix" works, it's a pain in the ***. 

     

    Does this help with narrowing down that the issue appears to be with the ATV (since I can fix it 100% of the time from there) and that an OS upgrade may be a possible solution?

  • ToddEagan Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 23, 2012 2:00 PM (in response to Der Det)

    I recently purchased a Macbook Air and Thunderbolt display and have this same problem but ONLY when I watch on the Thunderbolt display.  I have watched Netflix for years on iMac and iPad without problems.  And when I disconnect the Thunderbolt and view directly on the Macbook Air monitor, it is fine.

  • allenfromathens Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2012 9:22 AM (in response to Der Det)

    Go to Settings > Audio & Video > Dolby Digital = Off.

     

    I've been tormented by the lip sync problem particularly when watching 30 ROCK.  Some episodes are fine, some are not.  I tried the above fix and it worked.  Season 6, episode 4 plays badly out of sync for me with Dolby = auto or Dolby = on. With Dolby = Off, the show plays with audio synced.

     

    I still blame Netflix.  Some shows don't play well with Dolby Digital turned on and some shows do play well. Seems obvious that there is something different in the encoding of the files.

     

    BONUS FIX

    Also, turning Dolby off fixed a problem I was having using optical audio cable connection (TosLInk).  When using the optical audio input to my Visio sound bar, the sound for some shows (30 ROCK, MAD MEN) could not be heard.  The show would begin playing with an audible "click" and then the speaker goes silent while the video plays on the screen.  For other shows (DOCTOR WHO) this connection worked fine, video and audio played together. After turning Dolby Digital off, the digital audio input to Visio sound bar works fine.

     

    My setup: Apple TV 2 connected to Sanyo TV via HDMI cable.  Apple TV 2 connected to Vizio VSB200 via optical audio cable (TosLink).

  • vkahn Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 18, 2012 8:23 PM (in response to johnckendall)

    Netflix is almost always out of sync with some programs (Damages) and frequently with others that we stream from Comcast to our Apple computer using Safari.  Any one else having this problem?  Any suggestions?

  • juliasb Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 8, 2013 4:39 AM (in response to Der Det)

    I was having out of sink streaming with Netflix until I unchecked Autoplay in hardware and sound devices on my laptop. I hope this helps.

  • Husker23 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 15, 2013 8:29 AM (in response to Court Dimon)

    Although I do not have a "solution" I believe I can compile a lot of what has been talked about in this forum.  For years I have been trying to figure out the problem with steaming video (Netflix, Amazon, even iTunes) and lipsync.  I have found no real solutions despite buying all new cords, trying every conceivable combination of optical HDMI configurations, using various devices like PS3 and Apple TV and countless other things.  In literally years of working on this here is what I have learned:

     

    The problem for the most part is Dolby Digital 5.1 sound.  I would guess that nearly everyone complaining of this problem is running their audio through their receiver.  If it is going directly to your TV you are not using surround sound, so there is probably not a problem.  Although not an issue with all iTunes movies, I bet if you tried several movies you might find the same problem with some movies from Apple.  But the problem is not with the Apple TV because I have been fighting the same issues with my PS3.  I don’t know the technical reasons, but for some reason streaming HD video with 5.1 surround sound is hard to do and I am guessing the compression is where things get messed up.  Every TV episode or movie is going have a different amount of compression because the size of the audio and video information is different.  That is why the amount the audio is off varies from show to show. 

     

    I really enjoy the movie experience of a 1080p picture and surround sound and I am excited about the possibilities of having any movie streamed to my home at anytime.  However, it seems to me you can’t have you cake and eat it too, at least not yet.  Hopefully things will improve overtime although I have noticed no improvements in 3 years.  I wish companies like Netflix would invest more time and resources into this problem rather than working on SuperHD streams. I would take regular HD with good sound over SuperHD with no surround sound but that is just me.  Anyway, you will probably be most satisfied with the “fix” of turning off Dolby Digital when you find this a problem.    

  • Steve8778435342 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 25, 2013 11:05 AM (in response to allenfromathens)

    Turning off Dolby Digital worked for me.

  • Twirlycat Level 1 Level 1 (0 points)
    Currently Being Moderated
    Apr 26, 2013 1:05 PM (in response to Steve8778435342)

    For me the answer was to go wired and forget wifi. Since doing this I can use 1080 and Dolby and stay in sync all the time.

  • litterbuggy Level 1 Level 1 (5 points)
    Currently Being Moderated
    Apr 28, 2013 4:01 PM (in response to Steve8778435342)

    Just piping in that I've at least improved the audio delay playing music on a Yamaha soundbar.  I can just ignore out-of-sync audio when watching TV or movies, and it was perfectly fine if I streamed music with iTunes because it was all I heard, but was so out of sync with the computer speakers (and now a dock in the kitchen connected with an Airport Express) as to make music sound perfectly syncopated, so I only play music with iTunes through the Apple TV.  .

     

    At first I followed Yamaha's instructions and connected the Apple TV through an HDMI cable to the TV, and the TV with optical cable to the soundbar.  Turning off Dolby and any other sound effects on the TV decreased the delay just enough to ruin the syncopation, which proves that Dolby does create some delay (at least in my case).  Then I did the most obvious thing: I used the optical cable to connect the Apple TV directly to the soundbar.  Now the audio delay is a tantalizing fraction of a second that's audible with podcasts and anything with a rhythm, but will be close enough for watching TV and movies.

     

    Now I'm pretty much stuck.  Unless there's some way to further adjust the delay I guess I'm stuck with listening either through the soundbar or the kitchen speakers.

  • Steve8778435342 Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 1, 2013 9:48 AM (in response to litterbuggy)

    Have you tried swapping the inputs to the sound bar so it's being fed from the airport express?  If the problem is gone you can rule out sound processing in the sound bar, I expect however its to do with the Apple TV. You may have already read this above but turning off Dolby digital on the atv worked for me, I have a Yamaha amp and I pipe the sound via an optical cable.

  • litterbuggy Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 1, 2013 11:40 AM (in response to Steve8778435342)

    I probably wasn't clear about my setup.  I've got my ATV3 by the cable box, connected via wifi to my network and connected to the soundbar via optical audio.  The airport express is connected to the dock speakers in the kitchen.

     

    There's no audio delay with the airport express to the kitchen speaker.  Dolby is turned off both on the ATV and the TV, and like I said, I still have a noticeable lag.  I guess I could get another airport express just to bring audio directly to the soundbar, but I was trying to avoid spending anything more right now because I need to save for a solution to my need for a DVR that'll record encrypted cable channels, which is a whole 'nother thing.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.